aboutsummaryrefslogtreecommitdiffstats
path: root/news
diff options
context:
space:
mode:
authormezz <mezz@FreeBSD.org>2006-10-15 01:41:29 +0800
committermezz <mezz@FreeBSD.org>2006-10-15 01:41:29 +0800
commit76ebb7bf43bd79f44fc4a73ff9c97d9e98a999c3 (patch)
treee1ffe3dccdd98e5792d8eb7cb8bc9b08a12ba7db /news
parentc0e3493b2595c7789650246b7469cbac36baf399 (diff)
downloadfreebsd-ports-gnome-76ebb7bf43bd79f44fc4a73ff9c97d9e98a999c3.tar.gz
freebsd-ports-gnome-76ebb7bf43bd79f44fc4a73ff9c97d9e98a999c3.tar.zst
freebsd-ports-gnome-76ebb7bf43bd79f44fc4a73ff9c97d9e98a999c3.zip
Fix slow download and download corrupted in 0.116. Patch was took from CVS.
Bump the PORTREVISION. Bugzilla: http://bugzilla.gnome.org/show_bug.cgi?id=361941 Approved by: portmgr (marcus)
Diffstat (limited to 'news')
-rw-r--r--news/pan/Makefile1
-rw-r--r--news/pan/files/patch-pan_tasks_socket-impl-gio.cc16
2 files changed, 17 insertions, 0 deletions
diff --git a/news/pan/Makefile b/news/pan/Makefile
index 962fee2862bd..6d793e41d88e 100644
--- a/news/pan/Makefile
+++ b/news/pan/Makefile
@@ -8,6 +8,7 @@
PORTNAME= pan
PORTVERSION= 0.116
+PORTREVISION= 1
CATEGORIES= news gnome
MASTER_SITES= http://pan.rebelbase.com/download/releases/${PORTVERSION}/source/
DIST_SUBDIR= gnome2
diff --git a/news/pan/files/patch-pan_tasks_socket-impl-gio.cc b/news/pan/files/patch-pan_tasks_socket-impl-gio.cc
new file mode 100644
index 000000000000..4c7afcc21799
--- /dev/null
+++ b/news/pan/files/patch-pan_tasks_socket-impl-gio.cc
@@ -0,0 +1,16 @@
+===================================================================
+RCS file: /cvs/gnome/pan2/pan/tasks/socket-impl-gio.cc,v
+retrieving revision 1.2
+retrieving revision 1.3
+diff -u -r1.2 -r1.3
+--- pan/tasks/socket-impl-gio.cc.orig 2006/10/06 15:25:53 1.2
++++ pan/tasks/socket-impl-gio.cc 2006/10/13 15:29:34 1.3
+@@ -377,7 +377,7 @@
+ {
+ // see if we've got a partial line buffered up
+ if (_channel->read_buf && _channel->read_buf->len) {
+- _partial_line.assign (_channel->read_buf->str, _channel->read_buf->len);
++ _partial_line.append (_channel->read_buf->str, _channel->read_buf->len);
+ g_string_set_size (_channel->read_buf, 0);
+ }
+ // more to come