aboutsummaryrefslogtreecommitdiffstats
path: root/news
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2002-12-02 09:46:26 +0800
committermarcus <marcus@FreeBSD.org>2002-12-02 09:46:26 +0800
commit5ad0f4b9787017ddf6f6db87c6f1c68ae29c222c (patch)
tree8fff65858897566cf55bf4561bdb9c042ad6ea29 /news
parent01c354cd736678bf2a1b4dd6f4935a15200d0eca (diff)
downloadfreebsd-ports-gnome-5ad0f4b9787017ddf6f6db87c6f1c68ae29c222c.tar.gz
freebsd-ports-gnome-5ad0f4b9787017ddf6f6db87c6f1c68ae29c222c.tar.zst
freebsd-ports-gnome-5ad0f4b9787017ddf6f6db87c6f1c68ae29c222c.zip
Fix package building.
Reported by: bento
Diffstat (limited to 'news')
-rw-r--r--news/glitter/Makefile8
1 files changed, 3 insertions, 5 deletions
diff --git a/news/glitter/Makefile b/news/glitter/Makefile
index 6e3de6fe921d..a2a205eb3f3a 100644
--- a/news/glitter/Makefile
+++ b/news/glitter/Makefile
@@ -17,16 +17,14 @@ MAINTAINER= greg@gregnet.net
USE_X_PREFIX= yes
USE_GNOMENG= yes
-USE_GNOME= gnomelibs gtk12
+USE_GNOME= gnomeprefix gnomehack gnomelibs gtk12
GNU_CONFIGURE= yes
+USE_REINPLACE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib"
pre-patch:
- @${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
+ @${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
- @find ${WRKSRC} -name "Makefile.in" | xargs ${PERL} -pi -e \
- 's|\$\(datadir\)/gnome/|\$\(datadir\)/|g ; \
- s|\$\(datadir\)/locale|\$\(prefix\)/share/locale|g'
.include <bsd.port.mk>