aboutsummaryrefslogtreecommitdiffstats
path: root/news
diff options
context:
space:
mode:
authorriggs <riggs@FreeBSD.org>2014-09-07 15:23:56 +0800
committerriggs <riggs@FreeBSD.org>2014-09-07 15:23:56 +0800
commit93c592be2bcaa4a3517adf31ca953d782f3ca6f3 (patch)
tree83466a69d8ac6b63d32fd44e2b6b2412596a5308 /news
parent22d78b69eb75b55f57ae2c649ba67b570d44e7c2 (diff)
downloadfreebsd-ports-gnome-93c592be2bcaa4a3517adf31ca953d782f3ca6f3.tar.gz
freebsd-ports-gnome-93c592be2bcaa4a3517adf31ca953d782f3ca6f3.tar.zst
freebsd-ports-gnome-93c592be2bcaa4a3517adf31ca953d782f3ca6f3.zip
Resurrect news/diablo
- Stagify - Assign maintainership to Nikolai Lifanov <lifanov@mail.lifanov.com> - General cleanup of diablo port - Add LICENSE - Bump PORTREVISION PR: 193239 Submitted by: lifanov@mail.lifanov.com
Diffstat (limited to 'news')
-rw-r--r--news/Makefile1
-rw-r--r--news/diablo/Makefile61
-rw-r--r--news/diablo/distinfo2
-rw-r--r--news/diablo/files/diablo.sh-sample17
-rw-r--r--news/diablo/files/patch-XMakefile.inst44
-rw-r--r--news/diablo/files/patch-aa20
-rw-r--r--news/diablo/pkg-descr6
-rw-r--r--news/diablo/pkg-install24
-rw-r--r--news/diablo/pkg-message8
-rw-r--r--news/diablo/pkg-plist144
10 files changed, 327 insertions, 0 deletions
diff --git a/news/Makefile b/news/Makefile
index c42589374ca1..101725f47263 100644
--- a/news/Makefile
+++ b/news/Makefile
@@ -11,6 +11,7 @@
SUBDIR += cleanfeed
SUBDIR += cnews
SUBDIR += crashmail
+ SUBDIR += diablo
SUBDIR += fidogate
SUBDIR += fidogate-ds
SUBDIR += golded+
diff --git a/news/diablo/Makefile b/news/diablo/Makefile
new file mode 100644
index 000000000000..642a6ab327c3
--- /dev/null
+++ b/news/diablo/Makefile
@@ -0,0 +1,61 @@
+# Created by: James FitzGibbon <jfitz@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= diablo
+PORTVERSION= 5.1
+PORTREVISION= 1
+CATEGORIES= news
+MASTER_SITES= http://www.openusenet.org/diablo/download/
+DISTNAME= ${PORTNAME}-${PORTVERSION}-REL
+
+MAINTAINER= lifanov@mail.lifanov.com
+COMMENT= Comprehensive newsfeeding and newsreading software package
+
+LICENSE= BSD3CLAUSE
+
+BUILD_DEPENDS= xmake:${PORTSDIR}/devel/xmake
+
+PORTDOCS= COPYRIGHT INSTALL README.READER README.SERVER RELEASE_NOTES
+
+OPTIONS_DEFINE= DES DOCS
+DES_DESC= DES encryption support
+
+USES= tar:tgz
+
+.include <bsd.port.options.mk>
+
+post-patch:
+ ${CP} ${FILESDIR}/diablo.sh-sample ${WRKDIR}
+ ${REINPLACE_CMD} -E 's|%%PREFIX%%|${STAGEDIR}${PREFIX}|g ;\
+ s|-g -O.?|${CFLAGS}| ; s|g?cc|${CC}|' \
+ ${WRKSRC}/XMakefile.inc
+ ${REINPLACE_CMD} -E 's|%%PREFIX%%|${PREFIX}|g' \
+ ${WRKDIR}/diablo.sh-sample ${WRKSRC}/XMakefile.inst
+# Fix for GCC 4.2
+ ${REINPLACE_CMD} -e 's|VServerConfig\[\]|*VServerConfig|' \
+ ${WRKSRC}/dreaderd/main.c
+
+.if empty(PORT_OPTIONS:MDES)
+ ${REINPLACE_CMD} -e 's| -ldes||g' ${WRKSRC}/XMakefile.inc
+.endif
+
+do-build:
+ (cd ${WRKSRC} && xmake all)
+
+do-install:
+ ${MKDIR} ${STAGEDIR}${PREFIX}/news/dbin
+ ${MKDIR} ${STAGEDIR}${PREFIX}/news/dqueue
+ ${MKDIR} ${STAGEDIR}${PREFIX}/news/spool
+ ${MKDIR} ${STAGEDIR}${PREFIX}/news/spool/news
+ ${MKDIR} ${STAGEDIR}${PREFIX}/news/spool/cache
+ ${MKDIR} ${STAGEDIR}${PREFIX}/news/spool/group
+ ${MKDIR} ${STAGEDIR}${PREFIX}/news/spool/postq
+ (cd ${WRKSRC} && xmake install)
+ @${STRIP_CMD} ${STAGEDIR}${PREFIX}/news/dbin/*
+ ${INSTALL_SCRIPT} ${WRKDIR}/diablo.sh-sample ${STAGEDIR}${PREFIX}/etc/rc.d
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}
+.for file in ${PORTDOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${file} ${STAGEDIR}${DOCSDIR}
+.endfor
+
+.include <bsd.port.mk>
diff --git a/news/diablo/distinfo b/news/diablo/distinfo
new file mode 100644
index 000000000000..d22582a57b65
--- /dev/null
+++ b/news/diablo/distinfo
@@ -0,0 +1,2 @@
+SHA256 (diablo-5.1-REL.tgz) = db8155fcb306cc3f606809c420baa094742d415b9f52cb878022aecc4ee8b482
+SIZE (diablo-5.1-REL.tgz) = 694765
diff --git a/news/diablo/files/diablo.sh-sample b/news/diablo/files/diablo.sh-sample
new file mode 100644
index 000000000000..4d00b4dd3571
--- /dev/null
+++ b/news/diablo/files/diablo.sh-sample
@@ -0,0 +1,17 @@
+#!/bin/sh
+
+case $1 in
+start)
+ if [ -x %%PREFIX%%/news/rc.news ] ; then
+ %%PREFIX%%/news/rc.news && echo -n ' diablo'
+ fi
+ ;;
+stop)
+ ;;
+*)
+ echo "Usage: `basename $0` {start|stop}" >&2
+ exit 64
+ ;;
+esac
+
+exit 0
diff --git a/news/diablo/files/patch-XMakefile.inst b/news/diablo/files/patch-XMakefile.inst
new file mode 100644
index 000000000000..79a560e110c9
--- /dev/null
+++ b/news/diablo/files/patch-XMakefile.inst
@@ -0,0 +1,44 @@
+--- XMakefile.inst.orig 2002-06-07 23:14:13 UTC
++++ XMakefile.inst
+@@ -29,23 +29,13 @@
+
+ $(DDIRS) : $(DDIRS)
+ test -d %(left) || mkdir %(left)
+- chown news %(left)
+- chgrp news %(left)
+- chmod 755 %(left)
+
+ $(DMDIRS) : $(DMDIRS)
+ test -d %(left) || mkdir %(left)
+- chmod 755 %(left)
+- chown news %(left)
+- chgrp news %(left)
+- @echo "%(left): WARNING!!!! directory may require its own mount point"
+ @sleep 2
+
+ $(OTDIRS) : $(OTDIRS)
+ test -d %(left) || mkdir %(left)
+- chown news %(left)
+- chgrp news %(left)
+- chmod 755 %(left)
+
+ /*
+ * note: modes 444 so user is reminded to break the link
+@@ -54,15 +44,11 @@
+
+ $(DFILES) : $(IFILES)
+ cp %(right) %(left).new
+- chmod 444 %(left).new
+- chown news %(left).new
+- chgrp news %(left).new
+- if [ -x %(right) ]; then chmod 755 %(left).new; else chmod 444 %(left).new; fi
+ mv -f %(left).new %(left)
+
+ $(DTFILES) : $(TFILES)
+- if [ ! -f %(left) ]; then ln -s $(IDIR)/%(right) %(left); fi
++ if [ ! -f %(left) ]; then ln -s %%PREFIX%%/%(right) %(left); fi
+
+ $(DMAN) : $(IMAN)
+- $(INSTALL) -c -g news -o news -m 644 %(right) %(left)
++ $(INSTALL) -c %(right) %(left)
+
diff --git a/news/diablo/files/patch-aa b/news/diablo/files/patch-aa
new file mode 100644
index 000000000000..4ac2344dc701
--- /dev/null
+++ b/news/diablo/files/patch-aa
@@ -0,0 +1,20 @@
+--- XMakefile.inc.orig Tue Jun 20 10:31:09 2000
++++ XMakefile.inc Tue Jun 20 10:43:22 2000
+@@ -20,8 +20,8 @@
+ #endif
+
+ .set LFLAGS -L$(BD)obj -lfilter -ldiablo -lutil -lm
+-.set IDIR /news
+-.set MDIR /news/man
++.set IDIR %%PREFIX%%/news
++.set MDIR %%PREFIX%%/man
+ .set INSTALL install
+
+ #ifdef __FreeBSD__
+@@ -41,5 +41,5 @@
+ .set INSTALL /usr/ucb/install
+ #endif
+
+-.set DIST /news
++.set DIST %%PREFIX%%/news
+
diff --git a/news/diablo/pkg-descr b/news/diablo/pkg-descr
new file mode 100644
index 000000000000..867d6fc08ed1
--- /dev/null
+++ b/news/diablo/pkg-descr
@@ -0,0 +1,6 @@
+Diablo is a comprehensive newsfeeding and newsreading software package
+that was originally developed by Matthew Dillon and is now run as an open
+source project. Diablo is significantly faster and more robust than INN,
+and scales well to multi-server installations.
+
+WWW: http://www.openusenet.org/diablo/
diff --git a/news/diablo/pkg-install b/news/diablo/pkg-install
new file mode 100644
index 000000000000..eb06b347b27e
--- /dev/null
+++ b/news/diablo/pkg-install
@@ -0,0 +1,24 @@
+#!/bin/sh
+
+PKGNAME=$1
+
+case $2 in
+ PRE-INSTALL)
+ ;;
+ POST-INSTALL)
+ NEWSBASE=${PREFIX:-/usr/local}/news
+ install -d \
+ ${NEWSBASE}/dqueue \
+ ${NEWSBASE}/spool \
+ ${NEWSBASE}/spool/news \
+ ${NEWSBASE}/spool/cache \
+ ${NEWSBASE}/spool/group \
+ ${NEWSBASE}/spool/postq
+ chown -R news:news ${NEWSBASE}
+ ;;
+ *)
+ echo "Unexpected Argument $2!!!"
+ exit 1
+ ;;
+esac
+exit 0
diff --git a/news/diablo/pkg-message b/news/diablo/pkg-message
new file mode 100644
index 000000000000..16b1fb423e9d
--- /dev/null
+++ b/news/diablo/pkg-message
@@ -0,0 +1,8 @@
+
+Post-install notes for Diablo
+-----------------------------
+
+This port installs a very basic Diablo system. You will certainly
+want to change paths and partitions before you start using diablo in a
+production environment. Please refer to the documentation located at
+http://www.openusenet.org/diablo/ for further information.
diff --git a/news/diablo/pkg-plist b/news/diablo/pkg-plist
new file mode 100644
index 000000000000..3387db14fce2
--- /dev/null
+++ b/news/diablo/pkg-plist
@@ -0,0 +1,144 @@
+etc/rc.d/diablo.sh-sample
+man/man5/diablo-files.5.gz
+man/man5/diablo-kp.5.gz
+man/man8/dexpire.8.gz
+man/man8/dexpireover.8.gz
+man/man8/dfeedinfo.8.gz
+man/man8/dgrpctl.8.gz
+man/man8/dhisexpire.8.gz
+man/man8/diablo.8.gz
+man/man8/dicmd.8.gz
+man/man8/didump.8.gz
+man/man8/diloadfromspool.8.gz
+man/man8/dilookup.8.gz
+man/man8/dkp.8.gz
+man/man8/dnewslink.8.gz
+man/man8/doutq.8.gz
+man/man8/doverctl.8.gz
+man/man8/dpath.8.gz
+man/man8/drcmd.8.gz
+man/man8/dreadart.8.gz
+man/man8/dreaderd.8.gz
+man/man8/dreadover.8.gz
+man/man8/drequeue.8.gz
+man/man8/dspoolout.8.gz
+man/man8/dsyncgroups.8.gz
+@owner news
+@group news
+news/dactive.kp
+@mode 755
+news/dbin/.cvsignore
+news/dbin/.empty
+news/dbin/dcancel
+news/dbin/dclient
+news/dbin/dexpire
+news/dbin/dexpirecache
+news/dbin/dexpireover
+news/dbin/dexpirescoring
+news/dbin/dfeedinfo
+news/dbin/dfeedtest
+news/dbin/dgrpctl
+news/dbin/dhisbench
+news/dbin/dhisctl
+news/dbin/dhisexpire
+news/dbin/diablo
+news/dbin/dicmd
+news/dbin/diconvhist
+news/dbin/didate
+news/dbin/didump
+news/dbin/diload
+news/dbin/diloadfromspool
+news/dbin/dilookup
+news/dbin/dkp
+news/dbin/dlockhistory
+news/dbin/dnewslink
+news/dbin/doutq
+news/dbin/doverctl
+news/dbin/dpath
+news/dbin/dprimehostcache
+news/dbin/drcmd
+news/dbin/dreadart
+news/dbin/dreaderd
+news/dbin/dreadover
+news/dbin/drequeue
+news/dbin/dspaminfo
+news/dbin/dspoolout
+news/dbin/dstart
+news/dbin/dsyncgroups
+news/dbin/pgpverify
+news/dbin/plock
+news/dbin/showlocks
+@mode
+news/dcontrol.ctl
+news/dexpire.ctl
+news/diablo.config
+news/distrib.pats
+news/dnewsfeeds
+news/dreader.access
+news/dserver.hosts
+news/dspool.ctl
+news/moderators
+news/samples/adm/biweekly.atrim
+news/samples/adm/crontab.sample
+news/samples/adm/daily.atrim
+news/samples/adm/daily.reader
+news/samples/adm/hourly.expire
+news/samples/adm/old.biweekly.atrim.dexpire
+news/samples/adm/rc.news
+news/samples/adm/rot
+news/samples/adm/weekly.reader
+news/samples/dactive.kp
+news/samples/dcontrol.ctl
+news/samples/dexpire.ctl
+news/samples/diablo.config
+news/samples/diablo.hosts
+news/samples/distrib.pats
+news/samples/dnewsfeeds
+news/samples/dnntpspool.ctl
+news/samples/dreader.access
+news/samples/dserver.hosts
+news/samples/dspool.ctl
+news/samples/feeder+reader/README
+news/samples/feeder+reader/dactive.kp
+news/samples/feeder+reader/dcontrol.ctl
+news/samples/feeder+reader/dexpire.ctl
+news/samples/feeder+reader/diablo.config
+news/samples/feeder+reader/distrib.pats
+news/samples/feeder+reader/dnewsfeeds
+news/samples/feeder+reader/dreader.access
+news/samples/feeder+reader/dserver.hosts
+news/samples/feeder+reader/dspool.ctl
+news/samples/feeder+reader/moderators
+news/samples/feeder/diablo.config
+news/samples/feeder/dnewsfeeds
+news/samples/feeder/dspool.ctl
+news/samples/moderators
+news/samples/pgp-sample
+news/samples/reader/dactive.kp
+news/samples/reader/dcontrol.ctl
+news/samples/reader/dexpire.ctl
+news/samples/reader/diablo.config
+news/samples/reader/distrib.pats
+news/samples/reader/dreader.access
+news/samples/reader/dserver.hosts
+news/samples/reader/moderators
+@owner
+@group
+@dirrmtry news/dbin
+@dirrmtry news/dqueue
+@dirrmtry news/log
+@dirrmtry news/man/man5
+@dirrmtry news/man/man8
+@dirrmtry news/man
+@dirrmtry news/run
+@dirrmtry news/samples/adm
+@dirrmtry news/samples/feeder
+@dirrmtry news/samples/feeder+reader
+@dirrmtry news/samples/reader
+@dirrmtry news/samples
+@dirrmtry news/spool/cache
+@dirrmtry news/spool/group
+@dirrmtry news/spool/news
+@dirrmtry news/spool/postq
+@dirrmtry news/spool
+@dirrmtry news