aboutsummaryrefslogtreecommitdiffstats
path: root/news
diff options
context:
space:
mode:
authorarved <arved@FreeBSD.org>2004-01-19 21:03:56 +0800
committerarved <arved@FreeBSD.org>2004-01-19 21:03:56 +0800
commitc9482015ae8d7620eeb06e00d742c0ef0c46fb3d (patch)
tree5409e18d0a8f82116ee177e94cba03c33b331a50 /news
parent0718523c9b7202d4eade114f5413d1bb8b4a7132 (diff)
downloadfreebsd-ports-gnome-c9482015ae8d7620eeb06e00d742c0ef0c46fb3d.tar.gz
freebsd-ports-gnome-c9482015ae8d7620eeb06e00d742c0ef0c46fb3d.tar.zst
freebsd-ports-gnome-c9482015ae8d7620eeb06e00d742c0ef0c46fb3d.zip
Fix build on -STABLE
Reported by: Mike Harding
Diffstat (limited to 'news')
-rw-r--r--news/newscache/Makefile2
-rw-r--r--news/newscache/files/patch-NewsCache.cc12
2 files changed, 14 insertions, 0 deletions
diff --git a/news/newscache/Makefile b/news/newscache/Makefile
index e5c964e57617..ffef10ece0e3 100644
--- a/news/newscache/Makefile
+++ b/news/newscache/Makefile
@@ -20,6 +20,7 @@ LIB_DEPENDS= socket[+][+].1:${PORTSDIR}/net/libsocket++
USE_AUTOHEADER= yes
USE_AUTOMAKE_VER= 15
USE_GETOPT_LONG= yes
+USE_REINPLACE= yes
AUTOMAKE_ARGS= --add-missing
CONFIGURE_ENV= CPPFLAGS="${CFLAGS} -I${LOCALBASE}/include" \
LDFLAGS="${LDFLAGS} -L${LOCALBASE}/lib"
@@ -29,6 +30,7 @@ MAN8= newscache.8 newscacheclean.8 updatenews.8
INFO= NewsCache
post-patch:
+ ${REINPLACE_CMD} -e "s,-pedantic,," ${WRKSRC}/configure.in
cd ${WRKSRC}; ${ACLOCAL}
.include <bsd.port.mk>
diff --git a/news/newscache/files/patch-NewsCache.cc b/news/newscache/files/patch-NewsCache.cc
new file mode 100644
index 000000000000..71366e11c3a5
--- /dev/null
+++ b/news/newscache/files/patch-NewsCache.cc
@@ -0,0 +1,12 @@
+--- src/NewsCache.cc.orig Mon Jan 19 13:52:04 2004
++++ src/NewsCache.cc Mon Jan 19 13:52:55 2004
+@@ -24,7 +24,9 @@
+ */
+ #include "config.h"
+
++#ifndef __FreeBSD__
+ #include <crypt.h>
++#endif
+ #include <ctype.h>
+ #include <unistd.h>
+ #include <string.h>