aboutsummaryrefslogtreecommitdiffstats
path: root/news
diff options
context:
space:
mode:
authorshaun <shaun@FreeBSD.org>2006-08-24 04:57:28 +0800
committershaun <shaun@FreeBSD.org>2006-08-24 04:57:28 +0800
commiteb6eed746ebbcacc4d32c652caeac8a8caf6b835 (patch)
tree20ed2884b3f4e22c34b5b45236f877d9afb53594 /news
parenta2ade9e10bc28cb5d45d72e33f88de23fea84199 (diff)
downloadfreebsd-ports-gnome-eb6eed746ebbcacc4d32c652caeac8a8caf6b835.tar.gz
freebsd-ports-gnome-eb6eed746ebbcacc4d32c652caeac8a8caf6b835.tar.zst
freebsd-ports-gnome-eb6eed746ebbcacc4d32c652caeac8a8caf6b835.zip
Amend hostname check to succeed if /bin/hostname fails.
Another work-around for those pesky amd64 machines.
Diffstat (limited to 'news')
-rw-r--r--news/inn/Makefile9
1 files changed, 5 insertions, 4 deletions
diff --git a/news/inn/Makefile b/news/inn/Makefile
index 3310415e793d..9c8a9346cfee 100644
--- a/news/inn/Makefile
+++ b/news/inn/Makefile
@@ -48,12 +48,13 @@ CONFIGURE_ARGS+= --mandir=${PREFIX}/man \
# Attempt to avoid failures later on, when
# makedbz is executed: we need a valid hostname.
-.if exists(/bin/echo) && exists(/bin/hostname)
-HOSTNAME!= `/bin/echo /bin/hostname`
+.if exists(/bin/hostname)
+HOSTNAME!= /bin/hostname
+. if ${HOSTNAME} != ""
HOSTNAME:= ${HOSTNAME:C/[^\.]//g}
-
-. if ${HOSTNAME} == ""
+. if ${HOSTNAME} == ""
IGNORE= requires a fully-qualified hostname in order to build
+. endif
. endif
.endif