aboutsummaryrefslogtreecommitdiffstats
path: root/news
diff options
context:
space:
mode:
authormat <mat@FreeBSD.org>2018-09-10 21:11:23 +0800
committermat <mat@FreeBSD.org>2018-09-10 21:11:23 +0800
commitc6f82ca14271d2d9433ac4938a2188b9b6d092c1 (patch)
treeb47b12c2614f4db455f6a6733adce11a1cbba4b5 /news
parentb5f636d426adfd976e881a414696f678f16edcb8 (diff)
downloadfreebsd-ports-gnome-c6f82ca14271d2d9433ac4938a2188b9b6d092c1.tar.gz
freebsd-ports-gnome-c6f82ca14271d2d9433ac4938a2188b9b6d092c1.tar.zst
freebsd-ports-gnome-c6f82ca14271d2d9433ac4938a2188b9b6d092c1.zip
After an include, PLIST_SUB must be appended to, not overwritten.
If it is overwritten, many values will be clobbered, and pain will ensue. PR: 230864 Submitted by: mat exp-runs by: antoine
Diffstat (limited to 'news')
-rw-r--r--news/leafnode/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/news/leafnode/Makefile b/news/leafnode/Makefile
index 3bc785cace23..206a87819b27 100644
--- a/news/leafnode/Makefile
+++ b/news/leafnode/Makefile
@@ -31,7 +31,7 @@ LEAFNODE_SPOOLDIR?=/var/spool/news
LEAFNODE_SPOOLDIR?=${LOCALBASE}/var/spool/leafnode
.endif
LEAFNODE_SPOOLDIR?=/var/spool/leafnode
-PLIST_SUB= SPOOLDIR=${LEAFNODE_SPOOLDIR} REALPREFIX=${PREFIX}
+PLIST_SUB+= SPOOLDIR=${LEAFNODE_SPOOLDIR} REALPREFIX=${PREFIX}
CONFIGURE_ARGS= --sysconfdir=${PREFIX}/etc/leafnode \
--with-spooldir=${LEAFNODE_SPOOLDIR} --with-ipv6 \