aboutsummaryrefslogtreecommitdiffstats
path: root/news
diff options
context:
space:
mode:
authorsada <sada@FreeBSD.org>1999-07-06 02:59:58 +0800
committersada <sada@FreeBSD.org>1999-07-06 02:59:58 +0800
commitf88dbc0471f6cda14ba029db2ad2516d923fd918 (patch)
treefa34a0dfef4a04adcb0f65d59ab3d04d01e3ee41 /news
parentb657308f658cd9b38bd83a90d29cc86b1a9d4ba9 (diff)
downloadfreebsd-ports-gnome-f88dbc0471f6cda14ba029db2ad2516d923fd918.tar.gz
freebsd-ports-gnome-f88dbc0471f6cda14ba029db2ad2516d923fd918.tar.zst
freebsd-ports-gnome-f88dbc0471f6cda14ba029db2ad2516d923fd918.zip
Unified the writing of working directories.
The `test .. || ..' style could abort the make process, so changed to be using `if .. then' style.
Diffstat (limited to 'news')
-rw-r--r--news/leafnode+/Makefile9
-rw-r--r--news/leafnode+/files/INSTALL.in1
2 files changed, 6 insertions, 4 deletions
diff --git a/news/leafnode+/Makefile b/news/leafnode+/Makefile
index 047341fe2813..27a5d4a58c7c 100644
--- a/news/leafnode+/Makefile
+++ b/news/leafnode+/Makefile
@@ -3,7 +3,7 @@
# Date created: 19 November 1998
# Whom: Tom Hukins <tom@FreeBSD.org>
#
-# $Id: Makefile,v 1.6 1999/04/22 00:17:13 scrappy Exp $
+# $Id: Makefile,v 1.7 1999/07/04 19:40:32 sada Exp $
#
DISTNAME= leafnode+-2.6
@@ -47,10 +47,11 @@ do-install:
@${INSTALL_DATA} ${WRKSRC}/${file} ${PREFIX}/share/doc/leafnode+
.endfor
.endif
- @PKG_PREFIX=${PREFIX} ${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
post-install:
- @test -d /var/spool/news -a -d ${PREFIX}/lib/leafnode || \
- ${CAT} ${PKGDIR}/MESSAGE
+ @PKG_PREFIX=${PREFIX} ${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
+ @if test \( ! -d ${LEAFSPOOLDIR} \) -o \( ! -d ${LEAFLIBDIR} \) ; then \
+ ${CAT} ${PKGDIR}/MESSAGE; \
+ fi
.include <bsd.port.mk>
diff --git a/news/leafnode+/files/INSTALL.in b/news/leafnode+/files/INSTALL.in
index b8c1ccf4296f..c71fb6930b6f 100644
--- a/news/leafnode+/files/INSTALL.in
+++ b/news/leafnode+/files/INSTALL.in
@@ -1,4 +1,5 @@
#!/bin/sh
+# $Id$
LIBDIR=@LIBDIR@
SPOOLDIR=@SPOOLDIR@
if [ x$2 = xPOST-INSTALL -a x$LEAFNODE_SETUP_WRKDIRS != x ]; then