aboutsummaryrefslogtreecommitdiffstats
path: root/palm/coldsync
diff options
context:
space:
mode:
authormi <mi@FreeBSD.org>2002-12-28 15:04:40 +0800
committermi <mi@FreeBSD.org>2002-12-28 15:04:40 +0800
commitc297d4fab517660619140b3ebfb4cf93c82c1f04 (patch)
tree4cf51cc3eb4edfea0a21dd2a52547d4e09c9400c /palm/coldsync
parentc373825725852d7f86ced0b13bdea181d978dfd5 (diff)
downloadfreebsd-ports-gnome-c297d4fab517660619140b3ebfb4cf93c82c1f04.tar.gz
freebsd-ports-gnome-c297d4fab517660619140b3ebfb4cf93c82c1f04.tar.zst
freebsd-ports-gnome-c297d4fab517660619140b3ebfb4cf93c82c1f04.zip
Be sure to install the libraries together with the headers and the
manual pages. Build the shared libraries next to the static ones. Not bumping the PORTREVISION, since this is port was just upgraded. Approved by: knu (again!), maintainer (blanket)
Diffstat (limited to 'palm/coldsync')
-rw-r--r--palm/coldsync/Makefile3
-rw-r--r--palm/coldsync/files/patch-shlib29
-rw-r--r--palm/coldsync/pkg-plist6
3 files changed, 38 insertions, 0 deletions
diff --git a/palm/coldsync/Makefile b/palm/coldsync/Makefile
index 07b73f4d1737..8f49b1893951 100644
--- a/palm/coldsync/Makefile
+++ b/palm/coldsync/Makefile
@@ -13,9 +13,12 @@ MASTER_SITES= http://www.coldsync.org/download/
MAINTAINER= arensb+freebsd-ports@ooblick.com
LIB_DEPENDS= intl.4:${PORTSDIR}/devel/gettext
+
USE_REINPLACE= yes
REINPLACE_ARGS= -i "" -E
+INSTALLS_SHLIB= yes
+
GNU_CONFIGURE= yes
MAN3= libpconn.3 DlpAddSyncLogEntry.3 DlpCallApplication.3 \
diff --git a/palm/coldsync/files/patch-shlib b/palm/coldsync/files/patch-shlib
new file mode 100644
index 000000000000..b6d1c0564f5c
--- /dev/null
+++ b/palm/coldsync/files/patch-shlib
@@ -0,0 +1,29 @@
+--- libpconn/Makefile Mon Nov 19 12:07:15 2001
++++ libpconn/Makefile Fri Dec 27 16:40:20 2002
+@@ -43,3 +43,7 @@
+
+-all:: ${LIBRARY}
++all:: ${LIBRARY} ${SHLIB}
++
++install:: ${LIBRARY} ${SHLIB}
++ ${INSTALL_DATA} ${LIBRARY} ${SHLIBVER} ${PREFIX}/lib
++ ln -sf ${SHLIBVER} ${PREFIX}/lib/${SHLIB}
+
+--- libpdb/Makefile Sun Nov 11 23:31:25 2001
++++ libpdb/Makefile Fri Dec 27 16:41:06 2002
+@@ -27,3 +27,7 @@
+
+-all:: ${LIBRARY}
++all:: ${LIBRARY} ${SHLIB}
++
++install:: ${LIBRARY} ${SHLIB}
++ ${INSTALL_DATA} ${LIBRARY} ${SHLIBVER} ${PREFIX}/lib
++ ln -sf ${SHLIBVER} ${PREFIX}/lib/${SHLIB}
+
+--- Make.rules.in Mon Nov 19 12:05:33 2001
++++ Make.rules.in Fri Dec 27 16:58:41 2002
+@@ -142,3 +142,3 @@
+ SHLIB = lib${LIBNAME}.so
+-SHLIBVER = lib${LIBNAME}.so.${SHLIB_MAJOR}.${SHLIB_MINOR}
++SHLIBVER = lib${LIBNAME}.so.${SHLIB_MAJOR}
+
diff --git a/palm/coldsync/pkg-plist b/palm/coldsync/pkg-plist
index ff9e4e88845b..4dd6f4807e74 100644
--- a/palm/coldsync/pkg-plist
+++ b/palm/coldsync/pkg-plist
@@ -5,6 +5,12 @@ info/conduits.info
info/conduits.info-1
info/conduits.info-2
@exec install-info %D/info/conduits.info %D/info/dir
+lib/libpconn.a
+lib/libpconn.so
+lib/libpconn.so.0
+lib/libpdb.a
+lib/libpdb.so
+lib/libpdb.so.0
share/locale/cs/LC_MESSAGES/coldsync.mo
share/locale/de/LC_MESSAGES/coldsync.mo
share/locale/fr/LC_MESSAGES/coldsync.mo