aboutsummaryrefslogtreecommitdiffstats
path: root/palm/gnome-pilot-conduits/Makefile
diff options
context:
space:
mode:
authorade <ade@FreeBSD.org>2000-03-22 01:59:52 +0800
committerade <ade@FreeBSD.org>2000-03-22 01:59:52 +0800
commit27ae9dd880efe654ff32860f0e4947b15593a229 (patch)
treec4ccd31f80ac17e44e1f9f484e6b542aad126c48 /palm/gnome-pilot-conduits/Makefile
parentd62eb6efcf637e6f827a2709a80bba882ce39977 (diff)
downloadfreebsd-ports-gnome-27ae9dd880efe654ff32860f0e4947b15593a229.tar.gz
freebsd-ports-gnome-27ae9dd880efe654ff32860f0e4947b15593a229.tar.zst
freebsd-ports-gnome-27ae9dd880efe654ff32860f0e4947b15593a229.zip
Add gnomepilot-conduits which will provide additional
conduits for the base gnomepilot port.
Diffstat (limited to 'palm/gnome-pilot-conduits/Makefile')
-rw-r--r--palm/gnome-pilot-conduits/Makefile32
1 files changed, 32 insertions, 0 deletions
diff --git a/palm/gnome-pilot-conduits/Makefile b/palm/gnome-pilot-conduits/Makefile
new file mode 100644
index 000000000000..2615364c2030
--- /dev/null
+++ b/palm/gnome-pilot-conduits/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: gnomepilot-conduits
+# Version required: 0.1
+# Date created: 16th March 2000
+# Whom: Ade Lovett <ade@FreeBSD.org>
+#
+# $FreeBSD$
+
+DISTNAME= gnome-pilot-conduits-0.1
+PKGNAME= gnomepilot-conduits-0.1
+CATEGORIES= palm comms gnome
+MASTER_SITES= http://www.gnome.org/gnome-pilot/download/
+
+MAINTAINER= ade@FreeBSD.org
+
+BUILD_DEPENDS= gnome-pilot-config:${PORTSDIR}/palm/gnomepilot
+LIB_DEPENDS= pisock.3:${PORTSDIR}/palm/pilot-link \
+ capplet.1:${PORTSDIR}/sysutils/gnomecontrolcenter
+
+GTK_CONFIG?= ${X11BASE}/bin/gtk12-config
+GLIB_CONFIG?= ${LOCALBASE}/bin/glib12-config
+
+USE_GMAKE= yes
+USE_X_PREFIX= yes
+USE_LIBTOOL= yes
+LIBTOOLFILES= configure mal-conduit/configure
+CONFIGURE_ARGS= --localstatedir=${PREFIX}/share/gnome \
+ --datadir=${PREFIX}/share/gnome
+CONFIGURE_ENV= GTK_CONFIG="${GTK_CONFIG}" GLIB_CONFIG="${GLIB_CONFIG}" \
+ CPPFLAGS="-I${LOCALBASE}/include -I${LOCALBASE}/pilot/include" \
+ LIBS="-L${LOCALBASE}/lib -L${LOCALBASE}/pilot/lib"
+
+.include <bsd.port.mk>