aboutsummaryrefslogtreecommitdiffstats
path: root/palm/gnome-pilot-conduits
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2003-04-19 13:07:48 +0800
committermarcus <marcus@FreeBSD.org>2003-04-19 13:07:48 +0800
commite9cf8f8d748a76a30256e03c10d1e2801de30362 (patch)
tree781621e68890456902a359f117b4d92089da6fa3 /palm/gnome-pilot-conduits
parent9adaba7033a5a8af42f0e68f0cefa6bdadc34b11 (diff)
downloadfreebsd-ports-gnome-e9cf8f8d748a76a30256e03c10d1e2801de30362.tar.gz
freebsd-ports-gnome-e9cf8f8d748a76a30256e03c10d1e2801de30362.tar.zst
freebsd-ports-gnome-e9cf8f8d748a76a30256e03c10d1e2801de30362.zip
s|<malloc.h>|<stdlib.h>|
Reported by: Tom Parquette <tparquet@twcny.rr.com>
Diffstat (limited to 'palm/gnome-pilot-conduits')
-rw-r--r--palm/gnome-pilot-conduits/Makefile3
1 files changed, 3 insertions, 0 deletions
diff --git a/palm/gnome-pilot-conduits/Makefile b/palm/gnome-pilot-conduits/Makefile
index 423be699ef3a..c75e59449c48 100644
--- a/palm/gnome-pilot-conduits/Makefile
+++ b/palm/gnome-pilot-conduits/Makefile
@@ -24,6 +24,7 @@ USE_X_PREFIX= yes
USE_BISON= yes
USE_GNOME= gnomeprefix gnomehack libgnome
USE_LIBTOOL= yes
+USE_REINPLACE= yes
CONFIGURE_ARGS= --with-pisock=${LOCALBASE}
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib"
@@ -31,5 +32,7 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
post-patch:
@${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e 's|<malloc.h>|<stdlib.h>|' \
+ ${WRKSRC}/mal-conduit/mal/client/unix/MAL31DBConfig.c
.include <bsd.port.mk>