aboutsummaryrefslogtreecommitdiffstats
path: root/palm/gnomepilot2/Makefile
diff options
context:
space:
mode:
authornakai <nakai@FreeBSD.org>1999-12-28 10:26:40 +0800
committernakai <nakai@FreeBSD.org>1999-12-28 10:26:40 +0800
commite3a2c988885dbe80c4f36679ea19b0adbf324b21 (patch)
tree24e6971b9005649384b65dba4667db5e5037a58c /palm/gnomepilot2/Makefile
parent9dcf98bc0cc2c5d34a93d77bf55a31f1a880b698 (diff)
downloadfreebsd-ports-gnome-e3a2c988885dbe80c4f36679ea19b0adbf324b21.tar.gz
freebsd-ports-gnome-e3a2c988885dbe80c4f36679ea19b0adbf324b21.tar.zst
freebsd-ports-gnome-e3a2c988885dbe80c4f36679ea19b0adbf324b21.zip
New ports GNOME communication tool for palm pilot.
PR: ports/15727 Submitted by: Ade Lovett <ade@lovett.com>
Diffstat (limited to 'palm/gnomepilot2/Makefile')
-rw-r--r--palm/gnomepilot2/Makefile30
1 files changed, 30 insertions, 0 deletions
diff --git a/palm/gnomepilot2/Makefile b/palm/gnomepilot2/Makefile
new file mode 100644
index 000000000000..cf8823de59a3
--- /dev/null
+++ b/palm/gnomepilot2/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: gnomepilot
+# Version required: 0.1.46
+# Date created: 28th October 1999
+# Whom: Ade Lovett <ade@lovett.com>
+#
+# $FreeBSD$
+
+DISTNAME= gnome-pilot-0.1.46
+PKGNAME= gnomepilot-0.1.46
+CATEGORIES= palm comms gnome
+MASTER_SITES= http://www.gnome.org/gnome-pilot/download/
+
+MAINTAINER= ade@lovett.com
+
+LIB_DEPENDS= pisock.3:${PORTSDIR}/palm/pilot-link \
+ capplet.1:${PORTSDIR}/sysutils/gnomecontrolcenter
+
+GTK_CONFIG?= ${X11BASE}/bin/gtk12-config
+GLIB_CONFIG?= ${LOCALBASE}/bin/glib12-config
+
+USE_GMAKE= yes
+USE_X_PREFIX= yes
+USE_LIBTOOL= yes
+CONFIGURE_ARGS= --localstatedir=${PREFIX}/share/gnome \
+ --datadir=${PREFIX}/share/gnome \
+ --with-pisock=${LOCALBASE}/pilot
+CONFIGURE_ENV= GTK_CONFIG="${GTK_CONFIG}" GLIB_CONFIG="${GLIB_CONFIG}" \
+ CPPFLAGS="-I${LOCALBASE}/include" LIBS="-L${LOCALBASE}/lib"
+
+.include <bsd.port.mk>