aboutsummaryrefslogtreecommitdiffstats
path: root/palm/jfconv
diff options
context:
space:
mode:
authorknu <knu@FreeBSD.org>2000-05-17 05:24:55 +0800
committerknu <knu@FreeBSD.org>2000-05-17 05:24:55 +0800
commit4a894c84702b400a9f57f1a4c68293cbdaa62533 (patch)
tree73aa95bcdef0b785d537663a20bde6470fa30d69 /palm/jfconv
parent223ae5c69dcbe886802ecc8d9b3f75e9dca897e2 (diff)
downloadfreebsd-ports-gnome-4a894c84702b400a9f57f1a4c68293cbdaa62533.tar.gz
freebsd-ports-gnome-4a894c84702b400a9f57f1a4c68293cbdaa62533.tar.zst
freebsd-ports-gnome-4a894c84702b400a9f57f1a4c68293cbdaa62533.zip
Get some variables correctly initialized.
*sighs over the original code* Submitted by: Udo Schweigert <ust@cert.siemens.de>
Diffstat (limited to 'palm/jfconv')
-rw-r--r--palm/jfconv/Makefile2
-rw-r--r--palm/jfconv/files/patch-aa38
2 files changed, 39 insertions, 1 deletions
diff --git a/palm/jfconv/Makefile b/palm/jfconv/Makefile
index 7845493e889c..1808aed4627e 100644
--- a/palm/jfconv/Makefile
+++ b/palm/jfconv/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= jconv
-PORTVERSION= 2000.05.14
+PORTVERSION= 2000.05.17
CATEGORIES= palm databases
MASTER_SITES= http://www.land-j.com/files/ \
http://people.FreeBSD.org/~knu/ports/distfiles/
diff --git a/palm/jfconv/files/patch-aa b/palm/jfconv/files/patch-aa
index cbf52e18eb34..d849e2516e93 100644
--- a/palm/jfconv/files/patch-aa
+++ b/palm/jfconv/files/patch-aa
@@ -18,3 +18,41 @@
break;
case 't': strncpy(title, optarg, 32);
title[31] = 0;
+@@ -176,7 +176,7 @@
+ FILE* input;
+ FILE* output;
+ FILE* info;
+- tHeader header;
++ tHeader header = { 0 };
+ WORD oddity = 0x008C;
+ int numNonDeletedRecs;
+ JFileAppInfoType appInfo;
+@@ -185,7 +185,7 @@
+ int curDumpLoc;
+ char* tempPopupPtr;
+ int usesInfoFile;
+- int fldLens[MAX_FIELDS];
++ int fldLens[MAX_FIELDS] = { 0 };
+ unsigned char holdChr[2];
+ char endMsg[2048];
+ char recNumStr[10];
+@@ -437,7 +437,7 @@
+ int i,j;
+ char dbName[200];
+ int usesInfoFile;
+- tHeader header;
++ tHeader header = { 0 };
+ char inputString[MAX_RECORD_LENGTH];
+ int inputStringLoc, inputStringLen;
+ JFileAppInfoType appInfo;
+@@ -1165,10 +1165,6 @@
+ sprintf(recNumStr, "%d", currentRecord+1);
+ sprintf(endMsg, "Conversion of %s records in %s to %s was successful!",
+ recNumStr, m_CSVPath, m_PDBPath);
+-
+- if(!m_IsCommandLine)
+- MessageBox( endMsg, NULL, MB_OK );
+-
+ }
+
+ int TypeIsString(int t)