aboutsummaryrefslogtreecommitdiffstats
path: root/palm/kpilot/Makefile
diff options
context:
space:
mode:
authorse <se@FreeBSD.org>1998-03-07 23:31:55 +0800
committerse <se@FreeBSD.org>1998-03-07 23:31:55 +0800
commit577ee30b7a8af0185267101f369db360d27c45c3 (patch)
tree3be9fb94516a84adf11fd7089a6b2add670ffe33 /palm/kpilot/Makefile
parent9b67566bde6912af964257eabf7c710c96ed618c (diff)
downloadfreebsd-ports-gnome-577ee30b7a8af0185267101f369db360d27c45c3.tar.gz
freebsd-ports-gnome-577ee30b7a8af0185267101f369db360d27c45c3.tar.zst
freebsd-ports-gnome-577ee30b7a8af0185267101f369db360d27c45c3.zip
Port of KPilot, the KDE style frontend to your 3Com PalmPilot.
This port contains a recent version of libtool/ltmain.sh in "files", since I spent to many hours trying to make the "ltconfig" that comes with the kpilot sources DTRT under FreeBSD ... This port compiles cleanly, but has not been actually tested with a PalmPilot. If you want me to test it send one :)
Diffstat (limited to 'palm/kpilot/Makefile')
-rw-r--r--palm/kpilot/Makefile37
1 files changed, 37 insertions, 0 deletions
diff --git a/palm/kpilot/Makefile b/palm/kpilot/Makefile
new file mode 100644
index 000000000000..3f48a36bbeaa
--- /dev/null
+++ b/palm/kpilot/Makefile
@@ -0,0 +1,37 @@
+# New ports collection makefile for: kpilot
+# Version required: 2.0
+# Date created: 09 April 1998
+# Whom: Stefan Eßer <se@freebsd.org>
+#
+# $Id:$
+#
+
+DISTNAME= kpilot-2.0
+CATEGORIES= x11 kde
+MASTER_SITES= http://www.slac.com/pilone/kpilot_home/download/
+
+MAINTAINER= se@freebsd.org
+
+BUILD_DEPENDS= moc:${PORTSDIR}/x11/qt
+LIB_DEPENDS= qt\\.1\\.3[1-9]:${PORTSDIR}/x11/qt \
+ gif\\.[23]\\.:${PORTSDIR}/graphics/giflib \
+ jpeg\\.[67]\\.:${PORTSDIR}/graphics/jpeg \
+ kdecore\\.0\\.9[0-9]:${PORTSDIR}/x11/kdelibs \
+ kdeui\\.0\\.9[1-9]:${PORTSDIR}/x11/kdelibs \
+ jscript\\.0\\.9[0-9]:${PORTSDIR}/x11/kdelibs \
+ khtmlw\\.0\\.9[1-9]:${PORTSDIR}/x11/kdelibs \
+ kfm\\.0\\.9[0-9]:${PORTSDIR}/x11/kdelibs \
+ mediatool\\.0\\.[6-9]:${PORTSDIR}/x11/kdelibs
+
+HAS_CONFIGURE= yes
+CONFIGURE_ARGS= "--prefix=$(PREFIX)" \
+ "--with-extra-includes=$(PREFIX)/include/giflib"
+USE_GMAKE= yes
+
+CONFIGURE_ENV= CXXFLAGS="$(CFLAGS)" \
+ INSTALL_SCRIPT="install -c -m 555"
+
+pre-configure:
+ ${CP} ${FILESDIR}/libtool ${FILESDIR}/ltmain.sh $(WRKSRC)/kpilot/libpilot
+
+.include <bsd.port.mk>