aboutsummaryrefslogtreecommitdiffstats
path: root/palm/palmpower/files
diff options
context:
space:
mode:
authorjeh <jeh@FreeBSD.org>2000-10-12 20:19:15 +0800
committerjeh <jeh@FreeBSD.org>2000-10-12 20:19:15 +0800
commit788027be10b9fbb443535f91863e8763554211d9 (patch)
treecce7f52f27fc70d5c379d9207bc0bde122643475 /palm/palmpower/files
parentdcc4945ec9a606e5773afa77ce3b754d7a92167e (diff)
downloadfreebsd-ports-gnome-788027be10b9fbb443535f91863e8763554211d9.tar.gz
freebsd-ports-gnome-788027be10b9fbb443535f91863e8763554211d9.tar.zst
freebsd-ports-gnome-788027be10b9fbb443535f91863e8763554211d9.zip
Initial import of palmpower 1.0.1
Disassembler and other tools for PalmOS binaries PR: 20837 Submitted by: Roman Shterenzon <roman@xpert.com>
Diffstat (limited to 'palm/palmpower/files')
-rw-r--r--palm/palmpower/files/patch-aa11
-rw-r--r--palm/palmpower/files/patch-ab11
-rw-r--r--palm/palmpower/files/patch-ac11
-rw-r--r--palm/palmpower/files/patch-ad11
4 files changed, 44 insertions, 0 deletions
diff --git a/palm/palmpower/files/patch-aa b/palm/palmpower/files/patch-aa
new file mode 100644
index 000000000000..6385d1a71dcb
--- /dev/null
+++ b/palm/palmpower/files/patch-aa
@@ -0,0 +1,11 @@
+--- src/pila/main.c.orig Tue Aug 22 13:45:39 2000
++++ src/pila/main.c Tue Aug 22 13:47:16 2000
+@@ -26,7 +26,7 @@
+ // for htonl and ntohl
+ #ifndef unix
+ #include <winsock.h>
+-#else
++#elsif defined(__linux__)
+ #include <asm/byteorder.h>
+ #endif
+
diff --git a/palm/palmpower/files/patch-ab b/palm/palmpower/files/patch-ab
new file mode 100644
index 000000000000..36291593365b
--- /dev/null
+++ b/palm/palmpower/files/patch-ab
@@ -0,0 +1,11 @@
+--- src/pila/object.c.orig Tue Aug 22 13:46:44 2000
++++ src/pila/object.c Tue Aug 22 13:47:04 2000
+@@ -10,7 +10,7 @@
+ // for htonl and ntohl
+ #ifndef unix
+ #include <winsock.h>
+-#else
++#elsif defined(__linux__)
+ #include <asm/byteorder.h>
+ #endif
+
diff --git a/palm/palmpower/files/patch-ac b/palm/palmpower/files/patch-ac
new file mode 100644
index 000000000000..73bc30962f98
--- /dev/null
+++ b/palm/palmpower/files/patch-ac
@@ -0,0 +1,11 @@
+--- src/pila/prc.c.orig Tue Aug 22 13:47:27 2000
++++ src/pila/prc.c Tue Aug 22 13:47:43 2000
+@@ -22,7 +22,7 @@
+ #ifndef unix
+ //#include <windows.h>
+ #include <winsock.h>
+-#else
++#elsif defined(__linux__)
+ // for htonl and ntohl
+ #include <asm/byteorder.h>
+ #endif
diff --git a/palm/palmpower/files/patch-ad b/palm/palmpower/files/patch-ad
new file mode 100644
index 000000000000..08fd7fc1ec4b
--- /dev/null
+++ b/palm/palmpower/files/patch-ad
@@ -0,0 +1,11 @@
+--- src/pilotdis/Makefile.in.orig Tue Aug 22 13:53:22 2000
++++ src/pilotdis/Makefile.in Tue Aug 22 13:54:05 2000
+@@ -72,7 +72,7 @@
+ DEFS = @DEFS@ -I. -I$(srcdir)
+ CPPFLAGS = @CPPFLAGS@
+ LDFLAGS = @LDFLAGS@
+-LIBS = @LIBS@
++LIBS = @LIBS@ -lm
+ pilotdis_OBJECTS = afline.o dis.o fgen.o inst1.o inst2.o main.o pgen.o \
+ utils.o
+ pilotdis_LDADD = $(LDADD)