aboutsummaryrefslogtreecommitdiffstats
path: root/palm/py-synce-librapi2/Makefile
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2008-09-08 00:02:56 +0800
committermiwi <miwi@FreeBSD.org>2008-09-08 00:02:56 +0800
commit17005039b3c1a8e95804b248cc32b02500d17c5d (patch)
tree3e07aecffa4e454dbae18ceafe5730a023c16fe1 /palm/py-synce-librapi2/Makefile
parent817422386b517a8e7130961f45b3890bfdbedffe (diff)
downloadfreebsd-ports-gnome-17005039b3c1a8e95804b248cc32b02500d17c5d.tar.gz
freebsd-ports-gnome-17005039b3c1a8e95804b248cc32b02500d17c5d.tar.zst
freebsd-ports-gnome-17005039b3c1a8e95804b248cc32b02500d17c5d.zip
SynCE is a project for connecting to devices running Windows CE or Pocket PC.
Librapi is an open-source implementation that works like RAPI.DLL. The library makes it possible to make remote calls on a Windows CE device, including installing applications and transferring files. WWW: http://synce.sourceforge.net/ PR: ports/126134 Submitted by: Ilya Bakulin <webmaster at kibab.com>
Diffstat (limited to 'palm/py-synce-librapi2/Makefile')
-rw-r--r--palm/py-synce-librapi2/Makefile27
1 files changed, 27 insertions, 0 deletions
diff --git a/palm/py-synce-librapi2/Makefile b/palm/py-synce-librapi2/Makefile
new file mode 100644
index 000000000000..964b47ae0459
--- /dev/null
+++ b/palm/py-synce-librapi2/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: py-synce-librapi2
+# Date created: 19 June 2008
+# Whom: Ilya Bakulin <webmaster@kibab.com>
+#
+# $FreeBSD$
+
+CATEGORIES= palm python
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}synce-
+
+MAINTAINER= webmaster@kibab.com
+COMMENT= Python bibdigs for libRAPI2
+
+LIB_DEPENDS= rapi.2:${PORTSDIR}/palm/synce-librapi2
+BUILD_DEPENDS= pyrexc:${PORTSDIR}/devel/pyrex
+
+MASTERDIR= ${.CURDIR}/../synce-librapi2
+
+USE_PYTHON= yes
+
+PLIST= ${.CURDIR}/pkg-plist
+
+RAPI_SLAVE= pythonb
+
+do-install:
+ @(cd ${WRKSRC}/python && ${MAKE} install)
+
+.include "${MASTERDIR}/Makefile"