aboutsummaryrefslogtreecommitdiffstats
path: root/palm/synce-librapi2/Makefile
diff options
context:
space:
mode:
authorarved <arved@FreeBSD.org>2003-08-01 22:51:43 +0800
committerarved <arved@FreeBSD.org>2003-08-01 22:51:43 +0800
commit8a81d271537b1d7c188a759b9ebdb872c311ef11 (patch)
treebf1cc5aa934183a9229ca87a626a20e42e3b18d7 /palm/synce-librapi2/Makefile
parent3e3bab36d787e64ff8d65b781a9c5b5be9d6022d (diff)
downloadfreebsd-ports-gnome-8a81d271537b1d7c188a759b9ebdb872c311ef11.tar.gz
freebsd-ports-gnome-8a81d271537b1d7c188a759b9ebdb872c311ef11.tar.zst
freebsd-ports-gnome-8a81d271537b1d7c188a759b9ebdb872c311ef11.zip
Add Librapi2, an open source implementation of Microsoft's Remote
Application Programming Interface, used for communicating with Windows CE devices. PR: 53310 Submitted by: Sam Lawrance <boris@brooknet.com.au>
Diffstat (limited to 'palm/synce-librapi2/Makefile')
-rw-r--r--palm/synce-librapi2/Makefile27
1 files changed, 27 insertions, 0 deletions
diff --git a/palm/synce-librapi2/Makefile b/palm/synce-librapi2/Makefile
new file mode 100644
index 000000000000..5b64577f0002
--- /dev/null
+++ b/palm/synce-librapi2/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: synce-librapi2
+# Date created: 14 June 2003
+# Whom: Sam Lawrance <boris@brooknet.com.au>
+#
+# $FreeBSD$
+
+PORTNAME= synce-librapi2
+PORTVERSION= 0.7
+CATEGORIES= palm
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= synce
+
+MAINTAINER= boris@brooknet.com.au
+COMMENT= Utilities/libraries to make RAPI calls on WinCE devices
+
+LIB_DEPENDS+= synce.0:${PORTSDIR}/palm/synce-libsynce
+
+MAN1= pcp.1 pls.1 pmkdir.1 pmv.1 prm.1 prmdir.1 prun.1 pstatus.1 synce-install-cab.1
+
+GNU_CONFIGURE= yes
+USE_LIBTOOL= yes
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_ARGS+= --program-transform-name=""
+CONFIGURE_ARGS+= --with-libsynce=${PREFIX}
+
+INSTALLS_SHLIB= yes
+.include <bsd.port.mk>