aboutsummaryrefslogtreecommitdiffstats
path: root/palm
diff options
context:
space:
mode:
authoreadler <eadler@FreeBSD.org>2013-03-19 21:04:30 +0800
committereadler <eadler@FreeBSD.org>2013-03-19 21:04:30 +0800
commitcdabc54ad469c80d08327c0d32dfa55c640cff2a (patch)
treeeba3c1f7e94497327507881e3b0eb623013d377e /palm
parent3e5b766396a89930130c8530a30308b48d239d4b (diff)
downloadfreebsd-ports-gnome-cdabc54ad469c80d08327c0d32dfa55c640cff2a.tar.gz
freebsd-ports-gnome-cdabc54ad469c80d08327c0d32dfa55c640cff2a.tar.zst
freebsd-ports-gnome-cdabc54ad469c80d08327c0d32dfa55c640cff2a.zip
This changes almost all the "gnomehack" only USE_GNOME cases to USES= pathfix.
If a port used other USE_GNOME items it was untouched. The ports that used other USES were fixed by hand. PR: ports/177081 Reviewed by: bapt Approved by: portmgr (miwi)
Diffstat (limited to 'palm')
-rw-r--r--palm/synce-librapi2/Makefile2
-rw-r--r--palm/synce-librra/Makefile2
-rw-r--r--palm/synce-libsynce/Makefile2
3 files changed, 3 insertions, 3 deletions
diff --git a/palm/synce-librapi2/Makefile b/palm/synce-librapi2/Makefile
index 7954ab8e4ffc..a52fdfb483cf 100644
--- a/palm/synce-librapi2/Makefile
+++ b/palm/synce-librapi2/Makefile
@@ -20,7 +20,7 @@ CONFLICTS= popular-[0-9]*
GNU_CONFIGURE= yes
USE_AUTOTOOLS= libtool
USE_ICONV= yes
-USE_GNOME= gnomehack
+USES= pathfix
USE_LDCONFIG= yes
CONFIGURE_ARGS= --with-libiconv="${LOCALBASE}" \
--with-libsynce="${LOCALBASE}"
diff --git a/palm/synce-librra/Makefile b/palm/synce-librra/Makefile
index b1e57c0c1f40..53719ed552a2 100644
--- a/palm/synce-librra/Makefile
+++ b/palm/synce-librra/Makefile
@@ -25,7 +25,7 @@ GNU_CONFIGURE= yes
USE_AUTOTOOLS= libtool
USE_ICONV= yes
USE_LDCONFIG= yes
-USE_GNOME= gnomehack
+USES= pathfix
CONFIGURE_ARGS+= --with-libsynce="${LOCALBASE}" \
--with-libmimedir="${LOCALBASE}"
diff --git a/palm/synce-libsynce/Makefile b/palm/synce-libsynce/Makefile
index 80d9da66a344..5a295d43ae61 100644
--- a/palm/synce-libsynce/Makefile
+++ b/palm/synce-libsynce/Makefile
@@ -19,7 +19,7 @@ LIB_DEPENDS= dbus-glib-1.2:${PORTSDIR}/devel/dbus-glib \
GNU_CONFIGURE= yes
USE_AUTOTOOLS= libtool
USE_ICONV= yes
-USE_GNOME= gnomehack
+USES= pathfix
CONFIGURE_ARGS+= --with-libiconv-prefix="${LOCALBASE}" \
--enable-dccm-file-support=no \
--enable-hal-support=yes \