aboutsummaryrefslogtreecommitdiffstats
path: root/palm
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2005-01-09 07:25:38 +0800
committerpav <pav@FreeBSD.org>2005-01-09 07:25:38 +0800
commit4b6253dae90836431757ea833ace2a921704eae4 (patch)
treef1b642ce41d22eb75af64be80e21a9716d8b9508 /palm
parent618a4ba0aeb291f3b24039ecc3b3be3276a1c95f (diff)
downloadfreebsd-ports-gnome-4b6253dae90836431757ea833ace2a921704eae4.tar.gz
freebsd-ports-gnome-4b6253dae90836431757ea833ace2a921704eae4.tar.zst
freebsd-ports-gnome-4b6253dae90836431757ea833ace2a921704eae4.zip
Add synce-multisync, a SynCE synchronization plugin for Multisync.
PR: ports/72271 Submitted by: Sam Lawrance <boris@brooknet.com.au>
Diffstat (limited to 'palm')
-rw-r--r--palm/Makefile1
-rw-r--r--palm/synce-multisync/Makefile29
-rw-r--r--palm/synce-multisync/distinfo2
-rw-r--r--palm/synce-multisync/pkg-descr4
-rw-r--r--palm/synce-multisync/pkg-plist6
5 files changed, 42 insertions, 0 deletions
diff --git a/palm/Makefile b/palm/Makefile
index ab742107fb72..d7ac64baa9ca 100644
--- a/palm/Makefile
+++ b/palm/Makefile
@@ -38,6 +38,7 @@
SUBDIR += synce-kde
SUBDIR += synce-librapi2
SUBDIR += synce-libsynce
+ SUBDIR += synce-multisync
SUBDIR += synce-rra
SUBDIR += synce-serial
SUBDIR += synce-trayicon
diff --git a/palm/synce-multisync/Makefile b/palm/synce-multisync/Makefile
new file mode 100644
index 000000000000..2a51d30bd234
--- /dev/null
+++ b/palm/synce-multisync/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: synce-multisync
+# Date created: September 2004
+# Whom: Sam Lawrance <boris@brooknet.com.au>
+#
+# $FreeBSD$
+
+PORTNAME= synce-multisync_plugin
+PORTVERSION= 0.9.0
+CATEGORIES= palm deskutils
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= synce
+
+MAINTAINER= boris@brooknet.com.au
+COMMENT= SynCE synchronisation plugin for Multisync
+
+LIB_DEPENDS= rra.0:${PORTSDIR}/palm/synce-rra
+BUILD_DEPENDS= multisync:${PORTSDIR}/deskutils/multisync
+RUN_DEPENDS= multisync:${PORTSDIR}/deskutils/multisync
+
+USE_GNOME= gnomeprefix gnometarget gnomevfs2
+USE_GMAKE= yes
+USE_X_PREFIX= yes
+USE_LIBTOOL_VER=15
+CONFIGURE_ARGS+= --with-librapi=${LOCALBASE} \
+ --with-libsynce=${LOCALBASE} \
+ --with-librra=${LOCALBASE} \
+ --with-multisync-include=${X11BASE}/include/multisync
+
+.include <bsd.port.mk>
diff --git a/palm/synce-multisync/distinfo b/palm/synce-multisync/distinfo
new file mode 100644
index 000000000000..c26fa47bdecd
--- /dev/null
+++ b/palm/synce-multisync/distinfo
@@ -0,0 +1,2 @@
+MD5 (synce-multisync_plugin-0.9.0.tar.gz) = 0273cac4d2bce299aec8a51b08101985
+SIZE (synce-multisync_plugin-0.9.0.tar.gz) = 327269
diff --git a/palm/synce-multisync/pkg-descr b/palm/synce-multisync/pkg-descr
new file mode 100644
index 000000000000..0ecb3ef8dcb1
--- /dev/null
+++ b/palm/synce-multisync/pkg-descr
@@ -0,0 +1,4 @@
+This plugin adds a SynCE connector to Multisync, making it possible to sync
+your Pocket PC with any other Multisync supported device or software.
+
+WWW: http://synce.sourceforge.net/
diff --git a/palm/synce-multisync/pkg-plist b/palm/synce-multisync/pkg-plist
new file mode 100644
index 000000000000..02922dc4e4c6
--- /dev/null
+++ b/palm/synce-multisync/pkg-plist
@@ -0,0 +1,6 @@
+lib/multisync/libsynce_plugin.a
+lib/multisync/libsynce_plugin.so
+lib/multisync/libsynce_plugin.so.0
+share/gnome/synce/synce_multisync_plugin.glade
+@dirrm share/gnome/synce
+@unexec rmdir %D/lib/multisync 2>/dev/null || true