aboutsummaryrefslogtreecommitdiffstats
path: root/palm
diff options
context:
space:
mode:
authorvs <vs@FreeBSD.org>2007-06-18 10:27:09 +0800
committervs <vs@FreeBSD.org>2007-06-18 10:27:09 +0800
commitd8be5dabc9b7a66079763d88f09e272e00a0edd9 (patch)
tree806671f6fb5ba1b92dddd32f2f0c39ed15afc594 /palm
parentb52bbd825553c37e12e65db367e0f49b43054f23 (diff)
downloadfreebsd-ports-gnome-d8be5dabc9b7a66079763d88f09e272e00a0edd9.tar.gz
freebsd-ports-gnome-d8be5dabc9b7a66079763d88f09e272e00a0edd9.tar.zst
freebsd-ports-gnome-d8be5dabc9b7a66079763d88f09e272e00a0edd9.zip
Unbreak by adding libsynce to LDFLAGS. Configure doesn't use pkg-config
to discover the necessary flags and neither does librapi have an explicit dependency on libsynce.
Diffstat (limited to 'palm')
-rw-r--r--palm/synce-trayicon/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/palm/synce-trayicon/Makefile b/palm/synce-trayicon/Makefile
index d2b8a152fccf..832a3bd43644 100644
--- a/palm/synce-trayicon/Makefile
+++ b/palm/synce-trayicon/Makefile
@@ -18,13 +18,13 @@ BUILD_DEPENDS= ${LOCALBASE}/lib/gnome-vfs-2.0/modules/libsyncevfs.so:${PORTSDIR}
RUN_DEPENDS= ${LOCALBASE}/lib/gnome-vfs-2.0/modules/libsyncevfs.so:${PORTSDIR}/palm/synce-gnomevfs
LIB_DEPENDS= gtop-2.0.7:${PORTSDIR}/devel/libgtop
-BROKEN= Configure fails
-
USE_GMAKE= yes
USE_GNOME= libgnomeui gnometarget
USE_GETTEXT= yes
GNU_CONFIGURE= yes
USE_XLIB= yes
+LDFLAGS+= -L${LOCALBASE}/lib -lsynce
+CONFIGURE_ENV+= LDFLAGS="${LDFLAGS}"
CONFIGURE_ARGS+= --with-libsynce=${LOCALBASE} \
--with-librapi2=${LOCALBASE}