aboutsummaryrefslogtreecommitdiffstats
path: root/palm
diff options
context:
space:
mode:
authoredwin <edwin@FreeBSD.org>2007-09-08 20:31:14 +0800
committeredwin <edwin@FreeBSD.org>2007-09-08 20:31:14 +0800
commit9547aac389d1a50c837f46f589b6805d26c273e6 (patch)
tree601ca42117e39e8e9430ae2a9c19815a23afdad7 /palm
parent7a3f0be0f6ce931949b7081894ae5faf40ff27a8 (diff)
downloadfreebsd-ports-gnome-9547aac389d1a50c837f46f589b6805d26c273e6.tar.gz
freebsd-ports-gnome-9547aac389d1a50c837f46f589b6805d26c273e6.tar.zst
freebsd-ports-gnome-9547aac389d1a50c837f46f589b6805d26c273e6.zip
uppc kmod installation problem on amd64
Please see a discussion thread starting with the following message: http://lists.freebsd.org/pipermail/freebsd-ports/2007-August/042999.html It seems that installation action of uppc-kmod port (do-install target) uses incorrect tool to put uppc.ko in its destination. It seems that the tool (${INSTALL_PROGRAM}) corrupts the .ko, so that it is not a valid kernel module anymore. If I put uppc.ko into /boot/kernel and do kldxref then kldxref complains about missing symbol table in uppc.ko and dumps core. If the module is loaded then it crashes my system. On the other hand, if I simply copy uppc.ko from work directory then it works ok. Essentially this is the same issue as described in the following PR only with another port: http://www.freebsd.org/cgi/query-pr.cgi?pr=100703 Kostik Belousov confirms the issue with stripping kernel modules on amd64: You cannot strip kernel modules on amd64, because modules are elf object files, as opposed to shared objects on all other archs. Strip strips the object file symbol table, that is used by the static linker and in-kernel linker on amd64. On the other hand, shared object contains also a dynamic symbol table, that is not stripped and used by in-kernel linker on !amd64. PR: ports/115517 Submitted by: Andriy Gapon <avg@icyb.net.ua>
Diffstat (limited to 'palm')
-rw-r--r--palm/uppc-kmod/Makefile5
1 files changed, 5 insertions, 0 deletions
diff --git a/palm/uppc-kmod/Makefile b/palm/uppc-kmod/Makefile
index 43179a5bd4bc..a6dd48ea2188 100644
--- a/palm/uppc-kmod/Makefile
+++ b/palm/uppc-kmod/Makefile
@@ -24,6 +24,11 @@ IGNORE= Requires kernel source (/usr/src/sys) to build
.include <bsd.port.pre.mk>
+# Don't strip module on amd64 systems
+.if ${ARCH} == "amd64"
+STRIP=
+.endif
+
post-build:
@${REINPLACE_CMD} -e 's|%%INITIAL_INSTALLDIR%%|${PREFIX}/lib|g' ${BUILD_WRKSRC}/uppcsetup
@${REINPLACE_CMD} -e 's|%%INITIAL_MODDIR%%|${KMODDIR}|g' ${WRKSRC}/uppcsetup