aboutsummaryrefslogtreecommitdiffstats
path: root/palm
diff options
context:
space:
mode:
authordburr <dburr@FreeBSD.org>1998-05-27 08:17:45 +0800
committerdburr <dburr@FreeBSD.org>1998-05-27 08:17:45 +0800
commit48c580c69c4ebb5b2d3565171b02bf28aefed5f0 (patch)
tree0bd8683c8bfea5e8a5db5c7667ee1765a8c1f01f /palm
parentd4428099591d902a67353a8d3926fe742aee6664 (diff)
downloadfreebsd-ports-gnome-48c580c69c4ebb5b2d3565171b02bf28aefed5f0.tar.gz
freebsd-ports-gnome-48c580c69c4ebb5b2d3565171b02bf28aefed5f0.tar.zst
freebsd-ports-gnome-48c580c69c4ebb5b2d3565171b02bf28aefed5f0.zip
Added check for "-m486" in CFLAGS &/or /etc/make.conf.
The port doesn't build properly if "-m486" is present.
Diffstat (limited to 'palm')
-rw-r--r--palm/prc-tools/Makefile16
1 files changed, 15 insertions, 1 deletions
diff --git a/palm/prc-tools/Makefile b/palm/prc-tools/Makefile
index e164650d4c8f..887c22581aef 100644
--- a/palm/prc-tools/Makefile
+++ b/palm/prc-tools/Makefile
@@ -3,7 +3,7 @@
# Date created: November, 1997
# Whom: Paul Traina <pst@freebsd.org>
#
-# $Id: Makefile,v 1.6 1998/01/01 17:29:06 asami Exp $
+# $Id: Makefile,v 1.7 1998/02/19 06:55:19 asami Exp $
#
# *WARNING* write access to ${PREFIX} is required DURING build because the
# make "all" target actually installs the gnu tools before building the
@@ -61,6 +61,20 @@ STRIP= build-prc \
pilrc \
txt2bitm
+# check for "-m486" and bomb out if the user has it
+pre-build:
+ @if ${ECHO} ${CFLAGS} | ${GREP} -- "-m486" > /dev/null ; then \
+ ${ECHO} "ERROR: You have \"-m486\" defined some-" ; \
+ ${ECHO} " where, either in /etc/make.conf" ; \
+ ${ECHO} " or in the CFLAGS environment" ; \
+ ${ECHO} " variable. This will cause this" ; \
+ ${ECHO} " port to not build properly. Please" ; \
+ ${ECHO} " fix this and re-run make." ; \
+ exit 1 ; \
+ else \
+ ${ECHO} "Your environment looks OK." ; \
+ fi
+
# after we apply freebsd patches, apply prc-tool's patches to gcc/gdb/...
post-patch:
(cd ${WRKSRC} ; make patch)