aboutsummaryrefslogtreecommitdiffstats
path: root/palm
diff options
context:
space:
mode:
authorehaupt <ehaupt@FreeBSD.org>2014-02-27 15:32:00 +0800
committerehaupt <ehaupt@FreeBSD.org>2014-02-27 15:32:00 +0800
commitff6f94ec1fb43ce71def716111053afaa9d820ad (patch)
treec3505840b8e8e2021babb38afca8de23186f8e6c /palm
parent66190116ddf9d858e9006627c00d4565e92f75ec (diff)
downloadfreebsd-ports-gnome-ff6f94ec1fb43ce71def716111053afaa9d820ad.tar.gz
freebsd-ports-gnome-ff6f94ec1fb43ce71def716111053afaa9d820ad.tar.zst
freebsd-ports-gnome-ff6f94ec1fb43ce71def716111053afaa9d820ad.zip
- Support staging
- Use shebangfix
Diffstat (limited to 'palm')
-rw-r--r--palm/bibelot/Makefile12
1 files changed, 7 insertions, 5 deletions
diff --git a/palm/bibelot/Makefile b/palm/bibelot/Makefile
index b0c41d7ba652..1ffb9db8154e 100644
--- a/palm/bibelot/Makefile
+++ b/palm/bibelot/Makefile
@@ -9,14 +9,16 @@ MASTER_SITES= SF/${PORTNAME}/Bibelot/${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= Formats and converts text documents into compressed PalmDoc .pdb files
-PLIST_FILES= bin/bibelot
-USES= perl5
+USES= perl5 shebangfix
+NO_BUILD= yes
WRKSRC= ${WRKDIR}/${PORTNAME}
-NO_BUILD= yes
-NO_STAGE= yes
+PLIST_FILES= bin/bibelot
+SHEBANG_FILES= bibelot.pl
+
do-install:
- ${INSTALL_SCRIPT} ${WRKSRC}/${PORTNAME}.pl ${PREFIX}/bin/${PORTNAME}
+ ${INSTALL_SCRIPT} ${WRKSRC}/${PORTNAME}.pl \
+ ${STAGEDIR}${PREFIX}/bin/${PORTNAME}
.include <bsd.port.mk>