aboutsummaryrefslogtreecommitdiffstats
path: root/polish/ekg
diff options
context:
space:
mode:
authorpawel <pawel@FreeBSD.org>2013-07-11 03:41:30 +0800
committerpawel <pawel@FreeBSD.org>2013-07-11 03:41:30 +0800
commit4682c2c61dcb7a63ae78f7c087ba5d0bda84f154 (patch)
treef00883f68004a81b9e525ad5cc94de309898b666 /polish/ekg
parent31dd4fd824aafa89c7f4eb95e23f32974c053110 (diff)
downloadfreebsd-ports-gnome-4682c2c61dcb7a63ae78f7c087ba5d0bda84f154.tar.gz
freebsd-ports-gnome-4682c2c61dcb7a63ae78f7c087ba5d0bda84f154.tar.zst
freebsd-ports-gnome-4682c2c61dcb7a63ae78f7c087ba5d0bda84f154.zip
Convert my ports to current standards
- Switch USE_GMAKE to USES=gmake - Define supported options so users can see them in config dialogs - Use OPTIONS_SUB for plist alteration - Convert to options macros for better readability - Use PORTDOCS where it makes sense
Diffstat (limited to 'polish/ekg')
-rw-r--r--polish/ekg/Makefile15
1 files changed, 4 insertions, 11 deletions
diff --git a/polish/ekg/Makefile b/polish/ekg/Makefile
index 64f33bea216f..4b230d8bc1e6 100644
--- a/polish/ekg/Makefile
+++ b/polish/ekg/Makefile
@@ -14,9 +14,8 @@ COMMENT= Text-mode Gadu-Gadu client
LIB_DEPENDS= execinfo:${PORTSDIR}/devel/libexecinfo \
gadu:${PORTSDIR}/polish/libgadu
-USE_GMAKE= yes
GNU_CONFIGURE= yes
-USES= pathfix pkgconfig
+USES= gmake pathfix pkgconfig
USE_LDCONFIG= yes
CONFIGURE_ARGS= --without-libungif \
@@ -33,16 +32,10 @@ MANCOMPRESSED= no
OPTIONS_DEFINE= ASPELL OPENSSL
OPTIONS_DEFAULT= OPENSSL
-.include <bsd.port.options.mk>
+ASPELL_CONFIGURE_ON= --enable-aspell
+ASPELL_LIB_DEPENDS= aspell:${PORTSDIR}/polish/aspell
-.if ${PORT_OPTIONS:MASPELL}
-LIB_DEPENDS+= aspell:${PORTSDIR}/polish/aspell
-CONFIGURE_ARGS+= --enable-aspell
-.endif
-
-.if ! ${PORT_OPTIONS:MOPENSSL}
-CONFIGURE_ARGS+= --without-openssl
-.endif
+OPENSSL_CONFIGURE_OFF= --without-openssl
post-install:
${STRIP_CMD} ${PREFIX}/bin/ekg