aboutsummaryrefslogtreecommitdiffstats
path: root/polish/kadu
diff options
context:
space:
mode:
authorpawel <pawel@FreeBSD.org>2015-11-11 23:40:39 +0800
committerpawel <pawel@FreeBSD.org>2015-11-11 23:40:39 +0800
commit8c5fa79bd92ef34bf7d5d8b98cdf7d08706177bb (patch)
tree0a48cca47853e1e239112f9b2449c6dd1c7dd301 /polish/kadu
parent3b2438559c237cfa475a0c053706c95e54ee2c9e (diff)
downloadfreebsd-ports-gnome-8c5fa79bd92ef34bf7d5d8b98cdf7d08706177bb.tar.gz
freebsd-ports-gnome-8c5fa79bd92ef34bf7d5d8b98cdf7d08706177bb.tar.zst
freebsd-ports-gnome-8c5fa79bd92ef34bf7d5d8b98cdf7d08706177bb.zip
- Fix build with gcc 4.9 [1]
- Use option helper PR: 204395 [1] Reported by: gerald [1]
Diffstat (limited to 'polish/kadu')
-rw-r--r--polish/kadu/Makefile6
-rw-r--r--polish/kadu/files/patch-kadu-core_execution-arguments_execution-arguments-parser.h11
2 files changed, 12 insertions, 5 deletions
diff --git a/polish/kadu/Makefile b/polish/kadu/Makefile
index df0ee97cfa6e..10b4a0c444cc 100644
--- a/polish/kadu/Makefile
+++ b/polish/kadu/Makefile
@@ -53,10 +53,7 @@ GG_EMOTS_DESC= GG-compatible emoticons
GG_EMOTS_DISTFILES= ${GG6_EMOTS_DISTFILE}:additions \
${GG7_EMOTS_DISTFILE}:additions
-.include <bsd.port.options.mk>
-
-post-install:
-.if ${PORT_OPTIONS:MGG_EMOTS}
+post-install-GG_EMOTS-on:
@${MKDIR} ${WRKSRC}/varia/themes/emoticons
@cd ${WRKSRC}/varia/themes/emoticons && \
${TAR} -zxf ${_DISTDIR}/${GG6_EMOTS_DISTFILE} && \
@@ -64,6 +61,5 @@ post-install:
cd gg6_compatible && ${TAR} -zxf ${_DISTDIR}/${GG7_EMOTS_DISTFILE}
@cd ${WRKSRC}/varia/themes/emoticons && \
${COPYTREE_SHARE} gg6_compatible ${STAGEDIR}${DATADIR}/themes/emoticons
-.endif
.include <bsd.port.mk>
diff --git a/polish/kadu/files/patch-kadu-core_execution-arguments_execution-arguments-parser.h b/polish/kadu/files/patch-kadu-core_execution-arguments_execution-arguments-parser.h
new file mode 100644
index 000000000000..203e4756b569
--- /dev/null
+++ b/polish/kadu/files/patch-kadu-core_execution-arguments_execution-arguments-parser.h
@@ -0,0 +1,11 @@
+--- kadu-core/execution-arguments/execution-arguments-parser.h.orig 2015-11-09 20:19:32 UTC
++++ kadu-core/execution-arguments/execution-arguments-parser.h
+@@ -20,7 +20,7 @@
+ #pragma once
+
+ #include "exports.h"
+-
++#include <cstdio>
+ #include <QtCore/QStringList>
+
+ class ExecutionArguments;