aboutsummaryrefslogtreecommitdiffstats
path: root/polish/kadu
diff options
context:
space:
mode:
authorpawel <pawel@FreeBSD.org>2017-05-12 00:59:56 +0800
committerpawel <pawel@FreeBSD.org>2017-05-12 00:59:56 +0800
commita82c71b8600ebead807cd68c3f9613be68f5219c (patch)
tree889226c120d2d508119255935b194ec3ff95cc23 /polish/kadu
parenteb9dee61d9a491a01e84445aafc89d4a5499ede3 (diff)
downloadfreebsd-ports-gnome-a82c71b8600ebead807cd68c3f9613be68f5219c.tar.gz
freebsd-ports-gnome-a82c71b8600ebead807cd68c3f9613be68f5219c.tar.zst
freebsd-ports-gnome-a82c71b8600ebead807cd68c3f9613be68f5219c.zip
Fix segfault on program exit
Diffstat (limited to 'polish/kadu')
-rw-r--r--polish/kadu/Makefile2
-rw-r--r--polish/kadu/files/patch-kadu-core_gui_actions_action-description.cpp12
2 files changed, 13 insertions, 1 deletions
diff --git a/polish/kadu/Makefile b/polish/kadu/Makefile
index 9e4ef52404e2..76a310aab2c0 100644
--- a/polish/kadu/Makefile
+++ b/polish/kadu/Makefile
@@ -3,7 +3,7 @@
PORTNAME= kadu
PORTVERSION= 4.3
-PORTREVISION= 1
+PORTREVISION= 2
PORTEPOCH= 1
CATEGORIES= polish net-im
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTVERSION}/:kadu \
diff --git a/polish/kadu/files/patch-kadu-core_gui_actions_action-description.cpp b/polish/kadu/files/patch-kadu-core_gui_actions_action-description.cpp
new file mode 100644
index 000000000000..40e5d83c94f3
--- /dev/null
+++ b/polish/kadu/files/patch-kadu-core_gui_actions_action-description.cpp
@@ -0,0 +1,12 @@
+--- kadu-core/gui/actions/action-description.cpp.orig 2017-01-24 21:36:21 UTC
++++ kadu-core/gui/actions/action-description.cpp
+@@ -103,7 +103,8 @@ void ActionDescription::registerAction(Actions *action
+
+ void ActionDescription::unregisterAction(Actions *actions)
+ {
+- actions->remove(this);
++ if (actions)
++ actions->remove(this);
+ }
+
+ void ActionDescription::actionAboutToBeDestroyed(Action *action)