aboutsummaryrefslogtreecommitdiffstats
path: root/polish/libgadu/Makefile
diff options
context:
space:
mode:
authorlippe <lippe@FreeBSD.org>2008-03-26 02:45:09 +0800
committerlippe <lippe@FreeBSD.org>2008-03-26 02:45:09 +0800
commit2c27f980e5749f20007f76db78c6f7515a1460c6 (patch)
tree4ac17491ce6355a18f7530bfab7f777ace58b1e1 /polish/libgadu/Makefile
parentf66bc7a818ebcb13e4d6030bd35326de43361fa2 (diff)
downloadfreebsd-ports-gnome-2c27f980e5749f20007f76db78c6f7515a1460c6.tar.gz
freebsd-ports-gnome-2c27f980e5749f20007f76db78c6f7515a1460c6.tar.zst
freebsd-ports-gnome-2c27f980e5749f20007f76db78c6f7515a1460c6.zip
- Upgrade to 1.8.0.
- Use PLIST_FILES and remove pkg-plist. - Fix WWW in pkg-descr. - Add SSL support. PR: ports/121303 Submitted by: Aleksander Fafula <alex@fafula.com> (maintainer) Reviewed by: Marcin Wisnicki <mwisnicki@gmail.com> Approved by: gabor (mentor), Aleksander Fafula <alex@fafula.com> (maintainer)
Diffstat (limited to 'polish/libgadu/Makefile')
-rw-r--r--polish/libgadu/Makefile18
1 files changed, 15 insertions, 3 deletions
diff --git a/polish/libgadu/Makefile b/polish/libgadu/Makefile
index 44dbd0cc52f2..283b852e15da 100644
--- a/polish/libgadu/Makefile
+++ b/polish/libgadu/Makefile
@@ -5,7 +5,7 @@
# $FreeBSD$
PORTNAME= libgadu
-PORTVERSION= 1.7.1
+PORTVERSION= 1.8.0
PORTEPOCH= 1
CATEGORIES= polish net
MASTER_SITES= http://toxygen.net/libgadu/files/
@@ -13,14 +13,26 @@ MASTER_SITES= http://toxygen.net/libgadu/files/
MAINTAINER= alex@BSDGuru.org
COMMENT= This library is used by many IMs with Gadu-Gadu support
-CONFLICTS= pl-ekg-1.[0-5]* pl-ekg-1.6,2
+CONFLICTS= pl-ekg-1.[0-6]*
USE_GMAKE= yes
USE_GNOME= gnomehack pkgconfig
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --enable-shared --disable-static --without-openssl
+CONFIGURE_ARGS= --enable-shared --disable-static
USE_LDCONFIG= yes
+PLIST_FILES= include/libgadu.h \
+ lib/libgadu.la \
+ lib/libgadu.so \
+ lib/libgadu.so.3 \
+ libdata/pkgconfig/libgadu.pc
+
+OPTIONS= OPENSSL "Build with OPENSSL support" on
+
+.if defined(WITHOUT_OPENSSL)
+CONFIGURE_ARGS+= --without-openssl
+.endif
+
.include <bsd.port.mk>