aboutsummaryrefslogtreecommitdiffstats
path: root/polish/libgadu/Makefile
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2006-01-15 18:37:30 +0800
committerpav <pav@FreeBSD.org>2006-01-15 18:37:30 +0800
commit71785a52e413e62f81f1cd0a2e4c6df6febc9d19 (patch)
tree366f81c572b5b42112dacf8224ebca3a6aa8fcd3 /polish/libgadu/Makefile
parentef4a466efbe90fef75752afe3ff1baf7d6941b65 (diff)
downloadfreebsd-ports-gnome-71785a52e413e62f81f1cd0a2e4c6df6febc9d19.tar.gz
freebsd-ports-gnome-71785a52e413e62f81f1cd0a2e4c6df6febc9d19.tar.zst
freebsd-ports-gnome-71785a52e413e62f81f1cd0a2e4c6df6febc9d19.zip
A library used by many Instant Messangers that can communicate using the
Gadu-Gadu protocol. PR: ports/91675 Submitted by: Aleksander Fafula <alex@bsdguru.org>
Diffstat (limited to 'polish/libgadu/Makefile')
-rw-r--r--polish/libgadu/Makefile30
1 files changed, 30 insertions, 0 deletions
diff --git a/polish/libgadu/Makefile b/polish/libgadu/Makefile
new file mode 100644
index 000000000000..f83a76b0f3d5
--- /dev/null
+++ b/polish/libgadu/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: libgadu
+# Date created: 29 December 2005
+# Whom: Aleksander Fafula <alex@BSDGuru.org>
+#
+# $FreeBSD$
+
+PORTNAME= libgadu
+PORTVERSION= 20051229
+CATEGORIES= polish net
+MASTER_SITES= http://bsdguru.org/distfiles/
+
+MAINTAINER= alex@BSDGuru.org
+COMMENT= This library is used by many IMs with Gadu-Gadu support
+
+USE_REINPLACE= yes
+USE_GMAKE= yes
+USE_GNOME= gnomehack pkgconfig
+USE_AUTOTOOLS= aclocal:15 autoheader:259 autoconf:259
+ACLOCAL_ARGS= -I ${WRKSRC}/m4
+
+CONFIGURE_ARGS= --enable-shared --disable-static
+
+INSTALLS_SHLIB= yes
+
+post-install:
+ ${RM} ${PREFIX}/lib/libgadu.so ${PREFIX}/lib/libgadu.so.3
+ ${MV} ${PREFIX}/lib/libgadu.so.3.3 ${PREFIX}/lib/libgadu.so.3
+ ${LN} -s ${PREFIX}/lib/libgadu.so.3 ${PREFIX}/lib/libgadu.so
+
+.include <bsd.port.mk>