aboutsummaryrefslogtreecommitdiffstats
path: root/polish/tleenx2/Makefile
diff options
context:
space:
mode:
authortijl <tijl@FreeBSD.org>2014-08-27 18:06:11 +0800
committertijl <tijl@FreeBSD.org>2014-08-27 18:06:11 +0800
commitacb064e92d9e3852e86adcb3c3e6abc1373855b3 (patch)
tree521ed6e0ac23414dc3637b0f66722e3a3be6346a /polish/tleenx2/Makefile
parent522d67c2b80615628ec9c930be7405bafb286ad6 (diff)
downloadfreebsd-ports-gnome-acb064e92d9e3852e86adcb3c3e6abc1373855b3.tar.gz
freebsd-ports-gnome-acb064e92d9e3852e86adcb3c3e6abc1373855b3.tar.zst
freebsd-ports-gnome-acb064e92d9e3852e86adcb3c3e6abc1373855b3.zip
Fix missing library problem when the linker enforces explicit linking
PR: 192062
Diffstat (limited to 'polish/tleenx2/Makefile')
-rw-r--r--polish/tleenx2/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/polish/tleenx2/Makefile b/polish/tleenx2/Makefile
index 36d8f53c60a5..b4d71d3156ec 100644
--- a/polish/tleenx2/Makefile
+++ b/polish/tleenx2/Makefile
@@ -16,7 +16,7 @@ LIB_DEPENDS= libtlen.so:${PORTSDIR}/polish/libtlen
USES= pkgconfig
USE_GNOME= gtk20
GNU_CONFIGURE= yes
-USE_XORG= xscrnsaver
+USE_XORG= x11 xscrnsaver
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
WRKSRC= ${WRKDIR}/TleenX2-${PORTVERSION}
@@ -25,7 +25,7 @@ PORTDOCS= README gg.txt sms.txt
post-patch:
@${REINPLACE_CMD} \
- -e '/^tleenx2_LDADD =/,+1s,/usr/X11R6/lib/libXss.a,-lXss,' \
+ -e '/^tleenx2_LDADD =/,+1s,/usr/X11R6/lib/libXss.a,-lXss -lX11,' \
-e 's,/usr/X11R6/lib/libXss.a,,' \
${WRKSRC}/src/Makefile.in
@${REINPLACE_CMD} 's,/usr/local,${LOCALBASE},g; s,gcc,${CC},' \