aboutsummaryrefslogtreecommitdiffstats
path: root/polish
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2009-05-17 18:15:24 +0800
committermiwi <miwi@FreeBSD.org>2009-05-17 18:15:24 +0800
commit247bec1dea82099aad1b4be066e068cd1db38df3 (patch)
tree9690fe867f265bc9adc56f2b396cae5ae6588061 /polish
parent9ea4a9007237ae078591608999179714e1c49670 (diff)
downloadfreebsd-ports-gnome-247bec1dea82099aad1b4be066e068cd1db38df3.tar.gz
freebsd-ports-gnome-247bec1dea82099aad1b4be066e068cd1db38df3.tar.zst
freebsd-ports-gnome-247bec1dea82099aad1b4be066e068cd1db38df3.zip
- Update to 0.6.5.2
PR: 134592 Submitted by: Marcin Wisnicki <mwisnicki+freebsd@gmail.com> (maintainer)
Diffstat (limited to 'polish')
-rw-r--r--polish/kadu/Makefile12
-rw-r--r--polish/kadu/distinfo6
-rw-r--r--polish/kadu/files/patch-kadu-core_CMakeLists.txt34
-rw-r--r--polish/kadu/files/patch-kadu-core_main.cpp11
-rw-r--r--polish/kadu/files/patch-modules-encryption_CMakeLists.txt14
-rw-r--r--polish/kadu/files/patch-varia_themes_emoticons_get-all.sh11
-rw-r--r--polish/kadu/pkg-plist24
7 files changed, 32 insertions, 80 deletions
diff --git a/polish/kadu/Makefile b/polish/kadu/Makefile
index 0eb704c98190..4b17b41ac6bc 100644
--- a/polish/kadu/Makefile
+++ b/polish/kadu/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= kadu
-PORTVERSION= 0.6.5.1
-PORTREVISION= 1
+PORTVERSION= 0.6.5.2
PORTEPOCH= 1
CATEGORIES= polish net-im
MASTER_SITES= http://www.kadu.net/download/stable/:kadu \
@@ -23,8 +22,10 @@ MAINTAINER= mwisnicki+freebsd@gmail.com
COMMENT= QT Gadu-Gadu client
BUILD_DEPENDS= bash:${PORTSDIR}/shells/bash
-LIB_DEPENDS= gadu.3:${PORTSDIR}/polish/libgadu\
+LIB_DEPENDS= gadu.3:${PORTSDIR}/polish/libgadu \
+ qca.2:${PORTSDIR}/devel/qca \
sndfile.1:${PORTSDIR}/audio/libsndfile
+RUN_DEPENDS= qca-ossl>=2.0.0.b3:${PORTSDIR}/security/qca-ossl
# TODO enable devel/libexecinfo
TABS_MOD_DISTFILE= kadu-tabs-1.2.3.tar.bz2
@@ -35,11 +36,8 @@ GG7_EMOTS_DISTFILE= dodatkowe_emoty_GG7.tar.gz
USE_BZIP2= yes
USE_CMAKE= yes
-# remove option with typo when they fix it
-CMAKE_ARGS= -DENABLE_AUTDOWNLOAD:BOOL=OFF \
- -DENABLE_AUTODOWNLOAD:BOOL=OFF
+CMAKE_ARGS= -DENABLE_AUTODOWNLOAD:BOOL=OFF
CMAKE_USE_PTHREAD= yes
-USE_OPENSSL= yes
USE_QT_VER= 4
QT_COMPONENTS= gui dbus linguist network qt3support webkit xml \
diff --git a/polish/kadu/distinfo b/polish/kadu/distinfo
index df3693ea5941..17c6be877fd8 100644
--- a/polish/kadu/distinfo
+++ b/polish/kadu/distinfo
@@ -1,6 +1,6 @@
-MD5 (kadu/kadu-0.6.5.1.tar.bz2) = 7101626c23a58d15bd35d23fdc4faac2
-SHA256 (kadu/kadu-0.6.5.1.tar.bz2) = e2df2e1d7c1fa9a5d931a35efeb936088c42ef4b5d42fef8dddadc40f87397e2
-SIZE (kadu/kadu-0.6.5.1.tar.bz2) = 1341099
+MD5 (kadu/kadu-0.6.5.2.tar.bz2) = 9cc1e59e538ff1aa416d162834ce43bb
+SHA256 (kadu/kadu-0.6.5.2.tar.bz2) = 28d8e7e31a5e502217a2d5ddb93343c8c33ab09772035f32c568af0e3cc36183
+SIZE (kadu/kadu-0.6.5.2.tar.bz2) = 1554848
MD5 (kadu/spellchecker-20080821.tar.bz2) = 61c3b8e64758b44dae1996f972f9312e
SHA256 (kadu/spellchecker-20080821.tar.bz2) = bb9f0e2d8b673355aac0e037826ff314e1f4a9600958f4239dc6b80460911cb7
SIZE (kadu/spellchecker-20080821.tar.bz2) = 6268
diff --git a/polish/kadu/files/patch-kadu-core_CMakeLists.txt b/polish/kadu/files/patch-kadu-core_CMakeLists.txt
deleted file mode 100644
index b226dde931ca..000000000000
--- a/polish/kadu/files/patch-kadu-core_CMakeLists.txt
+++ /dev/null
@@ -1,34 +0,0 @@
---- kadu-core/CMakeLists.txt.orig 2008-09-23 18:19:43.000000000 +0200
-+++ kadu-core/CMakeLists.txt 2009-03-08 02:46:30.000000000 +0100
-@@ -162,6 +162,7 @@
- target_link_libraries (kadu_c kadu_core)
- else (WIN32)
- add_executable (kadu main.cpp main_unix.cpp ${kadu_SRCS} ${MOC_FILES})
-+ set_target_properties (kadu PROPERTIES ENABLE_EXPORTS ON)
- target_link_libraries (kadu ${STATIC_MODULES} ${QT_LIBRARIES} ${LIBGADU_LIBRARIES})
- endif (WIN32)
-
-@@ -175,14 +176,15 @@
-
-
- # install icons
--install (FILES hi16-app-kadu.png DESTINATION "share/pixmaps" RENAME kadu-16.png)
--install (FILES hi22-app-kadu.png DESTINATION "share/pixmaps" RENAME kadu-22.png)
--install (FILES hi24-app-kadu.png DESTINATION "share/pixmaps" RENAME kadu-24.png)
--install (FILES hi32-app-kadu.png DESTINATION "share/pixmaps" RENAME kadu.png)
--install (FILES hi48-app-kadu.png DESTINATION "share/pixmaps" RENAME kadu-48.png)
--install (FILES hi64-app-kadu.png DESTINATION "share/pixmaps" RENAME kadu-64.png)
--install (FILES hi128-app-kadu.png DESTINATION "share/pixmaps" RENAME kadu-128.png)
--install (FILES hi256-app-kadu.png DESTINATION "share/pixmaps" RENAME kadu-256.png)
-+install (FILES hi16-app-kadu.png DESTINATION "share/icons/hicolor/16x16/apps" RENAME kadu.png)
-+install (FILES hi22-app-kadu.png DESTINATION "share/icons/hicolor/22x22/apps" RENAME kadu.png)
-+install (FILES hi24-app-kadu.png DESTINATION "share/icons/hicolor/24x24/apps" RENAME kadu.png)
-+install (FILES hi32-app-kadu.png DESTINATION "share/icons/hicolor/32x32/apps" RENAME kadu.png)
-+install (FILES hi48-app-kadu.png DESTINATION "share/icons/hicolor/48x48/apps" RENAME kadu.png)
-+install (FILES hi64-app-kadu.png DESTINATION "share/icons/hicolor/64x64/apps" RENAME kadu.png)
-+install (FILES hi128-app-kadu.png DESTINATION "share/icons/hicolor/128x128/apps" RENAME kadu.png)
-+# As of icon-theme-0.5 maximum supported pixmap size is 192, for anything larger one should use SVG.
-+#install (FILES hi256-app-kadu.png DESTINATION "share/icons/hicolor/256x256/apps" RENAME kadu.png)
-
- if (APPLE)
- pkg_search_module (SNDFILE REQUIRED sndfile>=1.0)
diff --git a/polish/kadu/files/patch-kadu-core_main.cpp b/polish/kadu/files/patch-kadu-core_main.cpp
deleted file mode 100644
index 86dde998efe5..000000000000
--- a/polish/kadu/files/patch-kadu-core_main.cpp
+++ /dev/null
@@ -1,11 +0,0 @@
---- kadu-core/main.cpp.orig 2009-01-04 14:18:33.000000000 +0100
-+++ kadu-core/main.cpp 2009-03-07 18:12:29.000000000 +0100
-@@ -19,7 +19,7 @@
- #else
- #include <winsock2.h>
- #endif
--#ifdef Q_WS_MAC
-+#ifdef Q_OS_BSD4
- #include <sys/types.h>
- #include <sys/stat.h>
- #endif
diff --git a/polish/kadu/files/patch-modules-encryption_CMakeLists.txt b/polish/kadu/files/patch-modules-encryption_CMakeLists.txt
deleted file mode 100644
index ae4b35b7d179..000000000000
--- a/polish/kadu/files/patch-modules-encryption_CMakeLists.txt
+++ /dev/null
@@ -1,14 +0,0 @@
---- ./modules/encryption/CMakeLists.txt.orig 2008-10-25 13:29:59.000000000 +0400
-+++ ./modules/encryption/CMakeLists.txt 2009-03-14 01:17:21.000000000 +0300
-@@ -38,9 +38,8 @@
- cmake_policy(SET CMP0003 NEW)
- endif (COMMAND cmake_policy)
-
--pkg_search_module (OPENSSL REQUIRED openssl)
--include_directories (${OPENSSL_INCLUDE_DIRS})
--link_directories (${OPENSSL_INCLUDE_DIRS})
-+find_package (OpenSSL)
-+include_directories (${OPENSSL_INCLUDE_DIR})
-
- add_library (encryption ${encryption} ${SOURCES} ${MOC_FILES})
- target_link_libraries(encryption ${OPENSSL_LIBRARIES})
diff --git a/polish/kadu/files/patch-varia_themes_emoticons_get-all.sh b/polish/kadu/files/patch-varia_themes_emoticons_get-all.sh
deleted file mode 100644
index fac64924616f..000000000000
--- a/polish/kadu/files/patch-varia_themes_emoticons_get-all.sh
+++ /dev/null
@@ -1,11 +0,0 @@
---- varia/themes/emoticons/get-all.sh.orig 2008-12-01 00:15:08.000000000 +0100
-+++ varia/themes/emoticons/get-all.sh 2009-03-12 23:56:25.000000000 +0100
-@@ -2,7 +2,7 @@
-
- available_emots_themes=""
- for dir in *; do
-- if [ -f "$dir/emots.txt" ]; then
-+ if [ "`find $dir -name emots.txt`" ]; then
- available_emots_themes="$available_emots_themes $dir"
- fi
- done
diff --git a/polish/kadu/pkg-plist b/polish/kadu/pkg-plist
index a47e3a0209a5..87984c5d5449 100644
--- a/polish/kadu/pkg-plist
+++ b/polish/kadu/pkg-plist
@@ -10,6 +10,7 @@ lib/kadu/modules/libdsp_sound.so
lib/kadu/modules/libencryption.so
lib/kadu/modules/libhints.so
lib/kadu/modules/libhistory.so
+lib/kadu/modules/libidle.so
lib/kadu/modules/libnotify.so
lib/kadu/modules/libsms.so
lib/kadu/modules/libsound.so
@@ -44,6 +45,20 @@ lib/kadu/modules/libwindow_notify.so
%%ASPELL_MOD%%%%DATADIR%%/modules/configuration/spellchecker.ui
%%TABS_MOD%%%%DATADIR%%/modules/configuration/tabs.ui
%%DATADIR%%/modules/configuration/voice.ui
+%%DATADIR%%/modules/data/config_wizard/joi/brak.jpg
+%%DATADIR%%/modules/data/config_wizard/ronk2/Blocking.png
+%%DATADIR%%/modules/data/config_wizard/ronk2/Busy (d.).png
+%%DATADIR%%/modules/data/config_wizard/ronk2/Busy.png
+%%DATADIR%%/modules/data/config_wizard/ronk2/Invisible (d.).png
+%%DATADIR%%/modules/data/config_wizard/ronk2/Invisible.png
+%%DATADIR%%/modules/data/config_wizard/ronk2/Offline (d.).png
+%%DATADIR%%/modules/data/config_wizard/ronk2/Offline.png
+%%DATADIR%%/modules/data/config_wizard/ronk2/Online (d.).png
+%%DATADIR%%/modules/data/config_wizard/ronk2/Online.png
+%%DATADIR%%/modules/data/config_wizard/ronk2/message.png
+%%DATADIR%%/modules/data/config_wizard/ronk2/mobile.png
+%%DATADIR%%/modules/data/config_wizard/ronk2/tlo.jpg
+%%DATADIR%%/modules/data/config_wizard/ronk2/tux.png
%%DATADIR%%/modules/dcc.desc
%%DATADIR%%/modules/default_sms.desc
%%DATADIR%%/modules/docking.desc
@@ -51,6 +66,7 @@ lib/kadu/modules/libwindow_notify.so
%%DATADIR%%/modules/encryption.desc
%%DATADIR%%/modules/hints.desc
%%DATADIR%%/modules/history.desc
+%%DATADIR%%/modules/idle.desc
%%DATADIR%%/modules/notify.desc
%%DATADIR%%/modules/qt4_docking.desc
%%DATADIR%%/modules/sms.desc
@@ -125,12 +141,18 @@ lib/kadu/modules/libwindow_notify.so
%%DATADIR%%/modules/translations/window_notify_pl.qm
%%DATADIR%%/modules/voice.desc
%%DATADIR%%/modules/window_notify.desc
+%%DATADIR%%/syntax/chat/Adi1981.syntax
+%%DATADIR%%/syntax/chat/Arvenil.syntax
+%%DATADIR%%/syntax/chat/aqq2_by_maddox84.syntax
+%%DATADIR%%/syntax/chat/c34_white_gradient_compact.syntax
%%DATADIR%%/syntax/chat/cheester.syntax
%%DATADIR%%/syntax/chat/filozof.syntax
%%DATADIR%%/syntax/chat/fuku.syntax
%%DATADIR%%/syntax/chat/hapi.syntax
%%DATADIR%%/syntax/chat/irc.syntax
%%DATADIR%%/syntax/chat/kadu.syntax
+%%DATADIR%%/syntax/chat/skp_by_dam.syntax
+%%DATADIR%%/syntax/chat/skype_by_dorr.syntax
%%DATADIR%%/syntax/infopanel/Arvenil.syntax
%%DATADIR%%/syntax/infopanel/ciuciu.syntax
%%DATADIR%%/syntax/infopanel/default.syntax
@@ -1021,6 +1043,8 @@ share/icons/hicolor/128x128/apps/kadu.png
@dirrm %%DATADIR%%/syntax/chat
@dirrm %%DATADIR%%/syntax
@dirrm %%DATADIR%%/modules/translations
+@dirrm %%DATADIR%%/modules/data/config_wizard/ronk2
+@dirrm %%DATADIR%%/modules/data/config_wizard/joi
@dirrm %%DATADIR%%/modules/data/config_wizard
@dirrm %%DATADIR%%/modules/data
@dirrm %%DATADIR%%/modules/configuration