aboutsummaryrefslogtreecommitdiffstats
path: root/polish
diff options
context:
space:
mode:
authormarino <marino@FreeBSD.org>2016-09-14 13:39:41 +0800
committermarino <marino@FreeBSD.org>2016-09-14 13:39:41 +0800
commit8396c8b300e1f82a07b553ab79c8c120aeaa41d1 (patch)
treeffb408aa97398771490b991b3c3ba89903d08eb8 /polish
parentce290ecf24d4e10d1af08c38c5384b6b6e219dbb (diff)
downloadfreebsd-ports-gnome-8396c8b300e1f82a07b553ab79c8c120aeaa41d1.tar.gz
freebsd-ports-gnome-8396c8b300e1f82a07b553ab79c8c120aeaa41d1.tar.zst
freebsd-ports-gnome-8396c8b300e1f82a07b553ab79c8c120aeaa41d1.zip
polish/fortunepl: Use fortune_strfile instead of strfile(8) and mark BROKEN
This removes the dependency on the games distribution. Unfortunately, it's also unfetchable so it's also been marked BROKEN for this reason.
Diffstat (limited to 'polish')
-rw-r--r--polish/fortunepl/Makefile20
1 files changed, 10 insertions, 10 deletions
diff --git a/polish/fortunepl/Makefile b/polish/fortunepl/Makefile
index 0798bd66c878..d3c50c551abd 100644
--- a/polish/fortunepl/Makefile
+++ b/polish/fortunepl/Makefile
@@ -14,13 +14,11 @@ PATCHFILES= fortunes-pl_${PORTVERSION}.freebsd.pl \
MAINTAINER= ports@FreeBSD.org
COMMENT= Lot of funny Polish fortune files
-.if exists(/usr/games/strfile)
-STRCMD= /usr/games/strfile
-.elif exists(/usr/bin/strfile)
-STRCMD= /usr/bin/strfile
-.else
-IGNORE= needs strfile command. Please install games distribution of base system
-.endif
+BROKEN= unfetchable
+
+BUILD_DEPENDS= fortune_strfile:misc/fortune_strfile
+STRCMD= ${LOCALBASE}/bin/fortune_strfile
+
WRKSRC= ${WRKDIR}/fortunes-pl-${PORTVERSION}.orig
FORTUNES= 7thguard advocacy apcoh argante bajki bok cnp cows \
@@ -35,12 +33,14 @@ FORTUNES= 7thguard advocacy apcoh argante bajki bok cnp cows \
znaki_zodiaku
do-patch:
- ${CP} ${DISTDIR}/fortunes-pl_${PORTVERSION}.freebsd.pl ${WRKSRC}/freebsd.pl
- ${CP} ${DISTDIR}/fortunes-pl_${PORTVERSION}.filozofia ${WRKSRC}/filozofia
+ ${CP} ${DISTDIR}/fortunes-pl_${PORTVERSION}.freebsd.pl \
+ ${WRKSRC}/freebsd.pl
+ ${CP} ${DISTDIR}/fortunes-pl_${PORTVERSION}.filozofia \
+ ${WRKSRC}/filozofia
do-build:
.for FILE in ${FORTUNES}
- @${STRCMD} ${WRKSRC}/${FILE}
+ ${STRCMD} ${WRKSRC}/${FILE}
.endfor
do-install: