aboutsummaryrefslogtreecommitdiffstats
path: root/polish
diff options
context:
space:
mode:
authorantoine <antoine@FreeBSD.org>2016-09-15 03:50:46 +0800
committerantoine <antoine@FreeBSD.org>2016-09-15 03:50:46 +0800
commite0831c933ca8bda64a7a5ed9b16f6302bb692d59 (patch)
treeec6270397becb70ebcaa5c6615c9cd29a5684b63 /polish
parent21c1782a9f81ba9c12ab39a2e136b9e6ff232d48 (diff)
downloadfreebsd-ports-gnome-e0831c933ca8bda64a7a5ed9b16f6302bb692d59.tar.gz
freebsd-ports-gnome-e0831c933ca8bda64a7a5ed9b16f6302bb692d59.tar.zst
freebsd-ports-gnome-e0831c933ca8bda64a7a5ed9b16f6302bb692d59.zip
Revert recent strfile changes, strfile is already in base
With hat: portmgr
Diffstat (limited to 'polish')
-rw-r--r--polish/fortunepl/Makefile20
1 files changed, 10 insertions, 10 deletions
diff --git a/polish/fortunepl/Makefile b/polish/fortunepl/Makefile
index d3c50c551abd..0798bd66c878 100644
--- a/polish/fortunepl/Makefile
+++ b/polish/fortunepl/Makefile
@@ -14,11 +14,13 @@ PATCHFILES= fortunes-pl_${PORTVERSION}.freebsd.pl \
MAINTAINER= ports@FreeBSD.org
COMMENT= Lot of funny Polish fortune files
-BROKEN= unfetchable
-
-BUILD_DEPENDS= fortune_strfile:misc/fortune_strfile
-STRCMD= ${LOCALBASE}/bin/fortune_strfile
-
+.if exists(/usr/games/strfile)
+STRCMD= /usr/games/strfile
+.elif exists(/usr/bin/strfile)
+STRCMD= /usr/bin/strfile
+.else
+IGNORE= needs strfile command. Please install games distribution of base system
+.endif
WRKSRC= ${WRKDIR}/fortunes-pl-${PORTVERSION}.orig
FORTUNES= 7thguard advocacy apcoh argante bajki bok cnp cows \
@@ -33,14 +35,12 @@ FORTUNES= 7thguard advocacy apcoh argante bajki bok cnp cows \
znaki_zodiaku
do-patch:
- ${CP} ${DISTDIR}/fortunes-pl_${PORTVERSION}.freebsd.pl \
- ${WRKSRC}/freebsd.pl
- ${CP} ${DISTDIR}/fortunes-pl_${PORTVERSION}.filozofia \
- ${WRKSRC}/filozofia
+ ${CP} ${DISTDIR}/fortunes-pl_${PORTVERSION}.freebsd.pl ${WRKSRC}/freebsd.pl
+ ${CP} ${DISTDIR}/fortunes-pl_${PORTVERSION}.filozofia ${WRKSRC}/filozofia
do-build:
.for FILE in ${FORTUNES}
- ${STRCMD} ${WRKSRC}/${FILE}
+ @${STRCMD} ${WRKSRC}/${FILE}
.endfor
do-install: