aboutsummaryrefslogtreecommitdiffstats
path: root/polish
diff options
context:
space:
mode:
authorpawel <pawel@FreeBSD.org>2012-01-06 23:27:25 +0800
committerpawel <pawel@FreeBSD.org>2012-01-06 23:27:25 +0800
commit07ddbb77bf22f7d761896948f7669e222def38d4 (patch)
tree082d867893d6b0e0eee4a5bc9b97d6321e2b9dfc /polish
parent91be4d4ce782d7e2e6132fdb7c70b68701f3d8df (diff)
downloadfreebsd-ports-gnome-07ddbb77bf22f7d761896948f7669e222def38d4.tar.gz
freebsd-ports-gnome-07ddbb77bf22f7d761896948f7669e222def38d4.tar.zst
freebsd-ports-gnome-07ddbb77bf22f7d761896948f7669e222def38d4.zip
- Add UNICODE option (default off) which enables experimental unicode support
- Don't link to libidn when found on system - Switch to bsd.port.options.mk
Diffstat (limited to 'polish')
-rw-r--r--polish/ekg2/Makefile20
-rw-r--r--polish/ekg2/files/patch-configure12
2 files changed, 16 insertions, 16 deletions
diff --git a/polish/ekg2/Makefile b/polish/ekg2/Makefile
index c894e56447c4..1e94e4db4234 100644
--- a/polish/ekg2/Makefile
+++ b/polish/ekg2/Makefile
@@ -6,6 +6,7 @@
PORTNAME= ekg2
PORTVERSION= 0.3.1
+PORTREVISION= 1
PORTEPOCH= 1
CATEGORIES= polish net-im
MASTER_SITES= http://pl.ekg2.org/
@@ -31,6 +32,7 @@ OPTIONS= ASPELL "Enable spell checking support" on \
PERL "Enable perl plugin" off \
PYTHON "Enable python plugin" off \
SQLITE "Enable sqlite plugin" off \
+ UNICODE "Enable unicode (experimental)" off \
XOSD "Enable xosd plugin" off
CONFIGURE_ARGS+= --enable-shared \
@@ -42,12 +44,13 @@ CONFIGURE_ARGS+= --enable-shared \
--with-libgadu \
--without-libgnutls \
--without-gif \
- --without-libjpeg
+ --without-libjpeg \
+ --without-libidn
LDFLAGS+= -L${LOCALBASE}/lib -lintl ${PTHREAD_LIBS}
CFLAGS+= -I${LOCALBASE}/include
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
.if defined(WITH_ASPELL)
LIB_DEPENDS+= aspell:${PORTSDIR}/textproc/aspell
@@ -122,6 +125,10 @@ CONFIGURE_ARGS+= --without-sqlite3
PLIST_SUB+= SQLITE_PLUGIN="@comment "
.endif
+.if defined(WITH_UNICODE)
+CONFIGURE_ARGS+= --enable-unicode
+.endif
+
.if defined(WITH_XOSD)
LIB_DEPENDS+= xosd:${PORTSDIR}/misc/xosd
CONFIGURE_ARGS+= --with-libxosd
@@ -133,8 +140,13 @@ PLIST_SUB+= XOSD_PLUGIN="@comment "
post-patch:
.if defined(WITH_PYTHON)
- ${REINPLACE_CMD} -e 's|/usr/bin/python|${PYTHON_CMD}|' \
+ @${REINPLACE_CMD} -e 's|/usr/bin/python|${PYTHON_CMD}|' \
${WRKSRC}/contrib/python/notify-bubble.py
.endif
-.include <bsd.port.post.mk>
+.if defined(WITH_UNICODE)
+ @${REINPLACE_CMD} -e 's|ncursesw/||' ${WRKSRC}/configure \
+ ${WRKSRC}/plugins/ncurses/ecurses.h
+.endif
+
+.include <bsd.port.mk>
diff --git a/polish/ekg2/files/patch-configure b/polish/ekg2/files/patch-configure
deleted file mode 100644
index 614db1ed787d..000000000000
--- a/polish/ekg2/files/patch-configure
+++ /dev/null
@@ -1,12 +0,0 @@
---- configure.orig Wed Apr 4 19:49:22 2007
-+++ configure Wed Apr 4 19:49:26 2007
-@@ -1923,9 +1923,6 @@
-
-
-
--F77="no"
--CXX="no"
--
- ac_ext=c
- ac_cpp='$CPP $CPPFLAGS'
- ac_compile='$CC -c $CFLAGS $CPPFLAGS conftest.$ac_ext >&5'