aboutsummaryrefslogtreecommitdiffstats
path: root/polish
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2008-04-20 01:56:05 +0800
committermiwi <miwi@FreeBSD.org>2008-04-20 01:56:05 +0800
commitbce9b81f9d6099820f3839d7809d6b08c1d2ae7b (patch)
treef5dd7c3a8dbebad79bdb5e844aeb69c59a9fd12c /polish
parent2eea5f1d2e44418020f8f4db08d40bea6915b6e8 (diff)
downloadfreebsd-ports-gnome-bce9b81f9d6099820f3839d7809d6b08c1d2ae7b.tar.gz
freebsd-ports-gnome-bce9b81f9d6099820f3839d7809d6b08c1d2ae7b.tar.zst
freebsd-ports-gnome-bce9b81f9d6099820f3839d7809d6b08c1d2ae7b.zip
- Remove unneeded dependency from gtk12/gtk20 [1]
- Remove USE_XLIB/USE_X_PREFIX/USE_XPM in favor of USE_XORG - Remove X11BASE support in favor of LOCALBASE or PREFIX - Use USE_LDCONFIG instead of INSTALLS_SHLIB - Remove unneeded USE_GCC 3.4+ Thanks to all Helpers: Dmitry Marakasov, Chess Griffin, beech@, dinoex, rafan, gahr, ehaupt, nox, itetcu, flz, pav PR: 116263 Tested on: pointyhat Approved by: portmgr (pav)
Diffstat (limited to 'polish')
-rw-r--r--polish/gnugadu2/Makefile8
-rw-r--r--polish/kadu/Makefile4
-rw-r--r--polish/libtlen/Makefile2
-rw-r--r--polish/tleenx2/Makefile8
-rw-r--r--polish/tleenx2/files/patch-iksemel-Makefile2
5 files changed, 11 insertions, 13 deletions
diff --git a/polish/gnugadu2/Makefile b/polish/gnugadu2/Makefile
index a125881c1c40..2a0405c4ec70 100644
--- a/polish/gnugadu2/Makefile
+++ b/polish/gnugadu2/Makefile
@@ -7,10 +7,9 @@
PORTNAME= gnugadu2
PORTVERSION= 2.3.0
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= polish net-im
-MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
-MASTER_SITE_SUBDIR= ggadu
+MASTER_SITES= SF/ggadu
DISTNAME= gg2-${PORTVERSION}
MAINTAINER= smyru@heron.pl
@@ -48,8 +47,7 @@ CONFIGURE_ARGS= --disable-esdtest \
--without-remote
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
- LDFLAGS="-L${LOCALBASE}/lib" \
- CPPFLAGS="-I${X11BASE}/include"
+ LDFLAGS="-L${LOCALBASE}/lib"
OPTIONS= TLEN "Enable Tlen.pl network plugin" off \
JABBER "Enable Jabber loudmouth plugin" off \
diff --git a/polish/kadu/Makefile b/polish/kadu/Makefile
index 747b038dbe45..4f66f4369d94 100644
--- a/polish/kadu/Makefile
+++ b/polish/kadu/Makefile
@@ -36,8 +36,8 @@ USE_GMAKE= yes
USE_OPENSSL= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS+= --with-existing-libgadu="${LOCALBASE}" \
- --with-includes="${LOCALBASE}/include ${X11BASE}/include" \
- --with-libs="${LOCALBASE}/lib ${X11BASE}/lib" \
+ --with-includes="${LOCALBASE}/include" \
+ --with-libs="${LOCALBASE}/lib" \
--program-transform-name='' \
--disable-autodownload
CONFIGURE_ENV= QTDIR="${QT_PREFIX}"
diff --git a/polish/libtlen/Makefile b/polish/libtlen/Makefile
index 64f8c28fea1a..b2f140ca7da8 100644
--- a/polish/libtlen/Makefile
+++ b/polish/libtlen/Makefile
@@ -16,7 +16,7 @@ MAINTAINER= smyru@heron.pl
COMMENT= Backend for interoperability with Tlen.pl, Polish IM network
GNU_CONFIGURE= yes
-INSTALLS_SHLIB= yes
+USE_LDCONFIG= yes
.if !defined(NOPORTDOCS)
post-install:
diff --git a/polish/tleenx2/Makefile b/polish/tleenx2/Makefile
index 2fc01d444f74..b4d5017c4839 100644
--- a/polish/tleenx2/Makefile
+++ b/polish/tleenx2/Makefile
@@ -7,10 +7,9 @@
PORTNAME= tleenx2
PORTVERSION= 20040214
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= polish net
-MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
-MASTER_SITE_SUBDIR= tleenx
+MASTER_SITES= SF/leenx
DISTNAME= TleenX2-${PORTVERSION}
MAINTAINER= mkorzen@gmail.com
@@ -20,6 +19,7 @@ LIB_DEPENDS= tlen.1:${PORTSDIR}/polish/libtlen
USE_GNOME= gtk20
GNU_CONFIGURE= yes
+USE_XORG= xscrnsaver
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" LDFLAGS="-L${LOCALBASE}/lib"
WRKSRC= ${WRKDIR}/TleenX2-${PORTVERSION}
@@ -27,7 +27,7 @@ MAN1= tleenx2.1
PORTDOCS= README gg.txt sms.txt
post-patch:
- @${REINPLACE_CMD} -e 's,/usr/X11R6,${X11BASE},g' ${WRKSRC}/src/Makefile.in
+ @${REINPLACE_CMD} -e 's,/usr/X11R6,${LOCALBASE},g' ${WRKSRC}/src/Makefile.in
post-install:
.if !defined(NOPORTDOCS)
diff --git a/polish/tleenx2/files/patch-iksemel-Makefile b/polish/tleenx2/files/patch-iksemel-Makefile
index 5d1cb30495c5..ffb2d67ec3a8 100644
--- a/polish/tleenx2/files/patch-iksemel-Makefile
+++ b/polish/tleenx2/files/patch-iksemel-Makefile
@@ -5,7 +5,7 @@
CC = gcc
-CFLAGS = -g -Wall -L/usr/local/lib -I/usr/local/include
-+CFLAGS = -Wall -L$(LOCALBASE)/lib -I$(LOCALBASE)/include -L$(X11BASE)/lib -I$(X11BASE)/include
++CFLAGS = -Wall -L$(LOCALBASE)/lib -I$(LOCALBASE)/include
OBJS = convert.o iks.o ikspool.o jabber.o sha.o core.o iksid.o io.o parser.o \
utility.o
all: $(OBJS)