aboutsummaryrefslogtreecommitdiffstats
path: root/ports-mgmt/bpm
diff options
context:
space:
mode:
authorjylefort <jylefort@FreeBSD.org>2005-12-09 00:24:32 +0800
committerjylefort <jylefort@FreeBSD.org>2005-12-09 00:24:32 +0800
commite3cc432b3ce6015af8f4241286b611bd46bcde1f (patch)
treefef4079f79cbe3bbd93b0481f76e2739f5e41cdf /ports-mgmt/bpm
parent7c3497d2d4bec429880a0611c1c64ab07d25e024 (diff)
downloadfreebsd-ports-gnome-e3cc432b3ce6015af8f4241286b611bd46bcde1f.tar.gz
freebsd-ports-gnome-e3cc432b3ce6015af8f4241286b611bd46bcde1f.tar.zst
freebsd-ports-gnome-e3cc432b3ce6015af8f4241286b611bd46bcde1f.zip
Fix runtime failure by linking against libpthread (GnomeVFS needs
pthread, and bpm may use GnomeVFS via GtkFileChooser).
Diffstat (limited to 'ports-mgmt/bpm')
-rw-r--r--ports-mgmt/bpm/Makefile5
1 files changed, 4 insertions, 1 deletions
diff --git a/ports-mgmt/bpm/Makefile b/ports-mgmt/bpm/Makefile
index e1fe77bca462..ff50fec51a5c 100644
--- a/ports-mgmt/bpm/Makefile
+++ b/ports-mgmt/bpm/Makefile
@@ -7,7 +7,7 @@
PORTNAME= bpm
PORTVERSION= 0.4.1b
-PORTREVISION= 7
+PORTREVISION= 8
CATEGORIES= sysutils
MASTER_SITES= http://www.meowfishies.com/code/bpm/
EXTRACT_SUFX= .tgz
@@ -26,5 +26,8 @@ MAKE_ENV+= OSTYPE="${OPSYS}"
post-patch:
@${FIND} ${WRKSRC} -name Makefile | ${XARGS} \
${REINPLACE_CMD} -e "s|-lintl|-lintl -L${LOCALBASE}/lib|g"
+# GnomeVFS needs pthread; bpm may use GnomeVFS (via GtkFileChooser)
+ @${REINPLACE_CMD} -e 's|^CFLAGS+=|& ${PTHREAD_CFLAGS}|; \
+ s|^LDLIBS+=|& ${PTHREAD_LIBS}|' ${WRKSRC}/src/Makefile
.include <bsd.port.mk>