aboutsummaryrefslogtreecommitdiffstats
path: root/ports-mgmt/pkg
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2012-06-04 03:02:27 +0800
committerbapt <bapt@FreeBSD.org>2012-06-04 03:02:27 +0800
commita54bf23340d7294e8a1ff62c53742420483cfac6 (patch)
treee01a4bdf544347c876f39ac3f39471da757296ab /ports-mgmt/pkg
parent404274a28f6c6b1af28c9e4bb174123c3407a302 (diff)
downloadfreebsd-ports-gnome-a54bf23340d7294e8a1ff62c53742420483cfac6.tar.gz
freebsd-ports-gnome-a54bf23340d7294e8a1ff62c53742420483cfac6.tar.zst
freebsd-ports-gnome-a54bf23340d7294e8a1ff62c53742420483cfac6.zip
Backout reproducible packages.
pkgng tried since beta14 to create reproducible package: aka 1 package build twice will get exactly the same checksums, this revealed some problem with python that were workaround in beta15 but lots of build system seems to really not approciate it, while the feature is good and might be reactivated in the futur, the ports tree and upstream build systems, need a lot of work to be able~ to deal with 100% reproducible packages :(
Diffstat (limited to 'ports-mgmt/pkg')
-rw-r--r--ports-mgmt/pkg/Makefile3
-rw-r--r--ports-mgmt/pkg/files/patch-libpkg__packing.c31
2 files changed, 33 insertions, 1 deletions
diff --git a/ports-mgmt/pkg/Makefile b/ports-mgmt/pkg/Makefile
index 85f06a7a955b..75158f88c465 100644
--- a/ports-mgmt/pkg/Makefile
+++ b/ports-mgmt/pkg/Makefile
@@ -7,7 +7,7 @@
PORTNAME= pkg
DISTVERSION= 1.0-beta15
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= ports-mgmt
MASTER_SITES= LOCAL/portmgr \
http://files.etoilebsd.net/pkg/
@@ -51,6 +51,7 @@ MAN8= pkg.8 \
pkg-which.8
MLINKS= pkg-delete.8 pkg-remove.8
MAN5= pkg.conf.5
+MLINKS= pkg-delete.8 pkg-remove.8
.include <bsd.port.pre.mk>
diff --git a/ports-mgmt/pkg/files/patch-libpkg__packing.c b/ports-mgmt/pkg/files/patch-libpkg__packing.c
new file mode 100644
index 000000000000..9faa9886f2d8
--- /dev/null
+++ b/ports-mgmt/pkg/files/patch-libpkg__packing.c
@@ -0,0 +1,31 @@
+--- ./libpkg/packing.c.orig 2012-06-03 16:28:53.000000000 +0200
++++ ./libpkg/packing.c 2012-06-03 20:55:42.669538609 +0200
+@@ -133,8 +133,8 @@
+ struct stat st;
+ struct archive_entry *entry, *sparse_entry;
+ /* ugly hack for python and emacs */
+- char *p;
+- bool unset_timestamp = true;
++ /*char *p;
++ bool unset_timestamp = true;*/
+
+ entry = archive_entry_new();
+ archive_entry_copy_sourcepath(entry, filepath);
+@@ -171,7 +171,7 @@
+ archive_entry_set_perm(entry, perm);
+
+ /* XXX ugly hack for python and emacs */
+- p = strrchr(filepath, '.');
++ /*p = strrchr(filepath, '.');
+
+ if (p != NULL && (strcmp(p, ".pyc") == 0 ||
+ strcmp(p, ".py") == 0 ||
+@@ -186,7 +186,7 @@
+ archive_entry_unset_ctime(entry);
+ archive_entry_unset_mtime(entry);
+ archive_entry_unset_birthtime(entry);
+- }
++ }*/
+
+ archive_entry_linkify(pack->resolver, &entry, &sparse_entry);
+