aboutsummaryrefslogtreecommitdiffstats
path: root/ports-mgmt/pkg
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2014-07-23 22:22:09 +0800
committerbapt <bapt@FreeBSD.org>2014-07-23 22:22:09 +0800
commitc683a6f0327ee89a491ba1a0b4ab80325e2ad68a (patch)
tree4b15d25b323725a7816c5fc28d56de58c0d70b3a /ports-mgmt/pkg
parent11ebf42e53b87a6d96d040708dd5596c139d81ed (diff)
downloadfreebsd-ports-gnome-c683a6f0327ee89a491ba1a0b4ab80325e2ad68a.tar.gz
freebsd-ports-gnome-c683a6f0327ee89a491ba1a0b4ab80325e2ad68a.tar.zst
freebsd-ports-gnome-c683a6f0327ee89a491ba1a0b4ab80325e2ad68a.zip
Update to 1.3.0
Since pkg 1.2: - 373 files changed, 66973 insertions(+), 38512 deletions(-) - 29 differents contributors - Merge of one of the 2013 Summer of code project Changelog: - New solver that can support external solvers using the CUDF format and the internal SAT solver - pkg-ssh(8) is now sandboxed with capsicum if it is available - pkg-ssh(8) now uses poll(2) - Remove StringList usage to improve portability - Rework the build system to use autotools to help portability - Now fetching is done to a temporary location and cleaned up if it fails - Remove PACKAGESITE - pkg-audit: remove support for portaudit compact database (only VulnXML will be used) - Improved UI experience based on jmmv write up (http://julipedia.meroh.net/search/label/cli-design) - Reworking the database locking mechanism into a finer grain and more clever system - Dynamic conflict handling if a conflict on files is detected at the sanity check level, try to solve the problem again with the new conflict information - Fix %t (timestamp) modifier in pkg_printf(3) - Full output now has a new field "date installed" - New pkg -o A=B to overwrite configuration from command line without the need of defining environment variables - pkg-install now can handle local files - pkg-add is now an alias on pkg-install - Simplify API by using more and more libucl objects (hidden behind an opaque 'pkg_object') - Rework multirepository handling - Prepare code for repository abstraction support - Sandbox signature checking and extraction - Support long options - Rework the extraction process - unicity of a package is now origin~name allowing subpackages and flavours - Improve ui for all commands - pkg lock -l now list the locked packages - symlinks now has a checksum to ensure they are valid - pkg backups generated by the distributed script are now plain sql files - Tons of bugfixes - Tons of behavour fixes
Diffstat (limited to 'ports-mgmt/pkg')
-rw-r--r--ports-mgmt/pkg/Makefile21
-rw-r--r--ports-mgmt/pkg/distinfo4
-rw-r--r--ports-mgmt/pkg/files/extra-patch-docs_pkg.8 (renamed from ports-mgmt/pkg/files/extra-patch-pkg_pkg.8)10
-rw-r--r--ports-mgmt/pkg/files/patch-libpkg__pkg_elf.c25
-rw-r--r--ports-mgmt/pkg/files/patch-libpkg__pkg_ports.c18
-rw-r--r--ports-mgmt/pkg/files/patch-rquery-I43
-rw-r--r--ports-mgmt/pkg/files/patch-scripts__periodic__Makefile18
-rw-r--r--ports-mgmt/pkg/files/patch-versionscript234
-rw-r--r--ports-mgmt/pkg/pkg-plist6
9 files changed, 19 insertions, 360 deletions
diff --git a/ports-mgmt/pkg/Makefile b/ports-mgmt/pkg/Makefile
index 300a18f52367..0e8821a4ac02 100644
--- a/ports-mgmt/pkg/Makefile
+++ b/ports-mgmt/pkg/Makefile
@@ -1,8 +1,7 @@
# $FreeBSD$
PORTNAME= pkg
-DISTVERSION= 1.2.7
-PORTREVISION= 4
+DISTVERSION= 1.3.0
CATEGORIES= ports-mgmt
MASTER_SITES= \
http://files.etoilebsd.net/${PORTNAME}/ \
@@ -20,17 +19,16 @@ USES= tar:xz uidfix
# With no dependency at all
NO_CCACHE= yes
USE_LDCONFIG= yes
-MAKE_ARGS+= PKG_PORTSDIR=${PORTSDIR}
-
-MAKE_ENV+= WITHOUT_PROFILE=yes __MAKE_CONF=/dev/null SRCCONF=/dev/null \
- PORTREVISION=${PORTREVISION} NO_PIE=yes
+USES= libtool tar:xz
+GNU_CONFIGURE= yes
+INSTALL_TARGET= install-strip
# Use a submake as 'deinstall install' needs to reevaluate PKG_CMD
# so that pkg-static is used from the wrkdir
USE_SUBMAKE= yes
.if !exists(/usr/include/jail.h)
-EXTRA_PATCHES= ${FILESDIR}/extra-patch-pkg_pkg.8
+EXTRA_PATCHES= ${FILESDIR}/extra-patch-docs_pkg.8
.endif
.include <bsd.port.pre.mk>
@@ -81,15 +79,12 @@ pre-everything::
PKG_DEPENDS=
.undef INSTALLS_DEPENDS
.if !exists(${LOCALBASE}/sbin/pkg)
-PKG_BIN= ${WRKSRC}/pkg/pkg-static
+PKG_BIN= ${WRKSRC}/src/pkg-static
.endif
.endif
-PERIODIC_DAILY= 400.status-pkg 411.pkg-backup 490.status-pkg-changes
-PERIODIC_SECURITY= 410.pkg-audit 460.pkg-checksum
-PERIODIC_ALL= ${PERIODIC_DAILY} ${PERIODIC_SECURITY}
-
post-install:
- @${INSTALL_DATA} ${WRKSRC}/pkg/pkg.conf.sample ${STAGEDIR}${PREFIX}/etc
+ @${MV} ${STAGEDIR}${PREFIX}/lib/libpkg_static.a \
+ ${STAGEDIR}${PREFIX}/lib/libpkg.a
.include <bsd.port.post.mk>
diff --git a/ports-mgmt/pkg/distinfo b/ports-mgmt/pkg/distinfo
index aca1a06a3523..5b432e0c700a 100644
--- a/ports-mgmt/pkg/distinfo
+++ b/ports-mgmt/pkg/distinfo
@@ -1,2 +1,2 @@
-SHA256 (pkg-1.2.7.tar.xz) = 450f51a4c6e3d05fac9b0e408e5dfe252ac87abe72481a5b4711f077178ba4c1
-SIZE (pkg-1.2.7.tar.xz) = 1822868
+SHA256 (pkg-1.3.0.tar.xz) = 6d3001cdd605e6e3c15e686370cbeea999a5f19e72fd7f26e8af92ed2e2c2a01
+SIZE (pkg-1.3.0.tar.xz) = 1729104
diff --git a/ports-mgmt/pkg/files/extra-patch-pkg_pkg.8 b/ports-mgmt/pkg/files/extra-patch-docs_pkg.8
index a6f077b2449b..ff2223629745 100644
--- a/ports-mgmt/pkg/files/extra-patch-pkg_pkg.8
+++ b/ports-mgmt/pkg/files/extra-patch-docs_pkg.8
@@ -1,5 +1,5 @@
---- pkg/pkg.8.orig 2013-11-27 18:14:50.000000000 +0000
-+++ pkg/pkg.8
+--- docs/pkg.8.orig 2014-06-19 12:43:52.000000000 +0000
++++ docs/pkg.8
@@ -30,7 +30,7 @@
.Op Fl d
.Op Fl l
@@ -9,11 +9,11 @@
.Op Fl C Ao configuration file Ac
.Op Fl R Ao repository configuration directory Ac
.Ao command Ac Ao Ar flags Ac
-@@ -129,22 +129,6 @@ is installed and activated:
+@@ -146,22 +146,6 @@ is installed and activated:
# pkg_install-specifics
fi
.Ed
--.It Fl j Ao jail name or id Ac
+-.It Fl j Ao jail name or id Ac , Cm --jail Ao jail name or id Ac
-.Nm
-will execute in the given
-.Ao jail name or id Ac ,
@@ -29,6 +29,6 @@
-.Xr jail 8
-and
-.Xr jls 8 .
- .It Fl c Ao chroot path Ac
+ .It Fl c Ao chroot path Ac , Cm --chroot Ao chroot path Ac
.Nm
will chroot in the
diff --git a/ports-mgmt/pkg/files/patch-libpkg__pkg_elf.c b/ports-mgmt/pkg/files/patch-libpkg__pkg_elf.c
deleted file mode 100644
index 8eaa598a03de..000000000000
--- a/ports-mgmt/pkg/files/patch-libpkg__pkg_elf.c
+++ /dev/null
@@ -1,25 +0,0 @@
-diff --git a/libpkg/pkg_elf.c b/libpkg/pkg_elf.c
-index 7c75606..165b65d 100644
---- libpkg/pkg_elf.c
-+++ libpkg/pkg_elf.c
-@@ -636,6 +636,11 @@
- int ret = EPKG_OK;
- int i;
- const char *arch, *abi, *endian_corres_str, *wordsize_corres_str, *fpu;
-+ const char *path;
-+
-+ path = getenv("ABI_FILE");
-+ if (path == NULL)
-+ path = _PATH_BSHELL;
-
- if (elf_version(EV_CURRENT) == EV_NONE) {
- pkg_emit_error("ELF library initialization failed: %s",
-@@ -643,7 +648,7 @@
- return (EPKG_FATAL);
- }
-
-- if ((fd = open(_PATH_BSHELL, O_RDONLY)) < 0) {
-+ if ((fd = open(path, O_RDONLY)) < 0) {
- pkg_emit_errno("open", _PATH_BSHELL);
- snprintf(dest, sz, "%s", "unknown");
- return (EPKG_FATAL);
diff --git a/ports-mgmt/pkg/files/patch-libpkg__pkg_ports.c b/ports-mgmt/pkg/files/patch-libpkg__pkg_ports.c
deleted file mode 100644
index bd6538c46bc4..000000000000
--- a/ports-mgmt/pkg/files/patch-libpkg__pkg_ports.c
+++ /dev/null
@@ -1,18 +0,0 @@
---- ./libpkg/pkg_ports.c.orig 2014-03-15 13:15:46.000000000 +0000
-+++ ./libpkg/pkg_ports.c 2014-04-01 18:20:02.000000000 +0000
-@@ -318,9 +318,14 @@
- buf = NULL;
- regular = false;
-
-- if (S_ISREG(st.st_mode))
-+ if (S_ISDIR(st.st_mode)) {
-+ pkg_emit_error("Plist error, directory listed as a file: %s", line);
-+ free_file_attr(a);
-+ return (EPKG_FATAL);
-+ } else if (S_ISREG(st.st_mode))
- regular = true;
-
-+
- /* special case for hardlinks */
- if (st.st_nlink > 1)
- regular = is_hardlink(p->hardlinks, &st);
diff --git a/ports-mgmt/pkg/files/patch-rquery-I b/ports-mgmt/pkg/files/patch-rquery-I
deleted file mode 100644
index 08a96723e308..000000000000
--- a/ports-mgmt/pkg/files/patch-rquery-I
+++ /dev/null
@@ -1,43 +0,0 @@
-diff --git pkg/rquery.c pkg/rquery.c
-index 7ce40f7..f967a34 100644
---- pkg/rquery.c
-+++ pkg/rquery.c
-@@ -84,13 +84,23 @@ print_index(struct pkg *pkg)
- #ifndef PORTSDIR
- #define PORTSDIR "/usr/ports"
- #endif
-- struct pkg_category *cat = NULL;
-
-- pkg_printf("%n-%v|" PORTSDIR "/%o|%p|%c|" PORTSDIR "/%o/pkg-descr|%m|",
-- pkg, pkg, pkg, pkg, pkg, pkg, pkg);
-- while (pkg_categories(pkg, &cat) == EPKG_OK)
-- pkg_printf("%Cn ", cat);
-- printf("\n");
-+ pkg_printf(
-+ "%n-%v|" /* PKGNAME */
-+ "%S/%o|" /* PORTDIR */
-+ "%p|" /* PREFIX */
-+ "%c|" /* COMMENT */
-+ "%S/%o/pkg-descr|" /* _DESCR */
-+ "%m|" /* MAINTAINER */
-+ "%C%{%Cn%| %}|" /* CATEGORIES */
-+ "|" /* BUILD_DEPENDS */
-+ "%d%{%dn-%dv%| %}|" /* RUN_DEPENDS */
-+ "%w|" /* WWW */
-+ "|" /* EXTRACT_DEPENDS */
-+ "|" /* PATCH_DEPENDS */
-+ "\n", /* FETCH_DEPENDS */
-+ pkg, pkg, PORTSDIR, pkg, pkg, pkg, PORTSDIR, pkg, pkg, pkg, pkg,
-+ pkg);
- }
-
- int
-@@ -201,7 +211,7 @@ exec_rquery(int argc, char **argv)
- return (EX_IOERR);
-
- if (index_output)
-- query_flags = PKG_LOAD_BASIC|PKG_LOAD_CATEGORIES;
-+ query_flags = PKG_LOAD_BASIC|PKG_LOAD_CATEGORIES|PKG_LOAD_DEPS;
-
- if (match == MATCH_ALL || match == MATCH_CONDITION) {
- const char *condition_sql = NULL;
diff --git a/ports-mgmt/pkg/files/patch-scripts__periodic__Makefile b/ports-mgmt/pkg/files/patch-scripts__periodic__Makefile
deleted file mode 100644
index 3b0ea9c87675..000000000000
--- a/ports-mgmt/pkg/files/patch-scripts__periodic__Makefile
+++ /dev/null
@@ -1,18 +0,0 @@
---- ./scripts/periodic/Makefile.orig 2014-03-15 13:15:46.000000000 +0000
-+++ ./scripts/periodic/Makefile 2014-05-29 06:02:03.000000000 +0000
-@@ -16,14 +16,11 @@
-
- all: ${SCRIPTS}
-
--# tell bmake we use the old :L :U modifiers
--.MAKE.FreeBSD_UL= yes
--
- install: all
- .for period in daily weekly security
-
- install -d ${DESTDIR}${PREFIX}/etc/periodic/${period}
--. for periodic in ${SCRIPTS_${period:U}:R}
-+. for periodic in ${SCRIPTS_${period:tu}:R}
- install -m 555 ${periodic} ${DESTDIR}${PREFIX}/etc/periodic/${period}
- . endfor
- .endfor
diff --git a/ports-mgmt/pkg/files/patch-versionscript b/ports-mgmt/pkg/files/patch-versionscript
deleted file mode 100644
index 54b081824046..000000000000
--- a/ports-mgmt/pkg/files/patch-versionscript
+++ /dev/null
@@ -1,234 +0,0 @@
-diff --git a/libpkg/Makefile b/libpkg/Makefile
-index 5c1fa56..ddb88f3 100644
---- libpkg/Makefile
-+++ libpkg/Makefile
-@@ -299,6 +299,8 @@ LDADD+= -larchive \
- LDADD+= -ledit
- .endif
-
-+LDADD+= -Wl,--version-script=${.CURDIR}/libpkg.ver
-+
- .if defined(DEBUG_FLAGS)
- .if ${DEBUG_FLAGS} == 1
- DEBUG_FLAGS= -ggdb -O0
-diff --git a/libpkg/libpkg.ver b/libpkg/libpkg.ver
-new file mode 100644
-index 0000000..ca489a5
---- /dev/null
-+++ libpkg/libpkg.ver
-@@ -0,0 +1,215 @@
-+LIBPKG_1.2 {
-+global:
-+ pkg_status;
-+ pkg_new;
-+ pkg_reset;
-+ pkg_free;
-+ pkg_is_valid;
-+ pkg_open;
-+ pkg_type;
-+ pkg_get2;
-+ pkg_list_count;
-+ pkg_deps;
-+ pkg_dep_lookup;
-+ pkg_rdeps;
-+ pkg_files;
-+ pkg_dirs;
-+ pkg_categories;
-+ pkg_licenses;
-+ pkg_users;
-+ pkg_groups;
-+ pkg_options;
-+ pkg_shlibs_required;
-+ pkg_shlibs_provided;
-+ pkg_annotations;
-+ pkg_annotation_lookup;
-+ pkg_analyse_files;
-+ pkg_suggest_arch;
-+ pkg_set2;
-+ pkgdb_set2;
-+ pkgdb_file_set_cksum;
-+ pkg_set_from_file;
-+ pkg_adddep;
-+ pkg_addrdep;
-+ pkg_addfile;
-+ pkg_addfile_attr;
-+ pkg_adddir;
-+ pkg_adddir_attr;
-+ pkg_addcategory;
-+ pkg_addlicense;
-+ pkg_adduser;
-+ pkg_addgroup;
-+ pkg_adduid;
-+ pkg_addgid;
-+ pkg_addscript;
-+ pkg_addscript_file;
-+ pkg_appendscript;
-+ pkg_addoption;
-+ pkg_addoption_default;
-+ pkg_addoption_description;
-+ pkg_addshlib_provided;
-+ pkg_addshlib_required;
-+ pkg_addannotation;
-+ pkg_delannotation;
-+ pkg_parse_manifest;
-+ pkg_parse_manifest_file;
-+ pkg_manifest_keys_new;
-+ pkg_manifest_keys_free;
-+ pkg_manifest_parser_new;
-+ pkg_manifest_parser_free;
-+ pkg_emit_manifest;
-+ pkg_emit_manifest_file;
-+ pkg_dep_get;
-+ pkg_dep_is_locked;
-+ pkg_file_get;
-+ pkg_file_mode;
-+ pkg_file_keep;
-+ pkg_has_dir;
-+ pkg_has_file;
-+ pkg_dir_get;
-+ pkg_dir_mode;
-+ pkg_dir_keep;
-+ pkg_dir_try;
-+ pkg_category_name;
-+ pkg_license_name;
-+ pkg_user_name;
-+ pkg_user_uidstr;
-+ pkg_group_name;
-+ pkg_group_gidstr;
-+ pkg_script_get;
-+ pkg_option_opt;
-+ pkg_option_value;
-+ pkg_option_default_value;
-+ pkg_option_description;
-+ pkg_shlib_name;
-+ pkg_annotation_tag;
-+ pkg_annotation_value;
-+ pkg_try_installed;
-+ pkg_is_installed;
-+ pkg_create_repo;
-+ pkg_finish_repo;
-+ pkgdb_access;
-+ pkgdb_open;
-+ pkgdb_close;
-+ pkgdb_remote_init;
-+ pkgdb_dump;
-+ pkgdb_load;
-+ pkgdb_register_ports;
-+ pkgdb_unregister_pkg;
-+ pkgdb_set_case_sensitivity;
-+ pkgdb_query;
-+ pkgdb_rquery;
-+ pkgdb_search;
-+ pkgdb_query_which;
-+ pkgdb_query_shlib_required;
-+ pkgdb_query_shlib_provided;
-+ pkgdb_add_annotation;
-+ pkgdb_modify_annotation;
-+ pkgdb_delete_annotation;
-+ pkgdb_it_next;
-+ pkgdb_it_reset;
-+ pkgdb_it_free;
-+ pkgdb_compact;
-+ pkg_add;
-+ pkg_jobs_new;
-+ pkg_jobs_free;
-+ pkg_jobs_add;
-+ pkg_jobs_solve;
-+ pkg_jobs_find;
-+ pkg_jobs_set_repository;
-+ pkg_jobs_set_flags;
-+ pkg_jobs_type;
-+ pkg_jobs_count;
-+ pkg_jobs;
-+ pkg_jobs_apply;
-+ pkg_create_installed;
-+ pkg_create_staged;
-+ pkg_update;
-+ pkg_plugins_init;
-+ pkg_plugins_shutdown;
-+ pkg_plugins;
-+ pkg_plugin_set;
-+ pkg_plugin_get;
-+ pkg_plugin_func;
-+ pkg_plugin_conf_add_string;
-+ pkg_plugin_conf_add_bool;
-+ pkg_plugin_conf_add_integer;
-+ pkg_plugin_conf_add_kvlist;
-+ pkg_plugin_conf_add_list;
-+ pkg_plugin_conf_string;
-+ pkg_plugin_conf_bool;
-+ pkg_plugin_conf_kvlist;
-+ pkg_plugin_conf_list;
-+ pkg_plugin_conf_integer;
-+ pkg_plugin_confs;
-+ pkg_plugin_parse;
-+ pkg_plugin_errno;
-+ pkg_plugin_error;
-+ pkg_plugin_info;
-+ pkg_plugins_hook_run;
-+ pkg_plugin_hook_register;
-+ pkg_config_desc;
-+ pkg_config_string;
-+ pkg_config_bool;
-+ pkg_config_kvlist;
-+ pkg_config_list;
-+ pkg_config_kv_get;
-+ pkg_config_value;
-+ pkg_config_int64;
-+ pkg_configs;
-+ pkg_config_id;
-+ pkg_config_type;
-+ pkg_config_name;
-+ pkg_config_lookup;
-+ pkg_version_cmp;
-+ pkg_version_change;
-+ pkg_fetch_file;
-+ ports_parse_plist;
-+ pkg_copy_tree;
-+ pkg_event_register;
-+ pkg_init;
-+ pkg_initialized;
-+ pkg_shutdown;
-+ pkg_test_filesum;
-+ pkg_recompute;
-+ pkgdb_reanalyse_shlibs;
-+ pkg_get_myarch;
-+ pkgdb_cmd;
-+ pkg_old_load_from_path;
-+ pkg_old_emit_content;
-+ pkg_from_old;
-+ pkg_to_old;
-+ pkg_register_old;
-+ pkg_sshserve;
-+ pkg_repos_total_count;
-+ pkg_repos_activated_count;
-+ pkg_repos;
-+ pkg_repo_url;
-+ pkg_repo_ident;
-+ pkg_repo_name;
-+ pkg_repo_ident_from_name;
-+ pkg_repo_key;
-+ pkg_repo_fingerprints;
-+ pkg_repo_signature_type;
-+ pkg_repo_enabled;
-+ pkg_repo_mirror_type;
-+ pkg_repo_find_ident;
-+ pkg_repo_find_name;
-+ pkg_printf;
-+ pkg_vprintf;
-+ pkg_fprintf;
-+ pkg_vfprintf;
-+ pkg_dprintf;
-+ pkg_vdprintf;
-+ pkg_snprintf;
-+ pkg_vsnprintf;
-+ pkg_asprintf;
-+ pkg_vasprintf;
-+ pkg_sbuf_printf;
-+ pkg_sbuf_vprintf;
-+ pkg_has_message;
-+ pkg_is_locked;
-+ pkgdb_stats;
-+local:
-+ *;
-+};
diff --git a/ports-mgmt/pkg/pkg-plist b/ports-mgmt/pkg/pkg-plist
index 4d16760e754f..b99c167584c4 100644
--- a/ports-mgmt/pkg/pkg-plist
+++ b/ports-mgmt/pkg/pkg-plist
@@ -8,7 +8,8 @@ etc/pkg.conf.sample
include/pkg.h
lib/libpkg.a
lib/libpkg.so
-lib/libpkg.so.1
+lib/libpkg.so.3
+lib/libpkg.so.3.0.0
libdata/pkgconfig/pkg.pc
man/man3/pkg_printf.3.gz
man/man3/pkg_repos.3.gz
@@ -38,6 +39,7 @@ man/man8/pkg-search.8.gz
man/man8/pkg-set.8.gz
man/man8/pkg-shell.8.gz
man/man8/pkg-shlib.8.gz
+man/man8/pkg-ssh.8.gz
man/man8/pkg-static.8.gz
man/man8/pkg-stats.8.gz
man/man8/pkg-unlock.8.gz
@@ -50,7 +52,7 @@ man/man8/pkg.8.gz
sbin/pkg
sbin/pkg-static
sbin/pkg2ng
-share/zsh/site-functions/_pkg
+share/zsh/site-functions/_pkg.zsh
@dirrmtry etc/bash_completion.d
@dirrmtry etc/periodic/daily
@dirrmtry etc/periodic/security