aboutsummaryrefslogtreecommitdiffstats
path: root/ports-mgmt/pkgsearch
diff options
context:
space:
mode:
authoredwin <edwin@FreeBSD.org>2007-09-27 08:33:40 +0800
committeredwin <edwin@FreeBSD.org>2007-09-27 08:33:40 +0800
commit681fc24d85fb2254be9e39ba9020072c0ca9d604 (patch)
treec78ba014a1312abc8ab3bb1ac9999daacb7e3ffd /ports-mgmt/pkgsearch
parent97d429ae850820d87496a27540fec5e3f168f6a3 (diff)
downloadfreebsd-ports-gnome-681fc24d85fb2254be9e39ba9020072c0ca9d604.tar.gz
freebsd-ports-gnome-681fc24d85fb2254be9e39ba9020072c0ca9d604.tar.zst
freebsd-ports-gnome-681fc24d85fb2254be9e39ba9020072c0ca9d604.zip
[NEW PORT]sysutils/pkgsearch : find your packages
pkgsearch find packages in ports in any place from your computer , and find also packages installeds in your system, pkgsearch use c++, boost and sqlite3 for search packages more fast and is compiled with cmake PR: ports/116404 Submitted by: "Diego Rocha" <diegorocha1987@gmail.com>
Diffstat (limited to 'ports-mgmt/pkgsearch')
-rw-r--r--ports-mgmt/pkgsearch/Makefile40
-rw-r--r--ports-mgmt/pkgsearch/distinfo3
-rw-r--r--ports-mgmt/pkgsearch/pkg-descr6
3 files changed, 49 insertions, 0 deletions
diff --git a/ports-mgmt/pkgsearch/Makefile b/ports-mgmt/pkgsearch/Makefile
new file mode 100644
index 000000000000..74a549f6dd90
--- /dev/null
+++ b/ports-mgmt/pkgsearch/Makefile
@@ -0,0 +1,40 @@
+# New ports collection makefile for: Diego_Rocha
+# Date created: 14 September 2007
+# Whom: Diego_Rocha
+#
+# $FreeBSD$
+#
+
+PORTNAME= pkgsearch
+PORTVERSION= 1.0.2
+CATEGORIES= ports-mgmt
+MASTER_SITES= http://dl.sharesource.org/${PORTNAME}/ \
+ http://andsux.homeip.net/~diego/stable/
+
+MAINTAINER= diegorocha1987@gmail.com
+COMMENT= Find your packages in ports and installeds packages
+
+BUILD_DEPENDS= cmake:${PORTSDIR}/devel/cmake
+LIB_DEPENDS= boost_filesystem:${PORTSDIR}/devel/boost
+
+USE_PGSQL= yes
+
+WRKSRC= ${WRKDIR}/${DISTNAME}-build
+PLIST_FILES= sbin/pkgsearch etc/pkgsearch/pkgsearch.conf
+
+MAN1= pkgsearch.1
+MAN5= pkgsearch.conf.5
+MANCOMPRESSED= yes
+
+post-extract:
+ ${MKDIR} ${WRKSRC}
+
+do-configure:
+ @${CP} ${WRKDIR}/${DISTNAME}/pkgsearch.* ${WRKSRC}
+ @cd ${WRKSRC}; \
+ ${LOCALBASE}/bin/cmake ${WRKDIR}/${DISTNAME}
+
+post-build:
+ @${GZIP_CMD} ${WRKDIR}/${DISTNAME}/pkgsearch.*
+
+.include <bsd.port.mk>
diff --git a/ports-mgmt/pkgsearch/distinfo b/ports-mgmt/pkgsearch/distinfo
new file mode 100644
index 000000000000..7de53b6c58e8
--- /dev/null
+++ b/ports-mgmt/pkgsearch/distinfo
@@ -0,0 +1,3 @@
+MD5 (pkgsearch-1.0.2.tar.gz) = 6c38ee191bf85b1f022f91a064af91c4
+SHA256 (pkgsearch-1.0.2.tar.gz) = 824426698c8a73d48f2c4729d3e9e5f0a323940be58bb3d3a6fd82ae36dd468c
+SIZE (pkgsearch-1.0.2.tar.gz) = 12716
diff --git a/ports-mgmt/pkgsearch/pkg-descr b/ports-mgmt/pkgsearch/pkg-descr
new file mode 100644
index 000000000000..9a37aee66490
--- /dev/null
+++ b/ports-mgmt/pkgsearch/pkg-descr
@@ -0,0 +1,6 @@
+pkgsearch find packages in ports, pkgsrc and others,
+in any place from your computer, and find also packages installed
+in your system ! pkgsearch use c++, boost and PostGreSQL for search
+packages more fast, and is compiled with cmake. enjoy ;)
+
+WWW: http://sharesource.org/project/pkgsearch