aboutsummaryrefslogtreecommitdiffstats
path: root/ports-mgmt/portdowngrade
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2011-09-24 06:26:39 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2011-09-24 06:26:39 +0800
commite61d6a701f43e8cec5a4ec8c9641daf5376441de (patch)
tree920c5861867d049fb1f1e03285110561450a4ac1 /ports-mgmt/portdowngrade
parent124c6dcab8f89a37ab971e5ad23a959bfaa97426 (diff)
downloadfreebsd-ports-gnome-e61d6a701f43e8cec5a4ec8c9641daf5376441de.tar.gz
freebsd-ports-gnome-e61d6a701f43e8cec5a4ec8c9641daf5376441de.tar.zst
freebsd-ports-gnome-e61d6a701f43e8cec5a4ec8c9641daf5376441de.zip
- Add LDFLAGS to CONFIGURE_ENV and MAKE_ENV (as it was done with LDFLAGS)
- Fix all ports that add {CPP,LD}FLAGS to *_ENV to modify flags instead PR: 157936 Submitted by: myself Exp-runs by: pav Approved by: pav
Diffstat (limited to 'ports-mgmt/portdowngrade')
-rw-r--r--ports-mgmt/portdowngrade/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/ports-mgmt/portdowngrade/Makefile b/ports-mgmt/portdowngrade/Makefile
index 59fda3bc7b8c..bda285aab145 100644
--- a/ports-mgmt/portdowngrade/Makefile
+++ b/ports-mgmt/portdowngrade/Makefile
@@ -18,8 +18,8 @@ LIB_DEPENDS= popt.0:${PORTSDIR}/devel/popt
POPT_INCLUDE= `pkg_info -xL ^popt | ${GREP} popt.h | ${SED} -e 's?/popt.h??'`
POPT_LIB= `pkg_info -xL ^popt | ${GREP} libpopt.a | ${SED} -e 's?/libpopt.a??'`
-CONFIGURE_ENV= CPPFLAGS="-I${POPT_INCLUDE}" \
- LIBS="-lpopt -L${POPT_LIB}"
+CONFIGURE_ENV= LIBS="-lpopt -L${POPT_LIB}"
+CPPFLAGS+= -I${POPT_INCLUDE}
.if defined(DEFAULT_CVS_SERVER)
CONFIGURE_ARGS+= --enable-default-server=${DEFAULT_CVS_SERVER}
.endif