aboutsummaryrefslogtreecommitdiffstats
path: root/ports-mgmt/portlint
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2006-08-07 06:36:45 +0800
committermarcus <marcus@FreeBSD.org>2006-08-07 06:36:45 +0800
commit6e28d09900a3e36be7aa574e61a96343c53b4fc0 (patch)
treefc030e1649b30029660a4e7761e466f289eb84d6 /ports-mgmt/portlint
parent9e38961e983c3835c8146af437c4576e04f0a4e4 (diff)
downloadfreebsd-ports-gnome-6e28d09900a3e36be7aa574e61a96343c53b4fc0.tar.gz
freebsd-ports-gnome-6e28d09900a3e36be7aa574e61a96343c53b4fc0.tar.zst
freebsd-ports-gnome-6e28d09900a3e36be7aa574e61a96343c53b4fc0.zip
Actually check to see if $seen_special is set before checking the number
of plist items.
Diffstat (limited to 'ports-mgmt/portlint')
-rw-r--r--ports-mgmt/portlint/Makefile1
-rw-r--r--ports-mgmt/portlint/src/portlint.pl4
2 files changed, 3 insertions, 2 deletions
diff --git a/ports-mgmt/portlint/Makefile b/ports-mgmt/portlint/Makefile
index 5e05cacc0934..9a004e19adbb 100644
--- a/ports-mgmt/portlint/Makefile
+++ b/ports-mgmt/portlint/Makefile
@@ -9,6 +9,7 @@
PORTNAME= portlint
PORTVERSION= 2.9.1
+PORTREVISION= 1
CATEGORIES= devel
MASTER_SITES= # none
DISTFILES= # none
diff --git a/ports-mgmt/portlint/src/portlint.pl b/ports-mgmt/portlint/src/portlint.pl
index c4c3ef8089cd..bbb03e8ce828 100644
--- a/ports-mgmt/portlint/src/portlint.pl
+++ b/ports-mgmt/portlint/src/portlint.pl
@@ -17,7 +17,7 @@
# OpenBSD and NetBSD will be accepted.
#
# $FreeBSD$
-# $MCom: portlint/portlint.pl,v 1.122 2006/08/06 21:42:40 marcus Exp $
+# $MCom: portlint/portlint.pl,v 1.123 2006/08/06 22:36:21 marcus Exp $
#
use vars qw/ $opt_a $opt_A $opt_b $opt_C $opt_c $opt_g $opt_h $opt_t $opt_v $opt_M $opt_N $opt_B $opt_V /;
@@ -882,7 +882,7 @@ sub checkplist {
}
}
- if ($item_count < $numpitems) {
+ if (!$seen_special && $item_count < $numpitems) {
&perror("WARN", $file, -1, "There are only $item_count items in the plist. Consider using PLIST_FILES instead of pkg-plist when installing less than $numpitems items.");
}