aboutsummaryrefslogtreecommitdiffstats
path: root/ports-mgmt/portlint
diff options
context:
space:
mode:
authoritojun <itojun@FreeBSD.org>1999-04-22 13:37:46 +0800
committeritojun <itojun@FreeBSD.org>1999-04-22 13:37:46 +0800
commitfc6a13311970e80e2fc9afa8670fa11dd75b6521 (patch)
tree582b95538dc9a6b14a9ba31782c97969d16251a3 /ports-mgmt/portlint
parent581045d7212cc82e8f0fbfdfa2c7e9214326547a (diff)
downloadfreebsd-ports-gnome-fc6a13311970e80e2fc9afa8670fa11dd75b6521.tar.gz
freebsd-ports-gnome-fc6a13311970e80e2fc9afa8670fa11dd75b6521.tar.zst
freebsd-ports-gnome-fc6a13311970e80e2fc9afa8670fa11dd75b6521.zip
remove the first comment lines in a section properly.
Diffstat (limited to 'ports-mgmt/portlint')
-rw-r--r--ports-mgmt/portlint/src/portlint.pl4
1 files changed, 3 insertions, 1 deletions
diff --git a/ports-mgmt/portlint/src/portlint.pl b/ports-mgmt/portlint/src/portlint.pl
index c257e4235d9e..fdeede98aa58 100644
--- a/ports-mgmt/portlint/src/portlint.pl
+++ b/ports-mgmt/portlint/src/portlint.pl
@@ -13,7 +13,7 @@
# bsd.port.mk. There are significant differences in those so you'll have
# hard time upgrading this...
#
-# $Id: portlint.pl,v 1.4 1999/04/02 03:24:13 steve Exp $
+# $Id: portlint.pl,v 1.5 1999/04/04 21:35:10 steve Exp $
#
$err = $warn = 0;
@@ -654,9 +654,11 @@ EOF
# for the rest of the checks, comment lines are not important.
#
for ($i = 0; $i < scalar(@sections); $i++) {
+ $sections[$i] = "\n" . $sections[$i];
$sections[$i] =~ s/\n#[^\n]*//g;
$sections[$i] =~ s/\n\n+/\n/g;
$sections[$i] =~ s/\\\n/ /g;
+ $sections[$i] =~ s/^\n//;
}
#