aboutsummaryrefslogtreecommitdiffstats
path: root/ports-mgmt/synth
diff options
context:
space:
mode:
authormarino <marino@FreeBSD.org>2016-02-13 05:56:58 +0800
committermarino <marino@FreeBSD.org>2016-02-13 05:56:58 +0800
commitadea58e0a3ae9d00d56ea9b2a1a18a6e7650f7fa (patch)
treefbd82cc0f6d2d1d64f870228215608aed9188fa4 /ports-mgmt/synth
parent1d76e66a418f55f92693ba80f7ac9edabd974cfb (diff)
downloadfreebsd-ports-gnome-adea58e0a3ae9d00d56ea9b2a1a18a6e7650f7fa.tar.gz
freebsd-ports-gnome-adea58e0a3ae9d00d56ea9b2a1a18a6e7650f7fa.tar.zst
freebsd-ports-gnome-adea58e0a3ae9d00d56ea9b2a1a18a6e7650f7fa.zip
ports-mgmt/synth: Yet another release candidate
Unfortunately, there's been a bit too much change since 0.99_6 to confidently release version 1.00, so another release candidate is necessary. Both new features and bug fixes were added. New features: * Provide ability to define environment variables in a profile (/usr/local/etc/synth/<profile>-environment) * Support fetching by proxy using these environment variables * Add zsh and bash completion scripts * Accept port origins with trailing file separators (so people using completion scripts don't have to backtrack to remove them) * In text (non-curses) mode, output the current package build tally every 200 seconds (approximately) Bug fixes: * Fix support for system roots that don't match host (e.g. ARCH, OSRELEASE, OSVERSION, etc * Fix ABI check for system roots that don't match host * Remove effect of system /etc/make.conf (originally seen when MAKE_JOBS_NUMBER was defined there and disabled synth)
Diffstat (limited to 'ports-mgmt/synth')
-rw-r--r--ports-mgmt/synth/Makefile14
-rw-r--r--ports-mgmt/synth/distinfo4
-rw-r--r--ports-mgmt/synth/pkg-plist2
3 files changed, 14 insertions, 6 deletions
diff --git a/ports-mgmt/synth/Makefile b/ports-mgmt/synth/Makefile
index c0ba57801bda..5a8237754cf8 100644
--- a/ports-mgmt/synth/Makefile
+++ b/ports-mgmt/synth/Makefile
@@ -3,8 +3,8 @@
PORTNAME= synth
PORTVERSION= 0.99
-PORTREVISION= 6
DISTVERSIONPREFIX= v
+PORTREVISION= 7
CATEGORIES= ports-mgmt
MAINTAINER= marino@FreeBSD.org
@@ -21,7 +21,7 @@ USES= ada:6 ncurses:port
USE_GITHUB= yes
GH_ACCOUNT= jrmarino
GH_PROJECT= synth_external:bundle
-GH_TAGNAME= v1.3:bundle 4417017
+GH_TAGNAME= v1.3:bundle a8ed62b
# When framework is moved to Ada6, the ada-util and ini-file-manager
# libraries can be used as prebuilt (switch default.gpr url)
@@ -51,12 +51,18 @@ do-build:
-largs build/unix_core.o)
do-install:
+ ${MKDIR} ${STAGEDIR}${PREFIX}/etc/bash_completion.d \
+ ${STAGEDIR}${PREFIX}/share/zsh/site-functions \
+ ${STAGEDIR}/var/log/synth \
+ ${STAGEDIR}/var/synth/live_packages
${INSTALL_PROGRAM} ${WRKSRC}/build/synth \
${STAGEDIR}${PREFIX}/bin
${INSTALL_PROGRAM} ${WRKSRC}/build/synthexec \
${STAGEDIR}${PREFIX}/libexec
${INSTALL_MAN} ${WRKSRC}/synth.1 ${STAGEDIR}${MANPREFIX}/man/man1
- ${MKDIR} ${STAGEDIR}/var/log/synth \
- ${STAGEDIR}/var/synth/live_packages
+ ${INSTALL_SCRIPT} ${WRKSRC}/shell-completers/_synth.bash \
+ ${STAGEDIR}${PREFIX}/etc/bash_completion.d
+ ${INSTALL_DATA} ${WRKSRC}/shell-completers/_synth \
+ ${STAGEDIR}${PREFIX}/share/zsh/site-functions
.include <bsd.port.mk>
diff --git a/ports-mgmt/synth/distinfo b/ports-mgmt/synth/distinfo
index d14cb55170b3..84855f711305 100644
--- a/ports-mgmt/synth/distinfo
+++ b/ports-mgmt/synth/distinfo
@@ -1,4 +1,4 @@
-SHA256 (jrmarino-synth-v0.99-4417017_GH0.tar.gz) = 5cf9c170e5ed17b58eb07b2056a4d6b409507b6a7bf50d4db9878ccd9a69bbe2
-SIZE (jrmarino-synth-v0.99-4417017_GH0.tar.gz) = 86246
+SHA256 (jrmarino-synth-v0.99-a8ed62b_GH0.tar.gz) = eaaf55991c069e4ab2c81da93cdb32de2d901ad3d7b07915f54def1be934f8a1
+SIZE (jrmarino-synth-v0.99-a8ed62b_GH0.tar.gz) = 90469
SHA256 (jrmarino-synth_external-v1.3_GH0.tar.gz) = 2afc03e494d2394446eabdb5244967c202a79b449c7cad7ea67a87807cc25f44
SIZE (jrmarino-synth_external-v1.3_GH0.tar.gz) = 209283
diff --git a/ports-mgmt/synth/pkg-plist b/ports-mgmt/synth/pkg-plist
index 06cd9512e0df..a07058cd01e4 100644
--- a/ports-mgmt/synth/pkg-plist
+++ b/ports-mgmt/synth/pkg-plist
@@ -1,6 +1,8 @@
bin/synth
+etc/bash_completion.d/_synth.bash
libexec/synthexec
man/man1/synth.1.gz
+share/zsh/site-functions/_synth
@dir /var/log/synth
@dir /var/synth
@dir /var/synth/live_packages