aboutsummaryrefslogtreecommitdiffstats
path: root/ports-mgmt
diff options
context:
space:
mode:
authorcrees <crees@FreeBSD.org>2013-09-16 03:03:55 +0800
committercrees <crees@FreeBSD.org>2013-09-16 03:03:55 +0800
commit80fa85c54228e4de5b091a67d60ea9e2dda31b8d (patch)
treec028c160b9df7b1dcc1c65158be9b09539913d36 /ports-mgmt
parent49f3dc24a993364a03a7b29540895c270b2814d9 (diff)
downloadfreebsd-ports-gnome-80fa85c54228e4de5b091a67d60ea9e2dda31b8d.tar.gz
freebsd-ports-gnome-80fa85c54228e4de5b091a67d60ea9e2dda31b8d.tar.zst
freebsd-ports-gnome-80fa85c54228e4de5b091a67d60ea9e2dda31b8d.zip
dialog4ports -- a dialog for FreeBSD ports. This is a static version that
can be used in chroots, for example in Tinderbox. PR: ports/182021 Submitted by: marcus Reviewed by: portmgr (bdrewery) Approved by: maintainer
Diffstat (limited to 'ports-mgmt')
-rw-r--r--ports-mgmt/Makefile1
-rw-r--r--ports-mgmt/dialog4ports-static/Makefile18
-rw-r--r--ports-mgmt/dialog4ports-static/pkg-descr4
-rw-r--r--ports-mgmt/dialog4ports/Makefile11
4 files changed, 29 insertions, 5 deletions
diff --git a/ports-mgmt/Makefile b/ports-mgmt/Makefile
index 1778aea383be..5451ec025fca 100644
--- a/ports-mgmt/Makefile
+++ b/ports-mgmt/Makefile
@@ -8,6 +8,7 @@
SUBDIR += bxpkg
SUBDIR += chucky
SUBDIR += dialog4ports
+ SUBDIR += dialog4ports-static
SUBDIR += distilator
SUBDIR += fastest_sites
SUBDIR += fbsdmon
diff --git a/ports-mgmt/dialog4ports-static/Makefile b/ports-mgmt/dialog4ports-static/Makefile
new file mode 100644
index 000000000000..ddc27f272510
--- /dev/null
+++ b/ports-mgmt/dialog4ports-static/Makefile
@@ -0,0 +1,18 @@
+# $FreeBSD$
+
+PKGNAMESUFFIX= -static
+
+COMMENT= Console Interface to configure ports (static version for chroots)
+
+MASTERDIR= ${.CURDIR}/../dialog4ports
+DESCR= ${.CURDIR}/pkg-descr
+MAKE_ENV+= NO_SHARED=yes
+D4P_SLAVE= yes
+
+PLIST_FILES= bin/dialog4ports-static
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/dialog4ports \
+ ${PREFIX}/bin/dialog4ports-static
+
+.include "${MASTERDIR}/Makefile"
diff --git a/ports-mgmt/dialog4ports-static/pkg-descr b/ports-mgmt/dialog4ports-static/pkg-descr
new file mode 100644
index 000000000000..c50db9076c36
--- /dev/null
+++ b/ports-mgmt/dialog4ports-static/pkg-descr
@@ -0,0 +1,4 @@
+dialog4ports -- a dialog for FreeBSD ports. This is a static version that
+can be used in chroots, for example in Tinderbox.
+
+WWW: https://bitbucket.org/m1cro/d4p/
diff --git a/ports-mgmt/dialog4ports/Makefile b/ports-mgmt/dialog4ports/Makefile
index 69147961a98e..91d1b2979f09 100644
--- a/ports-mgmt/dialog4ports/Makefile
+++ b/ports-mgmt/dialog4ports/Makefile
@@ -3,7 +3,7 @@
PORTNAME= dialog4ports
PORTVERSION= 0.1.5
-PORTREVISION= 1
+PORTREVISION?= 1
CATEGORIES= ports-mgmt
MASTER_SITES= http://m1cro.tk/dialog4ports/ \
http://files.etoilebsd.net/dialog4ports/ \
@@ -14,17 +14,18 @@ MASTER_SITES= http://m1cro.tk/dialog4ports/ \
http://mirror.shatow.net/freebsd/${PORTNAME}/:dialog
MAINTAINER= rum1cro@yandex.ru
-COMMENT= Console Interface to configure ports
+COMMENT?= Console Interface to configure ports
# CCACHE has options, so may need d4p, make d4p not ccache friendly
# to avoid circular dependency
NO_CCACHE= yes
MANCOMPRESSED= yes
-MAN1= ${PORTNAME}.1
MAKE_ENV+= __MAKE_CONF=/dev/null SRCCONF=/dev/null
+.if !defined(D4P_SLAVE)
+MAN1= ${PORTNAME}.1
PLIST_FILES= bin/dialog4ports
-
+.endif
.include <bsd.port.pre.mk>
@@ -36,7 +37,7 @@ MAKE_ARGS+= DEBUG_FLAGS="${DEBUG_FLAGS}"
DIALOG4PORTS= ${WRKSRC}/dialog4ports
.endif
-.if ${OSVERSION} < 900030
+.if ${OSVERSION} < 900030 || defined(D4P_SLAVE)
DISTFILES= ${PORTNAME}-${PORTVERSION}${EXTRACT_SUFX} \
${DIALOGNAME}.tgz:dialog
DIALOGNAME= dialog-1.1-20120706