aboutsummaryrefslogtreecommitdiffstats
path: root/ports-mgmt
diff options
context:
space:
mode:
authormarino <marino@FreeBSD.org>2016-03-28 18:09:41 +0800
committermarino <marino@FreeBSD.org>2016-03-28 18:09:41 +0800
commit279afa1f111218431e109d7f6520360885e73607 (patch)
tree0386226e9a689905b0aa8fb8ec5dd34d90834504 /ports-mgmt
parentbb6f718ec5f817fa2975e6612f1d623c96edafca (diff)
downloadfreebsd-ports-gnome-279afa1f111218431e109d7f6520360885e73607.tar.gz
freebsd-ports-gnome-279afa1f111218431e109d7f6520360885e73607.tar.zst
freebsd-ports-gnome-279afa1f111218431e109d7f6520360885e73607.zip
ports-mgmt/synth: Fix regression
The empty-queue check was supposed to improve pre-fetch behavior, but it negatively affected other use modes, so remove the check for now.
Diffstat (limited to 'ports-mgmt')
-rw-r--r--ports-mgmt/synth/Makefile1
-rw-r--r--ports-mgmt/synth/files/patch-src_portscan-pilot.adb12
2 files changed, 13 insertions, 0 deletions
diff --git a/ports-mgmt/synth/Makefile b/ports-mgmt/synth/Makefile
index 7f2b2da19b47..e5c1b83dd081 100644
--- a/ports-mgmt/synth/Makefile
+++ b/ports-mgmt/synth/Makefile
@@ -4,6 +4,7 @@
PORTNAME= synth
PORTVERSION= 1.33
DISTVERSIONPREFIX= v
+PORTREVISION= 1
CATEGORIES= ports-mgmt
MAINTAINER= marino@FreeBSD.org
diff --git a/ports-mgmt/synth/files/patch-src_portscan-pilot.adb b/ports-mgmt/synth/files/patch-src_portscan-pilot.adb
new file mode 100644
index 000000000000..0eb7fe1e9982
--- /dev/null
+++ b/ports-mgmt/synth/files/patch-src_portscan-pilot.adb
@@ -0,0 +1,12 @@
+--- src/portscan-pilot.adb.orig 2016-03-27 14:03:52 UTC
++++ src/portscan-pilot.adb
+@@ -275,9 +275,6 @@ package body PortScan.Pilot is
+ (repository => JT.USS (PM.configuration.dir_repository),
+ dry_run => dry_run, suppress_remote => block_remote);
+ bld_counter := (OPS.queue_length, 0, 0, 0, 0);
+- if PKG.queue_is_empty then
+- return False;
+- end if;
+ if dry_run then
+ return True;
+ end if;