aboutsummaryrefslogtreecommitdiffstats
path: root/ports-mgmt
diff options
context:
space:
mode:
authorbeat <beat@FreeBSD.org>2013-01-15 06:43:23 +0800
committerbeat <beat@FreeBSD.org>2013-01-15 06:43:23 +0800
commit368ef84b9a4ad15acc758bd390bdb40533883616 (patch)
tree6169fc939366de645e1d533ebdd6b013a9ca4ae4 /ports-mgmt
parent2a43499244d07c3b42c1853c9ab6d32f326c7f49 (diff)
downloadfreebsd-ports-gnome-368ef84b9a4ad15acc758bd390bdb40533883616.tar.gz
freebsd-ports-gnome-368ef84b9a4ad15acc758bd390bdb40533883616.tar.zst
freebsd-ports-gnome-368ef84b9a4ad15acc758bd390bdb40533883616.zip
- Tinderbox 4 uses PDO instead of MDB2 for the WebUI [1]
- Remove replacement of obsolete set_rcvar [1] - Use sqlite3 PHP extension as sqlite is no longer available in PHP 5.4 - Bump PORTREVISION Submitted by: ohauer [1] Approved by: itetcu (maintainer)
Diffstat (limited to 'ports-mgmt')
-rw-r--r--ports-mgmt/tinderbox-devel/Makefile12
1 files changed, 4 insertions, 8 deletions
diff --git a/ports-mgmt/tinderbox-devel/Makefile b/ports-mgmt/tinderbox-devel/Makefile
index 55106ed13132..e702e890aabc 100644
--- a/ports-mgmt/tinderbox-devel/Makefile
+++ b/ports-mgmt/tinderbox-devel/Makefile
@@ -3,6 +3,7 @@
PORTNAME= tinderbox
DISTVERSION= 4.0.0.b2
+PORTREVISION= 1
PORTEPOCH= 1
CATEGORIES= ports-mgmt
MASTER_SITES= http://tinderbox.marcuscom.com/ \
@@ -62,16 +63,14 @@ PLIST_SUB+= WEBUI="@comment "
.if ${PORT_OPTIONS:MPGSQL}
USE_PGSQL= yes
.if defined(WEBUI)
-RUN_DEPENDS+= ${LOCALBASE}/share/pear/MDB2/Driver/pgsql.php:${PORTSDIR}/databases/pear-MDB2_Driver_pgsql
-USE_PHP+= pgsql
+USE_PHP+= pgsql pdo_pgsql
.endif
RUN_DEPENDS+= p5-DBD-Pg>=0:${PORTSDIR}/databases/p5-DBD-Pg
.endif
.if ${PORT_OPTIONS:MMYSQL}
.if defined(WEBUI)
-RUN_DEPENDS+= ${LOCALBASE}/share/pear/MDB2/Driver/mysql.php:${PORTSDIR}/databases/pear-MDB2_Driver_mysql
-USE_PHP+= mysql
+USE_PHP+= mysql pdo_mysql
.endif
USE_MYSQL= yes
RUN_DEPENDS+= p5-DBD-mysql>=0:${PORTSDIR}/databases/p5-DBD-mysql
@@ -79,8 +78,7 @@ RUN_DEPENDS+= p5-DBD-mysql>=0:${PORTSDIR}/databases/p5-DBD-mysql
.if ${PORT_OPTIONS:MSQLITE}
.if defined(WEBUI)
-RUN_DEPENDS+= ${LOCALBASE}/share/pear/MDB2/Driver/sqlite.php:${PORTSDIR}/databases/pear-MDB2_Driver_sqlite
-USE_PHP+= sqlite
+USE_PHP+= sqlite3 pdo_sqlite
.endif
RUN_DEPENDS+= p5-DBD-SQLite>=0:${PORTSDIR}/databases/p5-DBD-SQLite
.endif
@@ -123,8 +121,6 @@ post-patch:
${REINPLACE_CMD} -e 's/^if \[ `id -u` != 0 \]; then/if false; then/' \
${WRKSRC}/tc
.endif
- ${REINPLACE_CMD} -e 's/.set_rcvar./tinderd_enable/' \
- ${WRKSRC}/etc/rc.d/tinderd
@cd ${WRKSRC} && ${FIND} -E . -regex '.*(orig|bak)' -exec ${RM} {} \;
do-install: