aboutsummaryrefslogtreecommitdiffstats
path: root/ports-mgmt
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2012-06-06 14:44:37 +0800
committermiwi <miwi@FreeBSD.org>2012-06-06 14:44:37 +0800
commitbdb01e436951afbc072801302b9a72407299f54a (patch)
tree204231aa3dafe24790c35a32986984cdb94f5cd1 /ports-mgmt
parent6ec4188dabec3cbd63cc23138b8ae1aea5370086 (diff)
downloadfreebsd-ports-gnome-bdb01e436951afbc072801302b9a72407299f54a.tar.gz
freebsd-ports-gnome-bdb01e436951afbc072801302b9a72407299f54a.tar.zst
freebsd-ports-gnome-bdb01e436951afbc072801302b9a72407299f54a.zip
- Convert USE_QT_VER=4 and QT_COMPONETS to USE_QT4
Review by: bapt, David Naylor (kde team)
Diffstat (limited to 'ports-mgmt')
-rw-r--r--ports-mgmt/kpackagekit/Makefile3
-rw-r--r--ports-mgmt/kports-qt4/Makefile3
-rw-r--r--ports-mgmt/packagekit/Makefile3
-rw-r--r--ports-mgmt/portrac/Makefile3
4 files changed, 4 insertions, 8 deletions
diff --git a/ports-mgmt/kpackagekit/Makefile b/ports-mgmt/kpackagekit/Makefile
index 0532860ce501..18cf53b92663 100644
--- a/ports-mgmt/kpackagekit/Makefile
+++ b/ports-mgmt/kpackagekit/Makefile
@@ -23,8 +23,7 @@ USE_BZIP2= yes
USE_GETTEXT= yes
USE_GNOME= pkgconfig
USE_KDE4= automoc4 kdehier kdelibs kdeprefix
-USE_QT_VER= 4
-QT_COMPONENTS= moc_build qmake_build rcc_build uic_build
+USE_QT4= moc_build qmake_build rcc_build uic_build
MAKE_JOBS_SAFE= yes
USE_CMAKE= yes
LDFLAGS+= -L${LOCALBASE}/lib
diff --git a/ports-mgmt/kports-qt4/Makefile b/ports-mgmt/kports-qt4/Makefile
index 6cdf2085b579..b7514fb5873b 100644
--- a/ports-mgmt/kports-qt4/Makefile
+++ b/ports-mgmt/kports-qt4/Makefile
@@ -21,8 +21,7 @@ CONFLICTS= kports-0.[0-7]*
USE_BZIP2= yes
-USE_QT_VER= 4
-QT_COMPONENTS= corelib gui network qmake_build moc_build uic_build rcc_build
+USE_QT4= corelib gui network qmake_build moc_build uic_build rcc_build
QMAKE_ARGS+= PREFIX=${PREFIX}
MAKE_JOBS_SAFE= yes
diff --git a/ports-mgmt/packagekit/Makefile b/ports-mgmt/packagekit/Makefile
index d72ae1364a9a..8d8a9e4f56a8 100644
--- a/ports-mgmt/packagekit/Makefile
+++ b/ports-mgmt/packagekit/Makefile
@@ -90,8 +90,7 @@ LIB_DEPENDS+= packagekit-glib2.14:${PORTSDIR}/ports-mgmt/packagekit
.if ${SLAVEPORT}=="qt4"
CONFIGURE_ARGS+=--enable-qt
LIB_DEPENDS+= cppunit-1.12.1:${PORTSDIR}/devel/cppunit
-USE_QT_VER+= 4
-QT_COMPONENTS+= dbus gui xml sql moc_build
+USE_QT4+= dbus gui xml sql moc_build
.include "${PORTSDIR}/Mk/bsd.qt.mk"
.endif
.else
diff --git a/ports-mgmt/portrac/Makefile b/ports-mgmt/portrac/Makefile
index b5cbb8c7fc34..f37156963ec5 100644
--- a/ports-mgmt/portrac/Makefile
+++ b/ports-mgmt/portrac/Makefile
@@ -26,8 +26,7 @@ PLIST_DIRS= share/portrac
USE_BZIP2= yes
-USE_QT_VER= 4
-QT_COMPONENTS= gui moc_build qmake_build
+USE_QT4= gui moc_build qmake_build
do-configure:
@cd ${WRKDIR}/${DISTNAME} && ${QMAKE} portrac.pro