aboutsummaryrefslogtreecommitdiffstats
path: root/ports-mgmt
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2018-06-25 00:13:06 +0800
committermarcus <marcus@FreeBSD.org>2018-06-25 00:13:06 +0800
commitcb54e36b4124394225b702c6f70e5db3af4f41c0 (patch)
tree72ebdadee12345a6210ef6b125da591958b34d6e /ports-mgmt
parent136445e7ee7acf25d37911afa607b5aae6e1953a (diff)
downloadfreebsd-ports-gnome-cb54e36b4124394225b702c6f70e5db3af4f41c0.tar.gz
freebsd-ports-gnome-cb54e36b4124394225b702c6f70e5db3af4f41c0.tar.zst
freebsd-ports-gnome-cb54e36b4124394225b702c6f70e5db3af4f41c0.zip
Update to 2.18.3.
* Be less strict in the check for MASTER_SITE_SUBDIR use. This change checks that the subdirectory used is actually different than what is defined in MASTER_SITES_SUBDIRS. To make this easier to do, support has been added to single-quote variables passed to the get_makevar* functions. [1] * Now only PY_FLAVOR is recommended as opposed to FLAVOR. [2] * Remove an errant ':' when suggesting PY_FLAVOR. [3] PR: 228227 [1] Requested by: mat [2] Reported by: koobs [3]
Diffstat (limited to 'ports-mgmt')
-rw-r--r--ports-mgmt/portlint/Makefile2
-rw-r--r--ports-mgmt/portlint/src/portlint.pl34
2 files changed, 16 insertions, 20 deletions
diff --git a/ports-mgmt/portlint/Makefile b/ports-mgmt/portlint/Makefile
index 1e2cf4c752da..527162b3ee9f 100644
--- a/ports-mgmt/portlint/Makefile
+++ b/ports-mgmt/portlint/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= portlint
-PORTVERSION= 2.18.2
+PORTVERSION= 2.18.3
CATEGORIES= ports-mgmt
MASTER_SITES= # none
DISTFILES= # none
diff --git a/ports-mgmt/portlint/src/portlint.pl b/ports-mgmt/portlint/src/portlint.pl
index 9c55d01fa1e3..f466fe68c48f 100644
--- a/ports-mgmt/portlint/src/portlint.pl
+++ b/ports-mgmt/portlint/src/portlint.pl
@@ -15,7 +15,7 @@
# was removed.
#
# $FreeBSD$
-# $MCom: portlint/portlint.pl,v 1.463 2018/05/12 22:12:18 jclarke Exp $
+# $MCom: portlint/portlint.pl,v 1.467 2018/06/24 16:07:04 jclarke Exp $
#
use strict;
@@ -50,7 +50,7 @@ $portdir = '.';
# version variables
my $major = 2;
my $minor = 18;
-my $micro = 2;
+my $micro = 3;
# default setting - for FreeBSD
my $portsdir = '/usr/ports';
@@ -1149,18 +1149,9 @@ sub check_depends_syntax {
# check Python flavor
my $bdir = basename($m{'dir'});
if ($bdir =~ /^py-/) {
- if (!defined($makevar{USE_PYTHON}) ||
- $makevar{USE_PYTHON} eq 'noflavors' ||
- $makevar{USE_PYTHON} eq '') {
- if ($m{'fla'} ne '${PY_FLAVOR}') {
- &perror("WARN", $file, -1, "you may want directory for ".
- "dependency $m{'dep'} to be $m{'dir'}:\@\${PY_FLAVOR}");
- }
- } else {
- if ($m{'fla'} ne '${FLAVOR}') {
- &perror("WARN", $file, -1, "you may want directory for ".
- "dependency $m{'dep'} to be $m{'dir'}:\@\${FLAVOR}");
- }
+ if ($m{'fla'} ne '${PY_FLAVOR}') {
+ &perror("WARN", $file, -1, "you may want directory for ".
+ "dependency $m{'dep'} to be $m{'dir'}\@\${PY_FLAVOR}");
}
}
@@ -2767,9 +2758,14 @@ DIST_SUBDIR EXTRACT_ONLY
foreach my $mss (split(/\s+/, $makevar{MASTER_SITES_SUBDIRS})) {
my ($ms, $sd) = split(/:/, $mss);
if ($i =~ /^$ms/ && $i ne $ms) {
- &perror("WARN", $file, -1, "typically when you specify magic site $ms ".
- "you do not need anything else as $sd is assumed");
- $good_ms = 0;
+ my $ip = $i;
+ $ip =~ s/^$ms\///;
+ my $exp_sd = get_makevar($ip);
+ if ($exp_sd eq $sd) {
+ &perror("WARN", $file, -1, "typically when you specify magic site $ms ".
+ "you do not need anything else as $sd is assumed");
+ $good_ms = 0;
+ }
}
}
if ($good_ms) {
@@ -3627,7 +3623,7 @@ EOF
sub get_makevar {
my($cmd, $result);
- $cmd = join(' -V ', "make $makeenv MASTER_SITE_BACKUP=''", @_);
+ $cmd = join(' -V ', "make $makeenv MASTER_SITE_BACKUP=''", map { "'$_'" } @_);
$result = `$cmd`;
chomp $result;
@@ -3642,7 +3638,7 @@ sub get_makevar {
sub get_makevar_raw {
my($cmd, $result);
- $cmd = join(' -XV ', "make $makeenv MASTER_SITE_BACKUP=''", @_);
+ $cmd = join(' -XV ', "make $makeenv MASTER_SITE_BACKUP=''", map { "'$_'" } @_);
$result = `$cmd`;
chomp $result;