aboutsummaryrefslogtreecommitdiffstats
path: root/ports-mgmt
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2016-05-16 00:09:02 +0800
committerbapt <bapt@FreeBSD.org>2016-05-16 00:09:02 +0800
commitd3ad3408664ed0a08a887a9e18fb78ded8cd91f9 (patch)
treef9fc5ce513d06410c5c182afa345a2166c7640b1 /ports-mgmt
parent580bd785f91de90873680227bf5d1d8b10b4af1f (diff)
downloadfreebsd-ports-gnome-d3ad3408664ed0a08a887a9e18fb78ded8cd91f9.tar.gz
freebsd-ports-gnome-d3ad3408664ed0a08a887a9e18fb78ded8cd91f9.tar.zst
freebsd-ports-gnome-d3ad3408664ed0a08a887a9e18fb78ded8cd91f9.zip
Make portlint not yelling at TIMESTAMP in distinfo
PR: 209522 Reported by: John W. O'Brien <john@saltant.com>
Diffstat (limited to 'ports-mgmt')
-rw-r--r--ports-mgmt/portlint/Makefile2
-rw-r--r--ports-mgmt/portlint/src/portlint.pl2
2 files changed, 2 insertions, 2 deletions
diff --git a/ports-mgmt/portlint/Makefile b/ports-mgmt/portlint/Makefile
index 9b70fa1d8905..c13a5faf1978 100644
--- a/ports-mgmt/portlint/Makefile
+++ b/ports-mgmt/portlint/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= portlint
-PORTVERSION= 2.17.0
+PORTVERSION= 2.17.1
CATEGORIES= ports-mgmt
MASTER_SITES= # none
DISTFILES= # none
diff --git a/ports-mgmt/portlint/src/portlint.pl b/ports-mgmt/portlint/src/portlint.pl
index 8076a007a6c6..5b1ab914b063 100644
--- a/ports-mgmt/portlint/src/portlint.pl
+++ b/ports-mgmt/portlint/src/portlint.pl
@@ -398,7 +398,7 @@ sub checkdistinfo {
my ($tag, $path, $value) = ($1, $2, $3);
$records{$path}{$tag} = $value;
- if (!$algorithms{$tag} && $tag ne "SIZE") {
+ if (!$algorithms{$tag} && $tag ne "SIZE" && $tag ne "TIMESTAMP") {
&perror("FATAL", $file, $., "unsupported checksum algorithm ".
"found: $tag.");
}