aboutsummaryrefslogtreecommitdiffstats
path: root/ports-mgmt
diff options
context:
space:
mode:
authorlinimon <linimon@FreeBSD.org>2007-04-05 01:02:02 +0800
committerlinimon <linimon@FreeBSD.org>2007-04-05 01:02:02 +0800
commit6a3be3451937ab2266897f2a2eb910765321db9c (patch)
tree700021460d479d059bc6fe825878f731055ca500 /ports-mgmt
parent0ba15ac466b3b1309307d66e405e85d025a77053 (diff)
downloadfreebsd-ports-gnome-6a3be3451937ab2266897f2a2eb910765321db9c.tar.gz
freebsd-ports-gnome-6a3be3451937ab2266897f2a2eb910765321db9c.tar.zst
freebsd-ports-gnome-6a3be3451937ab2266897f2a2eb910765321db9c.zip
This is a possible fix for the 'makesum' regression introduced in ports/Mk
with the last commit.
Diffstat (limited to 'ports-mgmt')
-rw-r--r--ports-mgmt/portmk/Mk/bsd.port.mk4
1 files changed, 2 insertions, 2 deletions
diff --git a/ports-mgmt/portmk/Mk/bsd.port.mk b/ports-mgmt/portmk/Mk/bsd.port.mk
index 796402aede13..a52264c87709 100644
--- a/ports-mgmt/portmk/Mk/bsd.port.mk
+++ b/ports-mgmt/portmk/Mk/bsd.port.mk
@@ -3468,8 +3468,8 @@ check-vulnerable:
.endif
# set alg to any of SIZE, MD5, SHA256 (or any other checksum algorithm):
-DISTINFO_DATA?= DIR=${DIST_SUBDIR}; ${AWK} -v alg=$$alg \
- -v file=$${DIR:+$$DIR/}$${file\#\#*/} \
+DISTINFO_DATA?= if [ \( -n "${DISABLE_SIZE}" -a -n "${NO_CHECKSUM}" \) -o ! -f "${MD5_FILE}" ]; then exit; fi; \
+ DIR=${DIST_SUBDIR}; ${AWK} -v alg=$$alg -v file=$${DIR:+$$DIR/}$${file\#\#*/} \
'$$1 == alg && $$2 == "(" file ")" {print $$4}' ${MD5_FILE}
# Fetch