aboutsummaryrefslogtreecommitdiffstats
path: root/ports-mgmt
diff options
context:
space:
mode:
authorculot <culot@FreeBSD.org>2016-02-20 22:31:40 +0800
committerculot <culot@FreeBSD.org>2016-02-20 22:31:40 +0800
commit9382ab70cc7da9e78c1776dac0ea08982df978b4 (patch)
tree428b35efbc9a847bf19deab826c83fea1c33f621 /ports-mgmt
parent8281038731528495612e1f6aa2a81af513cd4628 (diff)
downloadfreebsd-ports-gnome-9382ab70cc7da9e78c1776dac0ea08982df978b4.tar.gz
freebsd-ports-gnome-9382ab70cc7da9e78c1776dac0ea08982df978b4.tar.zst
freebsd-ports-gnome-9382ab70cc7da9e78c1776dac0ea08982df978b4.zip
Portal is a front-end to FreeBSD's package manipulation tool pkg(8).
Currently, the application is a MVP (Minimum Viable Product) which provides only the following features: packages listing and searching, installation and deinstallation of packages, and filtering based on the package state. WWW: https://github.com/culot/portal
Diffstat (limited to 'ports-mgmt')
-rw-r--r--ports-mgmt/Makefile1
-rw-r--r--ports-mgmt/portal/Makefile24
-rw-r--r--ports-mgmt/portal/distinfo2
-rw-r--r--ports-mgmt/portal/pkg-descr8
4 files changed, 35 insertions, 0 deletions
diff --git a/ports-mgmt/Makefile b/ports-mgmt/Makefile
index 5bcd51fec5ec..a204605e74ba 100644
--- a/ports-mgmt/Makefile
+++ b/ports-mgmt/Makefile
@@ -40,6 +40,7 @@
SUBDIR += pkgs_which
SUBDIR += port-authoring-tools
SUBDIR += port-maintenance-tools
+ SUBDIR += portal
SUBDIR += portconf
SUBDIR += portdowngrade
SUBDIR += portell
diff --git a/ports-mgmt/portal/Makefile b/ports-mgmt/portal/Makefile
new file mode 100644
index 000000000000..b8f00efa0893
--- /dev/null
+++ b/ports-mgmt/portal/Makefile
@@ -0,0 +1,24 @@
+# $FreeBSD$
+
+PORTNAME= portal
+PORTVERSION= 0.1
+CATEGORIES= ports-mgmt
+MASTER_SITES= GH
+
+MAINTAINER= culot@FreeBSD.org
+COMMENT= Front-end to pkg(8)
+
+LICENSE= BSD2CLAUSE
+
+PLIST_FILES= bin/${PORTNAME} \
+ man/man1/${PORTNAME}.1.gz
+
+USE_GITHUB= yes
+GH_ACCOUNT= culot
+GH_TAGNAME= 0.1
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/${PORTNAME}.1 ${STAGEDIR}${MANPREFIX}/man/man1
+
+.include <bsd.port.mk>
diff --git a/ports-mgmt/portal/distinfo b/ports-mgmt/portal/distinfo
new file mode 100644
index 000000000000..eec8965df911
--- /dev/null
+++ b/ports-mgmt/portal/distinfo
@@ -0,0 +1,2 @@
+SHA256 (culot-portal-0.1_GH0.tar.gz) = 4242824317a1c7b97140e4b34b884df3ca88de8e53cc0217038b152e7f58f99e
+SIZE (culot-portal-0.1_GH0.tar.gz) = 29623
diff --git a/ports-mgmt/portal/pkg-descr b/ports-mgmt/portal/pkg-descr
new file mode 100644
index 000000000000..d2e7a9bac584
--- /dev/null
+++ b/ports-mgmt/portal/pkg-descr
@@ -0,0 +1,8 @@
+Portal is a front-end to FreeBSD's package manipulation tool pkg(8).
+
+Currently, the application is a MVP (Minimum Viable Product) which
+provides only the following features: packages listing and searching,
+installation and deinstallation of packages, and filtering based on
+the package state.
+
+WWW: https://github.com/culot/portal