aboutsummaryrefslogtreecommitdiffstats
path: root/ports-mgmt
diff options
context:
space:
mode:
authorswills <swills@FreeBSD.org>2012-06-25 11:35:16 +0800
committerswills <swills@FreeBSD.org>2012-06-25 11:35:16 +0800
commitabe7c08fdc8219a5eb0b2d2fd8ba5de81cac902e (patch)
treeb1146f313fd1578ba280374ace756d8347ac42c7 /ports-mgmt
parentec8651e09a8cbd5ddcf592828b24841e9a2e1bd7 (diff)
downloadfreebsd-ports-gnome-abe7c08fdc8219a5eb0b2d2fd8ba5de81cac902e.tar.gz
freebsd-ports-gnome-abe7c08fdc8219a5eb0b2d2fd8ba5de81cac902e.tar.zst
freebsd-ports-gnome-abe7c08fdc8219a5eb0b2d2fd8ba5de81cac902e.zip
- Switch this to using ${LOCALBASE} instead of calling pkg_info, which
should allow it to be installed in an all pkgng world.
Diffstat (limited to 'ports-mgmt')
-rw-r--r--ports-mgmt/portdowngrade/Makefile6
1 files changed, 2 insertions, 4 deletions
diff --git a/ports-mgmt/portdowngrade/Makefile b/ports-mgmt/portdowngrade/Makefile
index bda285aab145..aa080dfdeb60 100644
--- a/ports-mgmt/portdowngrade/Makefile
+++ b/ports-mgmt/portdowngrade/Makefile
@@ -16,10 +16,8 @@ COMMENT= Sets a port back to a previous version
LIB_DEPENDS= popt.0:${PORTSDIR}/devel/popt
-POPT_INCLUDE= `pkg_info -xL ^popt | ${GREP} popt.h | ${SED} -e 's?/popt.h??'`
-POPT_LIB= `pkg_info -xL ^popt | ${GREP} libpopt.a | ${SED} -e 's?/libpopt.a??'`
-CONFIGURE_ENV= LIBS="-lpopt -L${POPT_LIB}"
-CPPFLAGS+= -I${POPT_INCLUDE}
+CONFIGURE_ENV= LIBS="-lpopt -L${LOCALBASE}/lib"
+CPPFLAGS+= -I${LOCALBASE}/include
.if defined(DEFAULT_CVS_SERVER)
CONFIGURE_ARGS+= --enable-default-server=${DEFAULT_CVS_SERVER}
.endif